# Restore of snapshot from s3 is failing

**URL:** <https://discuss.elastic.co/t/restore-of-snapshot-from-s3-is-failing/370785>\
**Category:** Elasticsearch\
**Tags:** snapshot-and-restore\
**Created:** [November 19, 2024, 5:58pm UTC](https://discuss.elastic.co/t/restore-of-snapshot-from-s3-is-failing/370785 "2024-11-19T17:58:17Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![mealbert23](https://avatars.discourse-cdn.com/v4/letter/m/53a042/32.png) [@mealbert23](https://discuss.elastic.co/u/mealbert23)\
**Post date:** [November 19, 2024, 5:58pm UTC](https://discuss.elastic.co/t/restore-of-snapshot-from-s3-is-failing/370785/1 "2024-11-19T17:58:17Z")

</div>

Hi,

I have two elasticsearch clusters (prod and dev). I have both clusters pointing to the same s3 back snapshot repo. The snapshots in prod say they are completing without error. However, when I try to restore from the snapshot to the dev cluster I keep getting the error "no\_such\_file\_exception" "blob object [indices/folder/meta-file.dat]" not found. This is on elasticsearch 8.14. This error occurs no matter which snapshot I select. Has anyone seen this issue before? If the snapshot was created successfully I am not sure why it can't restore. Thanks in advance.  
Mark

---

<div class="post-metadata">

**Author:** ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)\
**Post date:** [November 20, 2024, 11:35am UTC](https://discuss.elastic.co/t/restore-of-snapshot-from-s3-is-failing/370785/2 "2024-11-20T11:35:28Z")

</div>

Can you try 8.16.0 instead? This sounds like a bug, but I think 8.16.0 handles it better and should succeed.

---

<div class="post-metadata">

**Author:** ![mealbert23](https://avatars.discourse-cdn.com/v4/letter/m/53a042/32.png) [@mealbert23](https://discuss.elastic.co/u/mealbert23)\
**Post date:** [November 21, 2024, 3:28pm UTC](https://discuss.elastic.co/t/restore-of-snapshot-from-s3-is-failing/370785/3 "2024-11-21T15:28:57Z")

</div>

Hi @DavidTurner ,

Thanks for the quick reply. It turns out I had a OLM rule applied to bucket and I think that deleted some key files. Cleared out that bucket completely, removed the OLM, recreated the repos in elasticsearch and now I can restore. The only issue I am seeing now is sometimes one cluster can see the repo but the other cluster cant. I have to restart all the pods on the cluster that cant access the s3 bucket and then it works. Then the other one cluster loses access. I am trying to use the eks service role of each cluster to access the bucket. That way I don't have to mess with access keys and secrets. Any suggestions on this issue?

Thanks,  
Mark

---

<div class="post-metadata">

**Author:** ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)\
**Post date:** [November 21, 2024, 3:49pm UTC](https://discuss.elastic.co/t/restore-of-snapshot-from-s3-is-failing/370785/4 "2024-11-21T15:49:12Z")

</div>

Those symptoms suggest that you have not set `read_only: true` on the cluster that isn't writing to the repository.
