# Rolling Upgrade from 6.8.0 to 7.3.1 Failed to Join the Cluster

**URL:** <https://discuss.elastic.co/t/rolling-upgrade-from-6-8-0-to-7-3-1-failed-to-join-the-cluster/198604>\
**Category:** Elasticsearch\
**Created:** [September 9, 2019, 5:57am UTC](https://discuss.elastic.co/t/rolling-upgrade-from-6-8-0-to-7-3-1-failed-to-join-the-cluster/198604 "2019-09-09T05:57:07Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Namrata\_Khobragade](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/namrata_khobragade/32/51733_2.png) [@Namrata\_Khobragade](https://discuss.elastic.co/u/Namrata_Khobragade)\
**Post date:** [September 9, 2019, 5:57am UTC](https://discuss.elastic.co/t/rolling-upgrade-from-6-8-0-to-7-3-1-failed-to-join-the-cluster/198604/1 "2019-09-09T05:57:08Z")

</div>

Hello all,  
I am currently having an Elasticsearch 6.8 Cluster with one master and one slave node.  
I need to upgrade this Elasticsearch to current version 7.3.1.  
I am following the Rolling Upgrade Steps given in [https://www.elastic.co/guide/en/elasticsearch/reference/current/rolling-upgrades.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/rolling-upgrades.html)

But after upgrading the Master node, unable to Join it with the Slave node. Getting the following error:  
[2019-09-09T11:16:37,868][INFO][o.e.d.z.ZenDiscovery] [node-2] failed to send join request to master [{node-1}{rhnmAFjARd-OGXRy\_eRiHQ}{GRwn2uehQ7awr6QujUgBYw}{192.168.2.10}{192.168.2.10:9300}{ml.machine\_memory=8438468608, ml.max\_open\_jobs=20, xpack.installed=true}], reason [RemoteTransportException[[node-1][192.168.2.10:9300][internal:discovery/zen/join]]; nested: IllegalStateException[index [.kibana\_1/GXKbMQisTte\_Zswjiks\_xA] version not supported: 7.3.1 the node version is: 6.8.0]; ]

The Rolling Upgrade says that we don't need to Restart the Full Cluster but here I am getting such issue. Can anyone tell me if I am following any wrong approach?

---

<div class="post-metadata">

**Author:** ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)\
**Post date:** [September 9, 2019, 6:06am UTC](https://discuss.elastic.co/t/rolling-upgrade-from-6-8-0-to-7-3-1-failed-to-join-the-cluster/198604/2 "2019-09-09T06:06:38Z")

</div>

> [@Namrata\_Khobragade](#):
>
> Can anyone tell me if I am following any wrong approach?

You only have one master eligible node so you cannot perform a true rolling upgrade: when you shut the master-eligible node down you are effectively fully restarting the cluster. You should follow the instructions for a [full cluster restart upgrade](https://www.elastic.co/guide/en/elasticsearch/reference/current/restart-upgrade.html) instead.

I think the docs could be clearer on this point.

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [September 9, 2019, 6:08am UTC](https://discuss.elastic.co/t/rolling-upgrade-from-6-8-0-to-7-3-1-failed-to-join-the-cluster/198604/3 "2019-09-09T06:08:52Z")

</div>

> [@Namrata\_Khobragade](#):
>
> an Elasticsearch 6.8 Cluster with one master and one slave node

Elasticsearch is a clustered syystem and does not have master and slave nodes. In order to have a highly available system you need at least 3 master-eligible nodes. These can also hold data in order to keep the cluster size down.

---

<div class="post-metadata">

**Author:** ![Namrata\_Khobragade](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/namrata_khobragade/32/51733_2.png) [@Namrata\_Khobragade](https://discuss.elastic.co/u/Namrata_Khobragade)\
**Post date:** [September 9, 2019, 6:09am UTC](https://discuss.elastic.co/t/rolling-upgrade-from-6-8-0-to-7-3-1-failed-to-join-the-cluster/198604/4 "2019-09-09T06:09:40Z")

</div>

Thanks for your quick reply.  
But with the same Master- Slave setup I have successfully upgraded the Cluster from 6.2.4 to 6.8 following Rolling Upgrade instructions given at [https://www.elastic.co/guide/en/elasticsearch/reference/6.2/rolling-upgrades.html](https://www.elastic.co/guide/en/elasticsearch/reference/6.2/rolling-upgrades.html)

---

<div class="post-metadata">

**Author:** ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)\
**Post date:** [September 9, 2019, 6:31am UTC](https://discuss.elastic.co/t/rolling-upgrade-from-6-8-0-to-7-3-1-failed-to-join-the-cluster/198604/5 "2019-09-09T06:31:06Z")

</div>

Yes I think I'd expect that to work from 6.2 to 6.8, although it wasn't a true rolling upgrade since the cluster would have stopped when you shut the master node down. Elasticsearch can be lenient when upgrading to a new minor version, but ithas to be stricter when moving to a new major version.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 7, 2019, 6:31am UTC](https://discuss.elastic.co/t/rolling-upgrade-from-6-8-0-to-7-3-1-failed-to-join-the-cluster/198604/6 "2019-10-07T06:31:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
