# RollingFileAppender Error while starting elasticsearch

**URL:** <https://discuss.elastic.co/t/rollingfileappender-error-while-starting-elasticsearch/100630>\
**Category:** Elasticsearch\
**Created:** [September 15, 2017, 4:04am UTC](https://discuss.elastic.co/t/rollingfileappender-error-while-starting-elasticsearch/100630 "2017-09-15T04:04:33Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![ssasporta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ssasporta/32/13695_2.png) [@ssasporta](https://discuss.elastic.co/u/ssasporta)\
**Post date:** [September 15, 2017, 4:04am UTC](https://discuss.elastic.co/t/rollingfileappender-error-while-starting-elasticsearch/100630/1 "2017-09-15T04:04:34Z")

</div>

I am getting the following error while starting Elasticsearch.

```
Sep 15 10:46:35 cbtbilevtmtr01 elasticsearch: 2017-09-15 10:46:35,367 main ERROR Unable to invoke factory method in class class
 org.apache.logging.log4j.core.appender.RollingFileAppender for element RollingFile. java.lang.IllegalStateException: No factor
y method found for class org.apache.logging.log4j.core.appender.RollingFileAppender

```

**Elasticsearch versin 5.4.1**

**[vpwrk1@cbtbilevtmtr02 ~]$ java -version**  
**java version "1.8.0\_144"**  
**Java(TM) SE Runtime Environment (build 1.8.0\_144-b01)**  
**Java HotSpot(TM) 64-Bit Server VM (build 25.144-b01, mixed mode)**

Any idea?

---

<div class="post-metadata">

**Author:** ![Miguel\_Sagun](https://avatars.discourse-cdn.com/v4/letter/m/bbe5ce/32.png) [@Miguel\_Sagun](https://discuss.elastic.co/u/Miguel_Sagun)\
**Post date:** [September 20, 2017, 3:32am UTC](https://discuss.elastic.co/t/rollingfileappender-error-while-starting-elasticsearch/100630/2 "2017-09-20T03:32:40Z")

</div>

I have the same problem. How did you fix this?

---

<div class="post-metadata">

**Author:** ![ssasporta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ssasporta/32/13695_2.png) [@ssasporta](https://discuss.elastic.co/u/ssasporta)\
**Post date:** [September 21, 2017, 7:06am UTC](https://discuss.elastic.co/t/rollingfileappender-error-while-starting-elasticsearch/100630/3 "2017-09-21T07:06:00Z")

</div>

I found that the problem appears when I tried to edit the following two lines in elasticsearch.yml:

```
path.logs: /var/log/elasticsearch
path.data: /var/log/elasticsearch/data

```

So, Currently I left them as OOB.

Of course that I still need to deal with it as I need to point to my filesytem, where I have the right size of storage.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 19, 2017, 7:06am UTC](https://discuss.elastic.co/t/rollingfileappender-error-while-starting-elasticsearch/100630/4 "2017-10-19T07:06:08Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
