# RPM upgrade from 7.1.1 to 7.5.0 fatal error

**URL:** <https://discuss.elastic.co/t/rpm-upgrade-from-7-1-1-to-7-5-0-fatal-error/210419>\
**Category:** Elasticsearch\
**Created:** [December 3, 2019, 7:05pm UTC](https://discuss.elastic.co/t/rpm-upgrade-from-7-1-1-to-7-5-0-fatal-error/210419 "2019-12-03T19:05:49Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![kdotson](https://avatars.discourse-cdn.com/v4/letter/k/ed655f/32.png) [@kdotson](https://discuss.elastic.co/u/kdotson)\
**Post date:** [December 3, 2019, 7:05pm UTC](https://discuss.elastic.co/t/rpm-upgrade-from-7-1-1-to-7-5-0-fatal-error/210419/1 "2019-12-03T19:05:49Z")

</div>

Hi, I just upgraded my first data node from 7.1.1 to 7.5.0 and the node will not start using "systemctl start elasticsearch". This is a Centos 7.0 OS.

To upgrade I stopped the node with "systemctl stop elasticsearch"  
then ran rpm -U elasticsearch-7.5.0-x86\_64.rpm

ouput from command:

> warning: elasticsearch-7.5.0-x86\_64.rpm: Header V4 RSA/SHA512 Signature, key ID d88e42b4: NOKEY  
> warning: /etc/elasticsearch/jvm.options created as /etc/elasticsearch/jvm.options.rpmnew  
> md5sum: /etc/elasticsearch/.elasticsearch.keystore.initial\_md5sum: No such file or directory

when I first attempted to start, I found this in the journalctl file:

> Exception in thread "main" org.elasticsearch.bootstrap.BootstrapException: java.nio.file.AccessDeniedException: /var/run/elasticsearch

I added the directory and gave it elasticsearh owner.

2nd attempt to start failed with this error (looks like I am missing /usr/lib64/libsystemd.so.0).

```
fatal error in thread [main], exiting
java.lang.ExceptionInInitializerError: null
        at org.elasticsearch.systemd.SystemdPlugin.sd_notify(SystemdPlugin.java:66) ~[?:?]
        at org.elasticsearch.systemd.SystemdPlugin.onNodeStarted(SystemdPlugin.java:74) ~[?:?]
        at java.util.ArrayList.forEach(ArrayList.java:1507) ~[?:?]
        at org.elasticsearch.node.Node.start(Node.java:762) ~[elasticsearch-7.5.0.jar:7.5.0]
        at org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:273) ~[elasticsearch-7.5.0.jar:7.5.0]
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:358) ~[elasticsearch-7.5.0.jar:7.5.0]
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) ~[elasticsearch-7.5.0.jar:7.5.0]
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150) ~[elasticsearch-7.5.0.jar:7.5.0]
        at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-7.5.0.jar:7.5.0]
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:125) ~[elasticsearch-cli-7.5.0.jar:7.5.0]
        at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-7.5.0.jar:7.5.0]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115) ~[elasticsearch-7.5.0.jar:7.5.0]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) ~[elasticsearch-7.5.0.jar:7.5.0]
Caused by: java.security.AccessControlException: access denied ("java.io.FilePermission" "/usr/lib64/libsystemd.so.0" "read")
        at java.security.AccessControlContext.checkPermission(AccessControlContext.java:472) ~[?:?]
        at java.security.AccessController.checkPermission(AccessController.java:1036) ~[?:?]
        at java.lang.SecurityManager.checkPermission(SecurityManager.java:408) ~[?:?]
        at java.lang.SecurityManager.checkRead(SecurityManager.java:747) ~[?:?]
        at java.io.File.exists(File.java:815) ~[?:?]
        at com.sun.jna.NativeLibrary.findLibraryPath(NativeLibrary.java:697) ~[jna-4.5.1.jar:4.5.1 (b0)]
        at com.sun.jna.NativeLibrary.loadLibrary(NativeLibrary.java:202) ~[jna-4.5.1.jar:4.5.1 (b0)]
        at com.sun.jna.NativeLibrary.getInstance(NativeLibrary.java:427) ~[jna-4.5.1.jar:4.5.1 (b0)]
        at com.sun.jna.Native.register(Native.java:1647) ~[jna-4.5.1.jar:4.5.1 (b0)]
        at org.elasticsearch.systemd.Libsystemd.lambda$static$0(Libsystemd.java:34) ~[?:?]
        at java.security.AccessController.doPrivileged(AccessController.java:312) ~[?:?]
        at org.elasticsearch.systemd.Libsystemd.<clinit>(Libsystemd.java:33) ~[?:?]
        ... 13 more 

```

Is there some software requirements I am missing from 7.1.1 to 7.5.0?

---

<div class="post-metadata">

**Author:** ![kdotson](https://avatars.discourse-cdn.com/v4/letter/k/ed655f/32.png) [@kdotson](https://discuss.elastic.co/u/kdotson)\
**Post date:** [December 3, 2019, 7:41pm UTC](https://discuss.elastic.co/t/rpm-upgrade-from-7-1-1-to-7-5-0-fatal-error/210419/2 "2019-12-03T19:41:08Z")

</div>

FYI, I upgraded OS and elasticsearch started.

---

<div class="post-metadata">

**Author:** ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)\
**Post date:** [December 4, 2019, 1:02pm UTC](https://discuss.elastic.co/t/rpm-upgrade-from-7-1-1-to-7-5-0-fatal-error/210419/3 "2019-12-04T13:02:23Z")

</div>

May I ask from what CentOS release to which CentOS you upgraded? Or are you still running 7.0, just upgraded some dependencies?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 1, 2020, 1:02pm UTC](https://discuss.elastic.co/t/rpm-upgrade-from-7-1-1-to-7-5-0-fatal-error/210419/4 "2020-01-01T13:02:35Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
