# Run logstash issue

**URL:** <https://discuss.elastic.co/t/run-logstash-issue/93003>\
**Category:** Logstash\
**Created:** [July 13, 2017, 11:46am UTC](https://discuss.elastic.co/t/run-logstash-issue/93003 "2017-07-13T11:46:02Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![marwa](https://avatars.discourse-cdn.com/v4/letter/m/67e7ee/32.png) [@marwa](https://discuss.elastic.co/u/marwa)\
**Post date:** [July 13, 2017, 11:46am UTC](https://discuss.elastic.co/t/run-logstash-issue/93003/1 "2017-07-13T11:46:02Z")

</div>

I am trying to configure logstash with config file nammed simple.conf after edeting it i tried to run logstash with the following command so i get this error

[cmarwa@vds005 bin]$ cd /home/cmarwa/logstash-5.5.0/bin  
[cmarwa@vds005 bin]$ ./logstash -f simple.conf  
ERROR StatusLogger No log4j2 configuration file found. Using default configuration: logging only errors to the console.  
Sending Logstash's logs to /home/cmarwa/logstash-5.5.0/logs which is now configured via log4j2.properties  
[2017-07-13T12:41:43,805][INFO][logstash.agent] No config files found in path {:path=\>"/home/cmarwa/logstash-5.5.0/bin/simple.conf"}  
[2017-07-13T12:41:43,812][ERROR][logstash.agent] failed to fetch pipeline configuration {:message=\>"No config files found: simple.conf. Can you make sure this path is a logstash config file?"}

Please any help ???

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [July 13, 2017, 2:13pm UTC](https://discuss.elastic.co/t/run-logstash-issue/93003/2 "2017-07-13T14:13:39Z")

</div>

Well, the error message suggests that /home/cmarwa/logstash-5.5.0/bin/simple.conf doesn't exist.

---

<div class="post-metadata">

**Author:** ![marwa](https://avatars.discourse-cdn.com/v4/letter/m/67e7ee/32.png) [@marwa](https://discuss.elastic.co/u/marwa)\
**Post date:** [July 13, 2017, 2:25pm UTC](https://discuss.elastic.co/t/run-logstash-issue/93003/3 "2017-07-13T14:25:22Z")

</div>

I did specify the path of the file simple.conf but the same error still [appear.In](http://appear.In) fact , it is mentionned that the pipeline is created but why the error still appear.I don't know if logs must be saved in log4j2.properties.  
have a look to this  
[cmarwa@vds005 bin]$ ./logstash -f /etc/logstash/conf.d/simple.conf  
ERROR StatusLogger No log4j2 configuration file found. Using default configuration: logging only errors to the console.  
Sending Logstash's logs to /home/cmarwa/logstash-5.5.0/logs which is now configured via log4j2.properties  
[2017-07-13T15:24:30,795][INFO][logstash.outputs.elasticsearch] Elasticsearch pool URLs updated {:changes=\>{:removed=\>[], :added=\>[[http://197.12.8.3:9200/](http://197.12.8.3:9200/)]}}  
[2017-07-13T15:24:30,802][INFO][logstash.outputs.elasticsearch] Running health check to see if an Elasticsearch connection is working {:healthcheck\_url=\>[http://197.12.8.3:9200/](http://197.12.8.3:9200/), :path=\>"/"}  
[2017-07-13T15:24:30,925][WARN][logstash.outputs.elasticsearch] Restored connection to ES instance {:url=\>#Java::JavaNet::URI:0x2b3b291d}  
[2017-07-13T15:24:30,926][INFO][logstash.outputs.elasticsearch] Using mapping template from {:path=\>nil}  
[2017-07-13T15:24:30,991][INFO][logstash.outputs.elasticsearch] Attempting to install template {:manage\_template=\>{"template"=\>"logstash-_", "version"=\>50001, "settings"=\>{"index.refresh\_interval"=\>"5s"}, "mappings"=\>{"default"=\>{"\_all"=\>{"enabled"=\>true, "norms"=\>false}, "dynamic\_templates"=\>[{"message\_field"=\>{"path\_match"=\>"message", "match\_mapping\_type"=\>"string", "mapping"=\>{"type"=\>"text", "norms"=\>false}}}, {"string\_fields"=\>{"match"=\>"_", "match\_mapping\_type"=\>"string", "mapping"=\>{"type"=\>"text", "norms"=\>false, "fields"=\>{"keyword"=\>{"type"=\>"keyword", "ignore\_above"=\>256}}}}}], "properties"=\>{"@timestamp"=\>{"type"=\>"date", "include\_in\_all"=\>false}, "@version"=\>{"type"=\>"keyword", "include\_in\_all"=\>false}, "geoip"=\>{"dynamic"=\>true, "properties"=\>{"ip"=\>{"type"=\>"ip"}, "location"=\>{"type"=\>"geo\_point"}, "latitude"=\>{"type"=\>"half\_float"}, "longitude"=\>{"type"=\>"half\_float"}}}}}}}}  
[2017-07-13T15:24:30,999][INFO][logstash.outputs.elasticsearch] New Elasticsearch output {:class=\>"LogStash::Outputs::ElasticSearch", :hosts=\>[#Java::JavaNet::URI:0x4d318710]}  
[2017-07-13T15:24:31,002][INFO][logstash.pipeline] Starting pipeline {"id"=\>"main", "pipeline.workers"=\>8, "pipeline.batch.size"=\>125, "pipeline.batch.delay"=\>5, "pipeline.max\_inflight"=\>1000}  
[2017-07-13T15:24:31,031][INFO][logstash.pipeline] Pipeline main started  
The stdin plugin is now waiting for input:  
[2017-07-13T15:24:31,103][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
hello  
{  
"@timestamp" =\> 2017-07-13T14:24:40.365Z,  
"@version" =\> "1",  
"host" =\> "[vds005.insightscale.tn](http://vds005.insightscale.tn)",  
"message" =\> "hello "  
}  
i want to understand the cause of the error !!!!!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 10, 2017, 2:25pm UTC](https://discuss.elastic.co/t/run-logstash-issue/93003/4 "2017-08-10T14:25:24Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
