# Running different instance in same 2 nodes

**URL:** <https://discuss.elastic.co/t/running-different-instance-in-same-2-nodes/139971>\
**Category:** Elasticsearch\
**Created:** [July 13, 2018, 3:24pm UTC](https://discuss.elastic.co/t/running-different-instance-in-same-2-nodes/139971 "2018-07-13T15:24:49Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![john\_99](https://avatars.discourse-cdn.com/v4/letter/j/bcef8e/32.png) [@john\_99](https://discuss.elastic.co/u/john_99)\
**Post date:** [July 13, 2018, 3:24pm UTC](https://discuss.elastic.co/t/running-different-instance-in-same-2-nodes/139971/1 "2018-07-13T15:24:50Z")

</div>

Hi,

I am running two instance in same two nodes with 5.0.0 and 6.3. in current 5.0.0 we are using default http port which is 9200 and in the 6.3 i am using custom port number which is 9201 i tried with 9300 but no luck and also i have changed for kibana 5602 ( this is up with no issues).

elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)  
Active: failed (Result: exit-code) since Fri 2018-07-13 11:18:44 EDT; 3s ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 11236 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)  
Main PID: 11236 (code=exited, status=1/FAILURE)

at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:93)  
elasticsearch[11236]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:86)  
elasticsearch[11236]: Caused by: com.fasterxml.jackson.dataformat.yaml.snakeyaml.error.MarkedYAMLException: expected '', but found B...MappingStart  
elasticsearch[11236]: in 'reader', line 59, column 1:  
elasticsearch[11236]: http.port: 9201  
elasticsearch[11236]: ^  
elasticsearch[11236]: at [Source: sun.nio.ch.ChannelInputStream@1e800aaa; line: 59, column: 1]  
elasticsearch[11236]: at com.fasterxml.jackson.dataformat.yaml.snakeyaml.error.MarkedYAMLException.from(MarkedYAMLException.java:27)  
elasticsearch[11236]: at com.fasterxml.jackson.dataformat.yaml.YAMLParser.nextToken(YAMLParser.java:343)  
elasticsearch[11236]: at org.elasticsearch.common.xcontent.json.JsonXContentParser.nextToken(JsonXContentParser.java:53)

please help me out i am missing here ?

Thank you,  
J

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 10, 2018, 3:25pm UTC](https://discuss.elastic.co/t/running-different-instance-in-same-2-nodes/139971/2 "2018-08-10T15:25:05Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
