# Running logstash pipeline is not working

**URL:** <https://discuss.elastic.co/t/running-logstash-pipeline-is-not-working/263394>\
**Category:** Logstash\
**Created:** [February 5, 2021, 1:57pm UTC](https://discuss.elastic.co/t/running-logstash-pipeline-is-not-working/263394 "2021-02-05T13:57:20Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Srinivas\_RK](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/srinivas_rk/32/83303_2.png) [@Srinivas\_RK](https://discuss.elastic.co/u/Srinivas_RK)\
**Post date:** [February 5, 2021, 1:57pm UTC](https://discuss.elastic.co/t/running-logstash-pipeline-is-not-working/263394/1 "2021-02-05T13:57:20Z")

</div>

```
input {
  jdbc {
	id => "my_plugin_id"
    jdbc_connection_string => "jdbc:sqlserver://abc.database.windows.net:1433;databaseName=db;"
    jdbc_driver_library => ""
    jdbc_driver_class => "com.microsoft.sqlserver.jdbc.SQLServerDriver"
    jdbc_user => "admin"
    jdbc_password => "123"
    statement => "SELECT [Id]
      ,[ISBN10]
      ,[ISBN13]
      ,[Title]
      ,[Author]
      ,[Category]
	  .....
      ,[Title] +' '+[Category] +' '+[Author] as full_text
        FROM [BookDetailsMaster]"
  }
}

filter {
  mutate {
    convert => ["suggested_price_new","float"]
	  convert => ["used_very_good_price","float"]
	  convert => ["used_good_price","float"]
  }
}

output {
  elasticsearch {
    hosts => ["https://abc.eastus.cloudapp.azure.com:443"]
    user => "elastic"
    password => "ajsadksdfasdf"
    index => "my_index"
    document_id => "%{id}%"
  }
}

```

this is basic conf file im using jdbc drive  
this works fine when i run

`logstash.bat -f sql_load.conf`

i tried to put in pipelines file to run

```
# Example of two pipelines:
#
 - pipeline.id: banan-elastic-population
   pipeline.workers: 1
   pipeline.batch.size: 1
   path.config: "C:/Elastic/logstash-7.10.2-windows-x86_64/logstash-7.10.2/bin/banan-all.cfg"
# config.string: "input { generator {} } filter { sleep { time => 1 } } output { stdout { codec => dots } }"

```

its giving following error

```
[2021-02-05T17:16:02,637][ERROR][logstash.config.sourceloader] No configuration found in the configured sources.
[2021-02-05T17:16:02,999][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=>9600}
[2021-02-05T17:16:07,937][INFO][logstash.runner] Logstash shut down.
[2021-02-05T17:16:07,957][ERROR][org.logstash.Logstash] java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

```

is my pipeline spec correct? im on win10

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [February 5, 2021, 4:34pm UTC](https://discuss.elastic.co/t/running-logstash-pipeline-is-not-working/263394/2 "2021-02-05T16:34:59Z")

</div>

> [@Srinivas\_RK](#):
>
> `[ERROR][logstash.config.sourceloader] No configuration found in the configured sources.`

It is telling you that it did not find a configuration file in path.config.

---

<div class="post-metadata">

**Author:** ![Srinivas\_RK](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/srinivas_rk/32/83303_2.png) [@Srinivas\_RK](https://discuss.elastic.co/u/Srinivas_RK)\
**Post date:** [February 5, 2021, 4:48pm UTC](https://discuss.elastic.co/t/running-logstash-pipeline-is-not-working/263394/3 "2021-02-05T16:48:01Z")

</div>

i got it but i have mentioned cfg file

`path.config: "C:/Elastic/logstash-7.10.2-windows-x86_64/logstash-7.10.2/bin/banan-all.cfg"`

which works when i run

logstash.bat -f banan-all.cfg

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 5, 2021, 4:48pm UTC](https://discuss.elastic.co/t/running-logstash-pipeline-is-not-working/263394/4 "2021-03-05T16:48:55Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
