# Running problem logstash\_5.0.0\_alpha5 with new configuration file

**URL:** https://discuss.elastic.co/t/running-problem-logstash-5-0-0-alpha5-with-new-configuration-file/60043
**Category:** Logstash
**Created:** [September 8, 2016, 7:16am UTC](https://discuss.elastic.co/t/running-problem-logstash-5-0-0-alpha5-with-new-configuration-file/60043 "2016-09-08T07:16:34Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![abu.sayeed](https://avatars.discourse-cdn.com/v4/letter/a/dec6dc/32.png) [@abu.sayeed](https://discuss.elastic.co/u/abu.sayeed)
#### Post date: [September 8, 2016, 7:16am UTC](https://discuss.elastic.co/t/running-problem-logstash-5-0-0-alpha5-with-new-configuration-file/60043/1 "2016-09-08T07:16:34Z")

</div>

I install Logstash deb file.

MY logstash configuration file like these;

#vim /etc/logstash/conf.d/02-beats-input.conf

input {  
beats {  
port =\> 5044  
ssl =\> true  
ssl\_certificate =\> "/etc/pki/tls/certs/logstash-forwarder.crt"  
ssl\_key =\> "/etc/pki/tls/private/logstash-forwarder.key"  
}  
}

#vim /etc/logstash/conf.d/10-syslog-filter.conf  
filter {  
if [type] == "syslog" {  
grok {  
match =\> { "message" =\> "%{SYSLOGTIMESTAMP:syslog\_timestamp} %{SYSLOGHOST:syslog\_hostname} %{DATA:syslog\_program}(?:[%{POSINT:syslog\_pid}])?: %{GREEDYDATA:syslog\_message}" }  
add\_field =\> ["received\_at", "%{@timestamp}"]  
add\_field =\> ["received\_from", "%{host}"]  
}  
syslog\_pri {}  
date {  
match =\> ["syslog\_timestamp", "MMM d HH:mm:ss", "MMM dd HH:mm:ss"]  
}  
}  
}

#vim /etc/logstash/conf.d/30-elasticsearch-output.conf

output {  
elasticsearch {  
hosts =\> ["localhost:9200"]  
sniffing =\> true  
manage\_template =\> false  
index =\> "%{[@metadata][beat]}-%{+YYYY.MM.dd}"  
document\_type =\> "%{[@metadata][type]}"  
}  
}

I load path.config by this command  
/usr/share/logstash/bin/logstash -f /etc/logstash/conf.d/ --config.test\_and\_exit

configuration ok.

I try to run logstash with my configuration. I use this command

/usr/share/logstash/bin/logstash -f /etc/logstash/conf.d/  
**It shows this error**  
--- jar coordinate com.fasterxml.jackson.core:jackson-annotations already loaded with version 2.7.1 - omit version 2.7.0  
--- jar coordinate com.fasterxml.jackson.core:jackson-databind already loaded with version 2.7.1 - omit version 2.7.1-1  
Sending logstash logs to /var/log/logstash/logstash.log.  
--- jar coordinate com.fasterxml.jackson.core:jackson-core already loaded with version 2.7.1 - omit version 2.7.5  
--- jar coordinate com.fasterxml.jackson.core:jackson-annotations already loaded with version 2.7.1 - omit version 2.7.5  
--- jar coordinate com.fasterxml.jackson.core:jackson-databind already loaded with version 2.7.1 - omit version 2.7.5  
--- jar coordinate com.fasterxml.jackson.module:jackson-module-afterburner already loaded with version 2.7.1 - omit version 2.7.5  
**ERROR StatusLogger No log4j2 configuration file found. Using default configuration: logging only errors to the console.**  
An unexpected error occurred! {:error=\>#\<NoMethodError: undefined method `stop' for nil:NilClass>, :backtrace=>["/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-beats-3.1.0.beta4-java/lib/logstash/inputs/beats.rb:173:in`stop'", "/usr/share/logstash/logstash-core/lib/logstash/inputs/base.rb:88:in `do_stop'", "org/jruby/RubyArray.java:1613:in`each'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:366:in `shutdown'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:252:in`stop\_pipeline'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:261:in `shutdown_pipelines'", "org/jruby/RubyHash.java:1342:in`each'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:261:in `shutdown_pipelines'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:123:in`shutdown'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:237:in `execute'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67:in`run'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:157:in `run'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:132:in`run'", "/usr/share/logstash/lib/bootstrap/environment.rb:66:in `(root)'"], :level=\>:fatal}

for this main pipeline doesn't start.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 4:39am UTC](https://discuss.elastic.co/t/running-problem-logstash-5-0-0-alpha5-with-new-configuration-file/60043/2 "2017-07-06T04:39:23Z")

</div>


