# S\_s\_l\_handshake\_exception error

**URL:** <https://discuss.elastic.co/t/s-s-l-handshake-exception-error/263041>\
**Category:** Logstash\
**Created:** [February 2, 2021, 8:46pm UTC](https://discuss.elastic.co/t/s-s-l-handshake-exception-error/263041 "2021-02-02T20:46:33Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![edster](https://avatars.discourse-cdn.com/v4/letter/e/da6949/32.png) [@edster](https://discuss.elastic.co/u/edster)\
**Post date:** [February 2, 2021, 8:46pm UTC](https://discuss.elastic.co/t/s-s-l-handshake-exception-error/263041/1 "2021-02-02T20:46:33Z")

</div>

I am getting the following error

> {  
> "error" : {  
> "root\_cause" : [  
> {  
> "type" : "s\_s\_l\_handshake\_exception",  
> "reason" : "Received fatal alert: handshake\_failure"  
> }  
> ],  
> "type" : "s\_s\_l\_handshake\_exception",  
> "reason" : "Received fatal alert: handshake\_failure"  
> },  
> "status" : 500  
> }

I have checked and verified all inputs for the following curl reindex call:

> curl -X POST "SERVER/\_reindex?pretty" -H 'Content-Type: application/json' -d"{ "source": { "remote": { "host": "REMOTE\_SERVER", "username": "SERVICE\_ACC", "password": "PW"},"index": "INDEX", "query": { "match\_all": {} } }, "dest": { "index": "INDEX" }}"

The remote servers have been added to the elasticsearch.yml. However, I am not sure if the issue is that the server i am running this call on is an http protocol server and the remote is https so it may have problems. But as you can see in the call i provided the username and password for the remote servers.

Is the issue the http to https connection or what else could be wrong?

---

<div class="post-metadata">

**Author:** ![edster](https://avatars.discourse-cdn.com/v4/letter/e/da6949/32.png) [@edster](https://discuss.elastic.co/u/edster)\
**Post date:** [February 3, 2021, 6:42pm UTC](https://discuss.elastic.co/t/s-s-l-handshake-exception-error/263041/2 "2021-02-03T18:42:52Z")

</div>

So I managed to set both servers to that of an https protocol. Both are secure and on the same domain. But the error still occurs.

---

<div class="post-metadata">

**Author:** ![inhinyera16](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/inhinyera16/32/61625_2.png) [@inhinyera16](https://discuss.elastic.co/u/inhinyera16)\
**Post date:** [February 4, 2021, 2:42am UTC](https://discuss.elastic.co/t/s-s-l-handshake-exception-error/263041/3 "2021-02-04T02:42:57Z")

</div>

Looks like SSL Certificate issue

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 4, 2021, 2:43am UTC](https://discuss.elastic.co/t/s-s-l-handshake-exception-error/263041/4 "2021-03-04T02:43:55Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
