# S3 Input plugin fails to start

**URL:** <https://discuss.elastic.co/t/s3-input-plugin-fails-to-start/74512>\
**Category:** Logstash\
**Created:** [February 9, 2017, 1:51pm UTC](https://discuss.elastic.co/t/s3-input-plugin-fails-to-start/74512 "2017-02-09T13:51:49Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Tonni\_Hult](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tonni_hult/32/11992_2.png) [@Tonni\_Hult](https://discuss.elastic.co/u/Tonni_Hult)\
**Post date:** [February 9, 2017, 1:51pm UTC](https://discuss.elastic.co/t/s3-input-plugin-fails-to-start/74512/1 "2017-02-09T13:51:49Z")

</div>

Hi  
I'm trying to get the S3 input plugin to work but it just fails saying it has an unrecoverable error. Hope that any of you recognize the error and can point me in the right direction because my googling is coming up short.

I've tried to see if it's the S3 policy that is wrong and used [Error: uninitialized constant Aws::Client::Errors](https://discuss.elastic.co/t/error-uninitialized-constant-aws-client-errors/64923/4) as input. But I can download a file via aws cli but the plugin still has errors. I've also tested on 2 different logstash setups, one in a docker container on a EC2 in aws and one locally on a ubuntu host, but got the same error on both setups.

The Logstash version is 5.2.0 and this is my input config

s3 {  
bucket =\> "mybucket"  
access\_key\_id =\> "access\_key"  
secret\_access\_key =\> "secret\_key"  
region =\> "eu-west-1"  
delete =\> false  
interval =\> 60 # seconds  
type =\> "cloudtrail"  
codec =\> "cloudtrail"  
prefix =\> "AWSLogs/accountnr/CloudTrail/"  
#sincedb\_path =\> "/usr/share/logstash/data/cloudtrail\_s3.sincedb"  
}

The error I get is this:

12:51:17.589 [[main]\<s3] ERROR logstash.pipeline - A plugin had an unrecoverable error. Will restart this plugin.  
Plugin: \<LogStash::Inputs::S3 bucket=\>"mybucket", access\_key\_id=\>"access\_key", secret\_access\_key=\>"secret\_key", region=\>"eu-west-1", delete=\>false, interval=\>60, type=\>"cloudtrail", codec=\>\<LogStash::Codecs::Plain id=\>"plain\_588576c4-c58d-4b93-8e30-44e3bbb753c7", enable\_metric=\>true, charset=\>"UTF-8"\>, prefix=\>"AWSLogs/accountnr/CloudTrail/", id=\>"id\_nr", enable\_metric=\>true, temporary\_directory=\>"/tmp/logstash"\>  
Error: execution expired  
Exception: Seahorse::Client::NetworkingError  
Stack: org/jruby/ext/socket/RubyTCPSocket.java:111:in `initialize' org/jruby/RubyIO.java:1197:in`open'  
/usr/share/logstash/vendor/jruby/lib/ruby/1.9/net/http.rb:763:in `connect' org/jruby/ext/timeout/Timeout.java:115:in`timeout'  
/usr/share/logstash/vendor/jruby/lib/ruby/1.9/net/http.rb:763:in `connect' /usr/share/logstash/vendor/jruby/lib/ruby/1.9/net/http.rb:756:in`do\_start'  
/usr/share/logstash/vendor/jruby/lib/ruby/1.9/net/http.rb:751:in `start' /usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/seahorse/client/net_http/connection_pool.rb:281:in`start\_session'  
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/seahorse/client/net\_http/connection\_pool.rb:93:in `session_for' /usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/seahorse/client/net_http/handler.rb:116:in`session'  
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/seahorse/client/net\_http/handler.rb:68:in `transmit' /usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/seahorse/client/net_http/handler.rb:42:in`call'  
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/seahorse/client/plugins/content\_length.rb:12:in `call' /usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/s3_request_signer.rb:88:in`call'  
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/s3\_request\_signer.rb:23:in `call' /usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/xml/error_handler.rb:8:in`call'  
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/s3\_request\_signer.rb:65:in `call' /usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/s3_redirects.rb:15:in`call'  
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/retry\_errors.rb:87:in `call' /usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/retry_errors.rb:118:in`retry\_request'  
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/retry\_errors.rb:101:in `retry_if_possible' /usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/retry_errors.rb:89:in`call'  
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/retry\_errors.rb:118:in `retry_request' /usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/retry_errors.rb:101:in`retry\_if\_possible'  
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/retry\_errors.rb:89:in `call' /usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/retry_errors.rb:118:in`retry\_request'  
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/retry\_errors.rb:101:in `retry_if_possible' /usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/retry_errors.rb:89:in`call'  
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/s3\_accelerate.rb:42:in `call' /usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/s3_md5s.rb:31:in`call'  
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/s3\_expect\_100\_continue.rb:21:in `call' /usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/s3_bucket_name_restrictions.rb:12:in`call'  
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/s3\_bucket\_dns.rb:31:in `call' /usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/rest/handler.rb:7:in`call'  
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/user\_agent.rb:12:in `call' /usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/seahorse/client/plugins/endpoint.rb:41:in`call'  
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/s3\_url\_encoded\_keys.rb:39:in `manage_keys' /usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/s3_url_encoded_keys.rb:31:in`call'  
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/param\_validator.rb:21:in `call' /usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/seahorse/client/plugins/raise_response_errors.rb:14:in`call'  
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/s3\_sse\_cpk.rb:19:in `call' /usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/s3_accelerate.rb:33:in`call'  
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/param\_converter.rb:20:in `call' /usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/response_paging.rb:26:in`call'  
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/seahorse/client/plugins/response\_target.rb:21:in `call'

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 9, 2017, 1:52pm UTC](https://discuss.elastic.co/t/s3-input-plugin-fails-to-start/74512/2 "2017-03-09T13:52:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
