# S3 Input unable to download remote file

**URL:** <https://discuss.elastic.co/t/s3-input-unable-to-download-remote-file/193238>\
**Category:** Logstash\
**Created:** [August 1, 2019, 2:44am UTC](https://discuss.elastic.co/t/s3-input-unable-to-download-remote-file/193238 "2019-08-01T02:44:46Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![placidlife](https://avatars.discourse-cdn.com/v4/letter/p/dbc845/32.png) [@placidlife](https://discuss.elastic.co/u/placidlife)\
**Post date:** [August 1, 2019, 2:44am UTC](https://discuss.elastic.co/t/s3-input-unable-to-download-remote-file/193238/1 "2019-08-01T02:44:46Z")

</div>

Hello,

Currently, I am facing an issue when I am trying to use the S3 input plugin.  
The resulting error is :  
S3 input: Unable to download remote file {:remote\_key=\>"XXXX/XXXX/XXXX/XXXX/XXXX/XXXX/2019-05-15T11:48:15.551061 00:00/1.log", :message=\>"The specified key does not exist."}

This issue only occurs when the key consists of the "+" symbol which seems to be replaced with a space when returned to logstash.  
The key can be found but the file just cannot be downloaded.

Any help or advice?  
Thanks

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 29, 2019, 2:49am UTC](https://discuss.elastic.co/t/s3-input-unable-to-download-remote-file/193238/2 "2019-08-29T02:49:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
