# S3 plugin config in elasticsearch.yml

**URL:** <https://discuss.elastic.co/t/s3-plugin-config-in-elasticsearch-yml/174400>\
**Category:** Elasticsearch\
**Created:** [March 28, 2019, 5:38pm UTC](https://discuss.elastic.co/t/s3-plugin-config-in-elasticsearch-yml/174400 "2019-03-28T17:38:23Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![\_sar](https://avatars.discourse-cdn.com/v4/letter/_/ac8455/32.png) [@\_sar](https://discuss.elastic.co/u/_sar)\
**Post date:** [March 28, 2019, 5:38pm UTC](https://discuss.elastic.co/t/s3-plugin-config-in-elasticsearch-yml/174400/1 "2019-03-28T17:38:23Z")

</div>

Installed Elasticsearch 6.7.0 and the service fails to start with the following error:

> [2019-03-28T15:25:28,350][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [cRr44aA] uncaught exception in thread [main]  
> org.elasticsearch.bootstrap.StartupException: java.lang.IllegalArgumentException: unknown setting [repositories.s3.bucket] please check that any required plugins are installed, or check the breaking changes documentation for removed settings

I verified that the s3 plugin is installed and the config for s3 in the elasticsearch.yml looks like this:

```
repositories:
  s3:
    bucket: <bucket_name>
    region: <region>

```

Any idea why that's failing and what needs to be changed? I have been unable to find documentation on what the elasticsearch.yml file should look like for the s3 plugin. Note that the above config is working in 5.x

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 25, 2019, 5:38pm UTC](https://discuss.elastic.co/t/s3-plugin-config-in-elasticsearch-yml/174400/2 "2019-04-25T17:38:26Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
