# S3-plugin logstash “Exception: Aws::S3::Errors::NotFound plugin had an unrecoverable error. Will restart this plugin

**URL:** <https://discuss.elastic.co/t/s3-plugin-logstash-exception-aws-notfound-plugin-had-an-unrecoverable-error-will-restart-this-plugin/366045>\
**Category:** Logstash\
**Created:** [September 4, 2024, 3:23pm UTC](https://discuss.elastic.co/t/s3-plugin-logstash-exception-aws-notfound-plugin-had-an-unrecoverable-error-will-restart-this-plugin/366045 "2024-09-04T15:23:09Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![vincentm](https://avatars.discourse-cdn.com/v4/letter/v/ba9def/32.png) [@vincentm](https://discuss.elastic.co/u/vincentm)\
**Post date:** [September 4, 2024, 3:23pm UTC](https://discuss.elastic.co/t/s3-plugin-logstash-exception-aws-notfound-plugin-had-an-unrecoverable-error-will-restart-this-plugin/366045/1 "2024-09-04T15:23:09Z")

</div>

Hi all, i have exactly the same error than this topic :

> [@S3-plugin logstash "plugin had an unrecoverable error. Will restart this plugin."](https://discuss.elastic.co/t/s3-plugin-logstash-plugin-had-an-unrecoverable-error-will-restart-this-plugin/156526):
>
> I am using s3-input plugin to process the logs to logstash, I am receiving some logs of logfiles from s3 but not all of them. As far as I know, my configuration is correct because I am receiving some logs but something is blocking in plugin and getting message as "A plugin had an unrecoverable error. Will restart this plugin" Here is the error log, logstash | Plugin: &lt;LogStash::Inputs::S3 bucket=&gt;"Bucket-name", prefix=&gt;"Bucket-name/", backup\_to\_bucket=&gt;"Bucket-name", backup\_ad…

Then i want to have some information about this problem and how to resolve it.  
Because, even if my logstash process restart alone, the problem is that just after the error, my logstash take the file of the next day after the day of the last file before error.  
Example : file of 1of september taken =\> error =\> restart with files of 2 of september.  
Consequences are some files of 1 of septembre are never takken by my logstash process then are missing in elastic cloud.

Then :  
do you have information about this problem ?  
How to resolve ?  
How to set parameters in my logstash for restart continue like normal stop and start

Thank you.
