# Safely repair (remove/add-back) a data node in cluster

**URL:** https://discuss.elastic.co/t/safely-repair-remove-add-back-a-data-node-in-cluster/293272
**Category:** Elasticsearch
**Created:** [January 1, 2022, 7:12am UTC](https://discuss.elastic.co/t/safely-repair-remove-add-back-a-data-node-in-cluster/293272 "2022-01-01T07:12:16Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![David\_Copperfield](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/david_copperfield/32/99260_2.png) [@David\_Copperfield](https://discuss.elastic.co/u/David_Copperfield)
#### Post date: [January 1, 2022, 7:12am UTC](https://discuss.elastic.co/t/safely-repair-remove-add-back-a-data-node-in-cluster/293272/1 "2022-01-01T07:12:17Z")

</div>

we have an Elasticsearch cluster running with a few data nodes. Recently one of the data nodes have some disk issues and we'll fix it.

To preserve indexes, I've excluded the faulty data node out from cluster, with

```auto
curl -XPUT P.P.P.P:9200/_cluster/settings -H 'Content-Type: application/json' -d '{
  "transient" :{
      "cluster.routing.allocation.exclude._ip" : "X.X.X.X"
   }
}';echo

```

refers to the link [How to remove node from elasticsearch cluster on runtime without down time - Stack Overflow](https://stackoverflow.com/questions/17268495/how-to-remove-node-from-elasticsearch-cluster-on-runtime-without-down-time).

The I shutdown the data node, fixed the disk, and power it on.

The problem is that, after the machine is on, it fails to add back into cluster.

Is it because of the above transient excluding setting? I tried similar setting, just replace exclude with include but had no effect.

If there a way to disable/delete the transient setting above, thanks

---

<div class="post-metadata">

### Author: ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)
#### Post date: [January 1, 2022, 5:29pm UTC](https://discuss.elastic.co/t/safely-repair-remove-add-back-a-data-node-in-cluster/293272/2 "2022-01-01T17:29:47Z")

</div>

> [@David\_Copperfield](#):
>
> The problem is that, after the machine is on, it fails to add back into cluster.

This could mean a number of different things but it's hard to help without knowing which it is. What does this mean exactly? Any relevant logs? Errors? API outputs?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 29, 2022, 5:29pm UTC](https://discuss.elastic.co/t/safely-repair-remove-add-back-a-data-node-in-cluster/293272/3 "2022-01-29T17:29:48Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
