# Sample .yml Rackspace

**URL:** <https://discuss.elastic.co/t/sample-yml-rackspace/4773>\
**Category:** Elasticsearch\
**Created:** [July 4, 2011, 8:38pm UTC](https://discuss.elastic.co/t/sample-yml-rackspace/4773 "2011-07-04T20:38:20Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![jp\_lorandi](https://avatars.discourse-cdn.com/v4/letter/j/e480ec/32.png) [@jp\_lorandi](https://discuss.elastic.co/u/jp_lorandi)\
**Post date:** [July 4, 2011, 8:38pm UTC](https://discuss.elastic.co/t/sample-yml-rackspace/4773/1 "2011-07-04T20:38:20Z")

</div>

Hello all, I'm trying to setup (in Rackspace) an ElasticSearch node (with data) as a service (done, works), as well as running a Client Node (not the TransportClient) inside an app server, on the same machine. I have the username and API key for Rackspace. Can somebody point me to a yml that configures disco for Rackspace? I will use the same code when creating the Node inside the app server.

Currently, I've tried to set it up using the example provided by Shay on the blog:[http://www.elasticsearch.org/blog/2010/05/11/here-comes-the-cloud.html](http://www.elasticsearch.org/blog/2010/05/11/here-comes-the-cloud.html)

To no avail -- at startup this is what elasticsearch is outputting based on that yml:

[2011-07-04 20:32:38,414][ERROR][bootstrap] {elasticsearch/0.16.2}: Initialization Failed ...

jvm 1 | - NoClassSettingsException[Failed to load class setting [discovery.type] with value [cloud]]

jvm 1 | ClassNotFoundException[cloud]

wrapper | \<-- Wrapper Stopped

I am using ES 0.16.2

Thanks,JP

---

<div class="post-metadata">

**Author:** ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)\
**Post date:** [July 5, 2011, 10:52am UTC](https://discuss.elastic.co/t/sample-yml-rackspace/4773/2 "2011-07-05T10:52:58Z")

</div>

Heya,

A lot has happened since then, basically the cloud plugin using jclouds has been removed due to stability issues with jclouds, and replaced with a dedicated ec2 plugin. If you want to run on rackspace, you will need to configure a unicast discovery configuration yourself explicitly.

jclouds obviously has come a long way since then, I do plan to revisit and possibly writing a plugin that uses jclouds again, at least to enable simpler discovery on different clouds.

On Monday, July 4, 2011 at 11:38 PM, [jp.lorandi@cfyar.com](mailto:jp.lorandi@cfyar.com) wrote:

> Hello all, I'm trying to setup (in Rackspace) an Elasticsearch node (with data) as a service (done, works), as well as running a Client Node (not the TransportClient) inside an app server, on the same machine. I have the username and API key for Rackspace. Can somebody point me to a yml that configures disco for Rackspace? I will use the same code when creating the Node inside the app server.
> 
> Currently, I've tried to set it up using the example provided by Shay on the blog:  
> [Elasticsearch Platform — Find real-time answers at scale | Elastic](http://www.elasticsearch.org/blog/2010/05/11/here-comes-the-cloud.html)
> 
> To no avail -- at startup this is what elasticsearch is outputting based on that yml:
> 
> [2011-07-04 20:32:38,414][ERROR][bootstrap] {elasticsearch/0.16.2}: Initialization Failed ...  
> jvm 1 | - NoClassSettingsException[Failed to load class setting [discovery.type] with value [cloud]]  
> jvm 1 | ClassNotFoundException[cloud]  
> wrapper | \<-- Wrapper Stopped
> 
> I am using ES 0.16.2
> 
> Thanks,  
> JP

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 4:01am UTC](https://discuss.elastic.co/t/sample-yml-rackspace/4773/3 "2017-07-06T04:01:48Z")

</div>


