# \[savedobjects-service\] Unable to connect to Elasticsearch. Error: Request Timeout after 30000ms

**URL:** <https://discuss.elastic.co/t/savedobjects-service-unable-to-connect-to-elasticsearch-error-request-timeout-after-30000ms/233548>\
**Category:** Kibana\
**Created:** [May 20, 2020, 1:55pm UTC](https://discuss.elastic.co/t/savedobjects-service-unable-to-connect-to-elasticsearch-error-request-timeout-after-30000ms/233548 "2020-05-20T13:55:46Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![jpnorenam](https://avatars.discourse-cdn.com/v4/letter/j/c2a13f/32.png) [@jpnorenam](https://discuss.elastic.co/u/jpnorenam)\
**Post date:** [May 20, 2020, 1:55pm UTC](https://discuss.elastic.co/t/savedobjects-service-unable-to-connect-to-elasticsearch-error-request-timeout-after-30000ms/233548/1 "2020-05-20T13:55:46Z")

</div>

Hi, I'am setting up the new ELK (7.7.0) in `debian/buster64` OS.

And Kibana is unable to connect to ES. The console log:

```auto
log [13:32:01.586] [info][savedobjects-service] Starting saved objects migrations
log [13:32:01.603] [info][savedobjects-service] Creating index .kibana_task_manager_1.
log [13:32:01.605] [info][savedobjects-service] Creating index .kibana_1.
log [13:32:31.606] [warning][savedobjects-service] Unable to connect to Elasticsearch. Error: Request Timeout after 30000ms
log [13:32:34.120] [warning][savedobjects-service] Unable to connect to Elasticsearch. Error: [resource_already_exists_exception] index [.kibana_task_manager_1/Sq62cOeNQbiFGBDoRNaYjA] already exists, with { index_uuid="Sq62cOeNQbiFGBDoRNaYjA" & index=".kibana_task_manager_1" }
log [13:32:34.121] [warning][savedobjects-service] Another Kibana instance appears to be migrating the index. Waiting for that migration to complete. If no other Kibana instance is attempting migrations, you can get past this message by deleting index .kibana_task_manager_1 and restarting Kibana.
log [13:32:34.122] [warning][savedobjects-service] Unable to connect to Elasticsearch. Error: [resource_already_exists_exception] index [.kibana_1/m2zcJV1gSTKUDbfgadBNuA] already exists, with { index_uuid="m2zcJV1gSTKUDbfgadBNuA" & index=".kibana_1" }
log [13:32:34.123] [warning][savedobjects-service] Another Kibana instance appears to be migrating the index. Waiting for that migration to complete. If no other Kibana instance is attempting migrations, you can get past this message by deleting index .kibana_1 and restarting Kibana.

```

I've also tried:

```auto
curl -X PUT http://localhost:9200/_all/_settings -H 'Content-Type: application/json' -d'{ "index.blocks.read_only_allow_delete" : false } }'
{"acknowledged":true}

```

```auto
curl -XDELETE http://localhost:9200/.kibana*
{"acknowledged":true}

```

and restarting but it still doesn't work, shows the same errors.

Also:

```auto
curl http://localhost:9200/_cat/indices/*?v&s=index
health status index uuid pri rep docs.count docs.deleted store.size pri.store.size
red open .apm-custom-link 0iXqzwytR4uLEWTjK_iLOQ 1 1
red open .kibana_task_manager_1 5ZG9AKXLSn2lkfGpy7UqXw 1 1
red open .apm-agent-configuration QS5piFfbRh2ExdO5hzFIOQ 1 1
red open .kibana_1 g_zCF7z7R5aqiJXp1sin8Q 1 1

```

---

<div class="post-metadata">

**Author:** ![rudolf](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rudolf/32/51200_2.png) [@rudolf](https://discuss.elastic.co/u/rudolf)\
**Post date:** [June 16, 2020, 8:23pm UTC](https://discuss.elastic.co/t/savedobjects-service-unable-to-connect-to-elasticsearch-error-request-timeout-after-30000ms/233548/2 "2020-06-16T20:23:50Z")

</div>

Kibana uses two indices for it's "saved objects" `.kibana_n` and `.kibana_task_manager_n` (where n is any positive number).

When multiple Kibana's are started at the same time they will all try to create this index, but some will fail (because the other instance already created that index). If this happens the node will go into a polling loop waiting for the other node to finish the migration.

In your case, it looks like Kibana might have tried to create an index, and that request might have succeeded, but because of the timeout, Kibana didn't know this succeeded. So the node might have fallen back into a polling loop, waiting for another instance to complete it, but there was no other instance busy with the migration.

Deleting all the Kibana indices like you did will allow Kibana to attempt the migration again

```auto
curl -XDELETE http://localhost:9200/.kibana*

```

If the same error happens over and over, it might be that something in your ES cluster is preventing Kibana from creating a new index within 30s. Can you share your ES and Kibana logs after deleting all the `.kibana*` indices?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 14, 2020, 8:23pm UTC](https://discuss.elastic.co/t/savedobjects-service-unable-to-connect-to-elasticsearch-error-request-timeout-after-30000ms/233548/3 "2020-07-14T20:23:57Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
