# Schema error: extra keys not allowed @ data\['actions'\]

**URL:** <https://discuss.elastic.co/t/schema-error-extra-keys-not-allowed-data-actions/102583>\
**Category:** Elasticsearch\
**Created:** [October 3, 2017, 3:01pm UTC](https://discuss.elastic.co/t/schema-error-extra-keys-not-allowed-data-actions/102583 "2017-10-03T15:01:32Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![wgnc](https://avatars.discourse-cdn.com/v4/letter/w/8edcca/32.png) [@wgnc](https://discuss.elastic.co/u/wgnc)\
**Post date:** [October 3, 2017, 3:01pm UTC](https://discuss.elastic.co/t/schema-error-extra-keys-not-allowed-data-actions/102583/1 "2017-10-03T15:01:33Z")

</div>

Hello,

I have problem with basic curator configuration. I'm trying to run delete\_indices example:

> <https://github.com/elastic/curator/blob/master/examples/actions/delete_indices.yml>

  
with no success.  
I run exactly the same code from example mentioned above (saved in .curator/curator.yml)

$ curator\_cli --dry-run delete\_indices  
Schema error: extra keys not allowed @ data['actions']  
Configuration: Client Configuration: Location: full configuration dictionary: Bad Value: "{1: {'action': 'delete\_indices', 'description': 'Delete indices older than 45 days (based on index name), for logstash- prefixed indices. Ignore the error if the filter does not result in an actionable list of indices (ignore\_empty\_list) and exit cleanly.', 'options': {'ignore\_empty\_list': True, 'timeout\_override': None, 'continue\_if\_exception': True, 'disable\_action': False}, 'filters': [{'filtertype': 'pattern', 'kind': 'prefix', 'value': 'logstash-', 'exclude': None}, {'filtertype': 'age', 'source': 'name', 'direction': 'older', 'timestring': '%Y.%m.%d', 'unit': 'days', 'unit\_count': 45, 'exclude': None}]}}", extra keys not allowed @ data['actions']. Check configuration file.

I'm using: curator\_cli, version 5.2.0

Do you have any ideas what is the reason of invalid schema?

---

<div class="post-metadata">

**Author:** ![wgnc](https://avatars.discourse-cdn.com/v4/letter/w/8edcca/32.png) [@wgnc](https://discuss.elastic.co/u/wgnc)\
**Post date:** [October 4, 2017, 7:37am UTC](https://discuss.elastic.co/t/schema-error-extra-keys-not-allowed-data-actions/102583/2 "2017-10-04T07:37:03Z")

</div>

Problem was solved. I tried to define configuration and actions is same file. Structure of .curator directory should be same as in Git repository ./example/\*.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 1, 2017, 7:39am UTC](https://discuss.elastic.co/t/schema-error-extra-keys-not-allowed-data-actions/102583/3 "2017-11-01T07:39:28Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
