# Security Error Kibana

**URL:** https://discuss.elastic.co/t/security-error-kibana/303823
**Category:** Kibana
**Tags:** elastic-stack-security
**Created:** [May 3, 2022, 11:43am UTC](https://discuss.elastic.co/t/security-error-kibana/303823 "2022-05-03T11:43:59Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![S-elk](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/s-elk/32/98464_2.png) [@S-elk](https://discuss.elastic.co/u/S-elk)
#### Post date: [May 3, 2022, 11:43am UTC](https://discuss.elastic.co/t/security-error-kibana/303823/1 "2022-05-03T11:43:59Z")

</div>

Hello !

When I enter a dashboard with my user who has a specific role assigned, the following error appears. I can't find what permission would be needed....

```auto
[object Object]: security_exception: [security_exception] Reason: unable to authenticate user [user1] for REST request [/index/_field_caps?fields=*&ignore_unavailable=true&allow_no_indices=false]

```

my role:

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/3/3/333d7e47445517eacaba26c6e003d200823fd007.png)

thank you in advanced!

---

<div class="post-metadata">

### Author: ![jsanz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jsanz/32/53734_2.png) [@jsanz](https://discuss.elastic.co/u/jsanz)
#### Post date: [May 5, 2022, 4:57pm UTC](https://discuss.elastic.co/t/security-error-kibana/303823/2 "2022-05-05T16:57:55Z")

</div>

You may need to add also `view_index_metadata` to the indices privileges apart from `read`.

---

<div class="post-metadata">

### Author: ![Yang\_Wang](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yang_wang/32/48857_2.png) [@Yang\_Wang](https://discuss.elastic.co/u/Yang_Wang)
#### Post date: [May 6, 2022, 12:33am UTC](https://discuss.elastic.co/t/security-error-kibana/303823/3 "2022-05-06T00:33:19Z")

</div>

This is an authentication error, not authorization. It means the credentials provided for `user1` is incorrect.

---

<div class="post-metadata">

### Author: ![S-elk](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/s-elk/32/98464_2.png) [@S-elk](https://discuss.elastic.co/u/S-elk)
#### Post date: [May 9, 2022, 7:50am UTC](https://discuss.elastic.co/t/security-error-kibana/303823/4 "2022-05-09T07:50:17Z")

</div>

All the permits that appear in the official documentation were granted, including the one you told me about.

---

<div class="post-metadata">

### Author: ![S-elk](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/s-elk/32/98464_2.png) [@S-elk](https://discuss.elastic.co/u/S-elk)
#### Post date: [May 9, 2022, 7:52am UTC](https://discuss.elastic.co/t/security-error-kibana/303823/5 "2022-05-09T07:52:19Z")

</div>

how can this happen?

The index pattern is the union of 2 indices separated by commas and the visualization is what makes the query in which process should the user authenticate? and how can i change the credentials ?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [June 6, 2022, 7:53am UTC](https://discuss.elastic.co/t/security-error-kibana/303823/6 "2022-06-06T07:53:09Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
