# Security\_exception: action \[indices:admin/create\] is unauthorized for user \[elasticsearch\] with effective roles \[superuser\] on restricted indices \[.kibana\_analytics\_8.13.4\_001\], this action is granted by the index privileges \[create\_index,manage,all\]'

**URL:** https://discuss.elastic.co/t/security-exception-action-indices-admin-create-is-unauthorized-for-user-elasticsearch-with-effective-roles-superuser-on-restricted-indices-kibana-analytics-8-13-4-001-this-action-is-granted-by-the-index-privileges-create-index-manage-all/363865
**Category:** Kibana
**Created:** [July 26, 2024, 1:58pm UTC](https://discuss.elastic.co/t/security-exception-action-indices-admin-create-is-unauthorized-for-user-elasticsearch-with-effective-roles-superuser-on-restricted-indices-kibana-analytics-8-13-4-001-this-action-is-granted-by-the-index-privileges-create-index-manage-all/363865 "2024-07-26T13:58:18Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![ppagano91](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ppagano91/32/122745_2.png) [@ppagano91](https://discuss.elastic.co/u/ppagano91)
#### Post date: [July 26, 2024, 1:58pm UTC](https://discuss.elastic.co/t/security-exception-action-indices-admin-create-is-unauthorized-for-user-elasticsearch-with-effective-roles-superuser-on-restricted-indices-kibana-analytics-8-13-4-001-this-action-is-granted-by-the-index-privileges-create-index-manage-all/363865/1 "2024-07-26T13:58:18Z")

</div>

Hi there,

I have been looking at similar topics, but I haven't been able to resolve this error. First of all, I wanted to mention that I faced some problems when I installed Elasticsearch, because the default user "elastic" was not created, so I had to create a new user called "elasticsearch". Now, when I try to start Kibana, I'm getting this error:

```auto
[2024-07-26T10:20:26.714-03:00][ERROR][savedobjects-service] [.kibana] Action failed with 'security_exception
        Root causes:
                security_exception: action [indices:admin/create] is unauthorized for user [elasticsearch] with effective roles [superuser] on restricted indices [.kibana_8.13.4_001], this action is granted by the index privileges [create_index,manage,all]'

```

What can I do to be able to use Kibana?

Thanks!

Patricio

---

<div class="post-metadata">

### Author: ![Musab\_Dogan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/musab_dogan/32/70691_2.png) [@Musab\_Dogan](https://discuss.elastic.co/u/Musab_Dogan)
#### Post date: [July 28, 2024, 10:26pm UTC](https://discuss.elastic.co/t/security-exception-action-indices-admin-create-is-unauthorized-for-user-elasticsearch-with-effective-roles-superuser-on-restricted-indices-kibana-analytics-8-13-4-001-this-action-is-granted-by-the-index-privileges-create-index-manage-all/363865/2 "2024-07-28T22:26:52Z")

</div>

You can't use `elastic` or any user with superuser role in **kibana.yml** on Elasticsearch/Kibana version 8 and onwards. Instead use `kibana_system` user.

```auto
elasticsearch.username: "kibana_system"
elasticsearch.password: "new-test-password"

```

If you don't know the `kibana_system` user password you can use the following command to reset the password.

`bin/elasticsearch-reset-password -u kibana_system -i`

---

<div class="post-metadata">

### Author: ![ppagano91](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ppagano91/32/122745_2.png) [@ppagano91](https://discuss.elastic.co/u/ppagano91)
#### Post date: [August 1, 2024, 2:29pm UTC](https://discuss.elastic.co/t/security-exception-action-indices-admin-create-is-unauthorized-for-user-elasticsearch-with-effective-roles-superuser-on-restricted-indices-kibana-analytics-8-13-4-001-this-action-is-granted-by-the-index-privileges-create-index-manage-all/363865/3 "2024-08-01T14:29:54Z")

</div>

Thank you! That's works, I could solve the issue.
