# Sendgrid supports elk configuration

**URL:** <https://discuss.elastic.co/t/sendgrid-supports-elk-configuration/242024>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-alerting\
**Created:** [July 21, 2020, 12:36pm UTC](https://discuss.elastic.co/t/sendgrid-supports-elk-configuration/242024 "2020-07-21T12:36:15Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![nikhilesh](https://avatars.discourse-cdn.com/v4/letter/n/46a35a/32.png) [@nikhilesh](https://discuss.elastic.co/u/nikhilesh)\
**Post date:** [July 21, 2020, 12:36pm UTC](https://discuss.elastic.co/t/sendgrid-supports-elk-configuration/242024/1 "2020-07-21T12:36:15Z")

</div>

Hi Team,

i am configuring sendgrid mail server in elastic search yml file to create alarms.

but i was getting below errors in logs, can please help on this.

Caused by: javax.mail.AuthenticationFailedException: 451 Authentication failed: Could not authenticate

ES configuration;

xpack.notification.email.account:  
sendgrid\_account:  
profile: sendgrid  
smtp:  
auth: true  
starttls.enable: true  
host: [smtp.sendgrid.com](http://smtp.sendgrid.com)  
port: 587  
user:

and for adding keystore password have executed the below command.

elasticsearch-keystore add xpack.notification.email.account.sendgrid\_account.smtp.secure\_password

Thanks  
Nikhilesh Gade

---

<div class="post-metadata">

**Author:** ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)\
**Post date:** [July 23, 2020, 7:50am UTC](https://discuss.elastic.co/t/sendgrid-supports-elk-configuration/242024/2 "2020-07-23T07:50:21Z")

</div>

Have you added the password to all keystore on all nodes? Did you restart each node?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 20, 2020, 7:50am UTC](https://discuss.elastic.co/t/sendgrid-supports-elk-configuration/242024/3 "2020-08-20T07:50:23Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
