# Sending failed shard

**URL:** <https://discuss.elastic.co/t/sending-failed-shard/16964>\
**Category:** Elasticsearch\
**Created:** [April 11, 2014, 6:14pm UTC](https://discuss.elastic.co/t/sending-failed-shard/16964 "2014-04-11T18:14:44Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![David\_Chamard](https://avatars.discourse-cdn.com/v4/letter/d/ba8739/32.png) [@David\_Chamard](https://discuss.elastic.co/u/David_Chamard)\
**Post date:** [April 11, 2014, 6:14pm UTC](https://discuss.elastic.co/t/sending-failed-shard/16964/1 "2014-04-11T18:14:44Z")

</div>

Hi,

I am currently having an issue that causes data loss with failed shards. At  
first sight it seems related to invalid mappings/parsing.  
Is that possible that a shard will fail to start due to that kind of issues?

There is the Gist:

> <https://gist.github.com/anonymous/d8a692d28a1cf14f961b>

[2014-04-11 18:04:22,166][WARN][cluster.action.shard]  
[elastic09.localdomain] [logstash-2014.04.11][3] sending failed shard for  
[logstash-2014.04.11][3], node[GrR8qRaeQLOKf3jhxvJJzw], [R],  
s[INITIALIZING], indexUUID [xMDsVqv7TwmQAxMq3buWPw], reason [Failed to  
start shard, message [RecoveryFailedException[[logstash-2014.04.11][3]:  
Recovery failed from  
[elastic08.localdomain][-hBCZQqVQ92wn0qTFZXCBQ][inet[/10.0.241.154:9300]]{rack\_id=us-east-1b,  
aws\_availability\_zone=us-east-1b, max\_local\_storage\_nodes=1, master=false}  
into  
[elastic09.localdomain][GrR8qRaeQLOKf3jhxvJJzw][inet[/10.0.241.183:9300]]{rack\_id=us-east-1c,  
aws\_availability\_zone=us-east-1c, max\_local\_storage\_nodes=1,  
master=false}]; nested:  
RemoteTransportException[[elastic08.localdomain][inet[/10.0.241.154:9300]][index/shard/recovery/startRecovery]];  
nested: RecoveryEngineException[[logstash-2014.04.11][3] Phase[2] Execution  
failed]; nested:  
RemoteTransportException[[elastic09.localdomain][inet[/10.0.241.183:9300]][index/shard/recovery/translogOps]];  
nested: MapperParsingException[failed to parse [result]]; nested:  
ElasticSearchIllegalArgumentException[unknown property [total\_rows]]; ]]

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/08ecbd3a-502f-4576-a9d8-8965ebf7d72f%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/08ecbd3a-502f-4576-a9d8-8965ebf7d72f%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)\
**Post date:** [April 21, 2014, 12:20pm UTC](https://discuss.elastic.co/t/sending-failed-shard/16964/2 "2014-04-21T12:20:08Z")

</div>

Hey,

has there a stacktrace been logged below this message? Also the  
elasticsearch version would be interesting..

--Alex

On Fri, Apr 11, 2014 at 8:14 PM, David Chamard [chammmmm@gmail.com](mailto:chammmmm@gmail.com) wrote:

> Hi,
> 
> I am currently having an issue that causes data loss with failed shards.  
> At first sight it seems related to invalid mappings/parsing.  
> Is that possible that a shard will fail to start due to that kind of  
> issues?
> 
> There is the Gist:
> 
> [gist:d8a692d28a1cf14f961b · GitHub](https://gist.github.com/anonymous/d8a692d28a1cf14f961b)
> 
> [2014-04-11 18:04:22,166][WARN][cluster.action.shard]  
> [elastic09.localdomain] [logstash-2014.04.11][3] sending failed shard for  
> [logstash-2014.04.11][3], node[GrR8qRaeQLOKf3jhxvJJzw], [R],  
> s[INITIALIZING], indexUUID [xMDsVqv7TwmQAxMq3buWPw], reason [Failed to  
> start shard, message [RecoveryFailedException[[logstash-2014.04.11][3]:  
> Recovery failed from  
> [elastic08.localdomain][-hBCZQqVQ92wn0qTFZXCBQ][inet[/10.0.241.154:9300]]{rack\_id=us-east-1b,  
> aws\_availability\_zone=us-east-1b, max\_local\_storage\_nodes=1, master=false}  
> into [elastic09.localdomain][GrR8qRaeQLOKf3jhxvJJzw][inet[/10.0.241.183:9300]]{rack\_id=us-east-1c,  
> aws\_availability\_zone=us-east-1c, max\_local\_storage\_nodes=1,  
> master=false}]; nested:  
> RemoteTransportException[[elastic08.localdomain][inet[/10.0.241.154:9300]][index/shard/recovery/startRecovery]];  
> nested: RecoveryEngineException[[logstash-2014.04.11][3] Phase[2] Execution  
> failed]; nested:  
> RemoteTransportException[[elastic09.localdomain][inet[/10.0.241.183:9300]][index/shard/recovery/translogOps]];  
> nested: MapperParsingException[failed to parse [result]]; nested:  
> ElasticSearchIllegalArgumentException[unknown property [total\_rows]]; ]]
> 
> --  
> You received this message because you are subscribed to the Google Groups  
> "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an  
> email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> To view this discussion on the web visit  
> [https://groups.google.com/d/msgid/elasticsearch/08ecbd3a-502f-4576-a9d8-8965ebf7d72f%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/08ecbd3a-502f-4576-a9d8-8965ebf7d72f%40googlegroups.com)[https://groups.google.com/d/msgid/elasticsearch/08ecbd3a-502f-4576-a9d8-8965ebf7d72f%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/08ecbd3a-502f-4576-a9d8-8965ebf7d72f%40googlegroups.com?utm_medium=email&utm_source=footer)  
> .  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/CAGCwEM-JWy2RJOa--pHb6JnXycEK1Pkgb%2B%3D-q8CaOu2P5aVmjg%40mail.gmail.com](https://groups.google.com/d/msgid/elasticsearch/CAGCwEM-JWy2RJOa--pHb6JnXycEK1Pkgb%2B%3D-q8CaOu2P5aVmjg%40mail.gmail.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:34am UTC](https://discuss.elastic.co/t/sending-failed-shard/16964/3 "2017-07-06T01:34:36Z")

</div>


