# Server 2012 R2 some metrics not send

**URL:** <https://discuss.elastic.co/t/server-2012-r2-some-metrics-not-send/51403>\
**Category:** Beats\
**Created:** [May 31, 2016, 9:16am UTC](https://discuss.elastic.co/t/server-2012-r2-some-metrics-not-send/51403 "2016-05-31T09:16:52Z")\
**Posts on this page:** 12\
**Page:** 1

<div class="post-metadata">

**Author:** ![Kevin\_Csuka](https://avatars.discourse-cdn.com/v4/letter/k/7feea3/32.png) [@Kevin\_Csuka](https://discuss.elastic.co/u/Kevin_Csuka)\
**Post date:** [May 31, 2016, 9:16am UTC](https://discuss.elastic.co/t/server-2012-r2-some-metrics-not-send/51403/1 "2016-05-31T09:16:52Z")

</div>

Hi,

I am running a Server 2012 R2, a Virtual Machine hosted by VMware, with Topbeat 1.2.3.  
It sends data to Logstash -\> Elasticsearch. I view the data in Kibana. The metrics are visualized from the most parts. But some data is not send to Logstash, which i'd like to see.

When I look at the log file of TopBeat, with level: debug, i see this error:

`2016-05-31T11:00:13+02:00 DBG Skip process pid=0: error getting process state for pid=0: OpenProcess fails with The parameter is incorrect.
2016-05-31T11:00:13+02:00 DBG Skip process pid=4: error getting process state for pid=4: OpenProcess fails with Access is denied.
2016-05-31T11:00:13+02:00 DBG Windows is interactive: false`

Image of the debug log: [http://imgur.com/LpV5aVE](http://imgur.com/LpV5aVE)

No info in Kibana: [http://imgur.com/Rdty6HM](http://imgur.com/Rdty6HM)  
But some data is: [http://imgur.com/GFHyEyv](http://imgur.com/GFHyEyv)

Is there something I can do to view all information?  
Thanks.

---

<div class="post-metadata">

**Author:** ![andrewkroh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewkroh/32/3784_2.png) [@andrewkroh](https://discuss.elastic.co/u/andrewkroh)\
**Post date:** [May 31, 2016, 10:12am UTC](https://discuss.elastic.co/t/server-2012-r2-some-metrics-not-send/51403/2 "2016-05-31T10:12:18Z")

</div>

> [@Kevin\_Csuka](#):
>
> OpenProcess fails with Access is denied.

What user are you running Topbeat as? In order for Topbeat to be able to read information about all processes it needs to be run as a super user. Try running it as Administrator.

---

<div class="post-metadata">

**Author:** ![Kevin\_Csuka](https://avatars.discourse-cdn.com/v4/letter/k/7feea3/32.png) [@Kevin\_Csuka](https://discuss.elastic.co/u/Kevin_Csuka)\
**Post date:** [May 31, 2016, 10:25am UTC](https://discuss.elastic.co/t/server-2012-r2-some-metrics-not-send/51403/3 "2016-05-31T10:25:09Z")

</div>

I did install and executed as administrator. It made no change.  
The same error remains.

---

<div class="post-metadata">

**Author:** ![andrewkroh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewkroh/32/3784_2.png) [@andrewkroh](https://discuss.elastic.co/u/andrewkroh)\
**Post date:** [June 2, 2016, 9:08pm UTC](https://discuss.elastic.co/t/server-2012-r2-some-metrics-not-send/51403/4 "2016-06-02T21:08:04Z")

</div>

If you find those processes in the task manager, who are they owned by? What are they? I haven't seen this before (when topbeat is run as admin).

---

<div class="post-metadata">

**Author:** ![Kevin\_Csuka](https://avatars.discourse-cdn.com/v4/letter/k/7feea3/32.png) [@Kevin\_Csuka](https://discuss.elastic.co/u/Kevin_Csuka)\
**Post date:** [June 6, 2016, 8:33am UTC](https://discuss.elastic.co/t/server-2012-r2-some-metrics-not-send/51403/5 "2016-06-06T08:33:43Z")

</div>

> [@andrewkroh](#):
>
> before (when topbeat is run as ad

The processes are owned by SYSTEM. Topbeat is also executed as SYSTEM.  
When I open ProcessMonitor, and filter to view only the TopBeat process, I see some information regarding 'name not found' or 'File locked with only readers'.

Images:  
[http://imgur.com/a/YUYG3](http://imgur.com/a/YUYG3)

Is there anything else I can try?

---

<div class="post-metadata">

**Author:** ![Kevin\_Csuka](https://avatars.discourse-cdn.com/v4/letter/k/7feea3/32.png) [@Kevin\_Csuka](https://discuss.elastic.co/u/Kevin_Csuka)\
**Post date:** [June 14, 2016, 1:40pm UTC](https://discuss.elastic.co/t/server-2012-r2-some-metrics-not-send/51403/6 "2016-06-14T13:40:25Z")

</div>

Like nothing?

---

<div class="post-metadata">

**Author:** ![andrewkroh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewkroh/32/3784_2.png) [@andrewkroh](https://discuss.elastic.co/u/andrewkroh)\
**Post date:** [June 16, 2016, 12:33am UTC](https://discuss.elastic.co/t/server-2012-r2-some-metrics-not-send/51403/7 "2016-06-16T00:33:28Z")

</div>

I'm not sure what's causing this. Does the same issue occur if you run Topbeat from a shell (not as a service) as the administrator?

For example:

```auto
PS > .\topbeat.exe -c path\to\config.yml -e -d "*"

```

---

<div class="post-metadata">

**Author:** ![Kevin\_Csuka](https://avatars.discourse-cdn.com/v4/letter/k/7feea3/32.png) [@Kevin\_Csuka](https://discuss.elastic.co/u/Kevin_Csuka)\
**Post date:** [June 16, 2016, 8:17am UTC](https://discuss.elastic.co/t/server-2012-r2-some-metrics-not-send/51403/8 "2016-06-16T08:17:37Z")

</div>

> [@andrewkroh](#):
>
> .\topbeat.exe -c path\to\config.yml -e -d "\*"

Result:  
[http://imgur.com/SUOvJT8](http://imgur.com/SUOvJT8)

---

<div class="post-metadata">

**Author:** ![Kevin\_Csuka](https://avatars.discourse-cdn.com/v4/letter/k/7feea3/32.png) [@Kevin\_Csuka](https://discuss.elastic.co/u/Kevin_Csuka)\
**Post date:** [June 22, 2016, 7:51am UTC](https://discuss.elastic.co/t/server-2012-r2-some-metrics-not-send/51403/9 "2016-06-22T07:51:52Z")

</div>

If you want I could give you access to the server, so you can debug on the server yourself.  
Or do you want me to provide more information?

---

<div class="post-metadata">

**Author:** ![andrewkroh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewkroh/32/3784_2.png) [@andrewkroh](https://discuss.elastic.co/u/andrewkroh)\
**Post date:** [June 22, 2016, 1:33pm UTC](https://discuss.elastic.co/t/server-2012-r2-some-metrics-not-send/51403/10 "2016-06-22T13:33:18Z")

</div>

Could you please open a [issue](https://github.com/elastic/beats/issues/new) on Github in the elastic/beats repo for this. It sounds like multiple people are experiencing the problem.

I want to do a bit more research into the Windows syscalls we are making (like OpenProcess) and see if there is any more debugging information I can add to the software. I didn't write this section of code so I need to familiarize myself with it. I will also check in with the original author to see if she has any insight into the issue.

---

<div class="post-metadata">

**Author:** ![Kevin\_Csuka](https://avatars.discourse-cdn.com/v4/letter/k/7feea3/32.png) [@Kevin\_Csuka](https://discuss.elastic.co/u/Kevin_Csuka)\
**Post date:** [June 22, 2016, 2:08pm UTC](https://discuss.elastic.co/t/server-2012-r2-some-metrics-not-send/51403/11 "2016-06-22T14:08:25Z")

</div>

> [@andrewkroh](#):
>
> so check in with the original author to see if

Allright, thanks for the reply.

The github issue can be found here: [[TopBeat 1.2.3.] Can't access PID, even with correct rights. · Issue #1897 · elastic/beats · GitHub](https://github.com/elastic/beats/issues/1897)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 9:51pm UTC](https://discuss.elastic.co/t/server-2012-r2-some-metrics-not-send/51403/12 "2017-07-05T21:51:06Z")

</div>


