# Server 2016 Logstash 7.7 continually stops and restarts with errors

**URL:** <https://discuss.elastic.co/t/server-2016-logstash-7-7-continually-stops-and-restarts-with-errors/235633>\
**Category:** Logstash\
**Created:** [June 3, 2020, 8:26pm UTC](https://discuss.elastic.co/t/server-2016-logstash-7-7-continually-stops-and-restarts-with-errors/235633 "2020-06-03T20:26:07Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Elkmaster20](https://avatars.discourse-cdn.com/v4/letter/e/8e8cbc/32.png) [@Elkmaster20](https://discuss.elastic.co/u/Elkmaster20)\
**Post date:** [June 3, 2020, 8:26pm UTC](https://discuss.elastic.co/t/server-2016-logstash-7-7-continually-stops-and-restarts-with-errors/235633/1 "2020-06-03T20:26:07Z")

</div>

Here is error in the log file:  
[2020-06-01T00:04:16,445][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"7.7.0"}  
[2020-06-01T00:04:16,986][INFO][logstash.config.source.local.configpathloader] No config files found in path {:path=\>"c:/elk/logstash/bin/config.json"}  
[2020-06-01T00:04:17,032][ERROR][logstash.config.sourceloader] No configuration found in the configured sources.  
[2020-06-01T00:04:17,329][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
[2020-06-01T00:04:17,494][INFO][logstash.runner] Logstash shut down.  
[2020-06-01T00:04:44,651][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified

The messages error messages above continuously repeat and fill up the disk drive at location C:\Windows\Temp\

I'm pretty sure there is a simple fix, but I'm a new ELK user. Help?

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [June 3, 2020, 8:59pm UTC](https://discuss.elastic.co/t/server-2016-logstash-7-7-continually-stops-and-restarts-with-errors/235633/2 "2020-06-03T20:59:18Z")

</div>

> [@Elkmaster20](#):
>
> [logstash.config.source.local.configpathloader] No config files found in path {:path=\>"c:/elk/logstash/bin/config.json"}

You have set path.config (either in logstash.yml or on the command line using -f) to "c:/elk/logstash/bin/config.json". logstash is not finding a configuration in that file, so it shuts down.

---

<div class="post-metadata">

**Author:** ![Elkmaster20](https://avatars.discourse-cdn.com/v4/letter/e/8e8cbc/32.png) [@Elkmaster20](https://discuss.elastic.co/u/Elkmaster20)\
**Post date:** [June 4, 2020, 3:28pm UTC](https://discuss.elastic.co/t/server-2016-logstash-7-7-continually-stops-and-restarts-with-errors/235633/3 "2020-06-04T15:28:42Z")

</div>

I uninstalled and re-installed logstash on Server 2016 DataCenter edition using the NSSM and renamed the sample-logstash.conf file and the argument -f C:\ELK\logstash\config\logstash.conf and renamed the sample logstash.conf file to logstash.conf.

Then Java started tearing up my processor:  
 ![image](https://us1.discourse-cdn.com/elastic/original/3X/b/c/bccb6caa3c48a29639d554bdb1c2e0911415b8bb.png)  
and new jruby folders were created every 15 to 30 seconds filling up the Windows\Temp directory.

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/1/0/1061b224c0d28b7a9c1012bae5e2a4b1b80fd9a7.png)  
and When I stopped the logstash service, my CPU utilization drops to normal.  
The logstash log file repeats the following message:  
`[2020-06-04T06:45:57,178][INFO][logstash.runner] Starting Logstash {"logstash.version"=>"7.7.0"} [2020-06-04T06:45:58,427][ERROR][logstash.agent] Failed to execute action {:action=>LogStash::PipelineAction::Create/pipeline_id:main, :exception=>"LogStash::ConfigurationError", :message=>"Expected one of [\\t\\r\\n], \"#\", \"input\", \"filter\", \"output\" at line 3, column 1 (byte 59) after ", :backtrace=>["C:/ELK/logstash/logstash-core/lib/logstash/compiler.rb:58:in `compile\_imperative'", "C:/ELK/logstash/logstash-core/lib/logstash/compiler.rb:66:in `compile_graph'", "C:/ELK/logstash/logstash-core/lib/logstash/compiler.rb:28:in `block in compile\_sources'", "org/jruby/RubyArray.java:2577:in `map'", "C:/ELK/logstash/logstash-core/lib/logstash/compiler.rb:27:in `compile\_sources'", "org/logstash/execution/AbstractPipelineExt.java:181:in `initialize'", "org/logstash/execution/JavaBasePipelineExt.java:67:in `initialize'", "C:/ELK/logstash/logstash-core/lib/logstash/java\_pipeline.rb:43:in `initialize'", "C:/ELK/logstash/logstash-core/lib/logstash/pipeline_action/create.rb:52:in `execute'", "C:/ELK/logstash/logstash-core/lib/logstash/agent.rb:342:in `block in converge_state'"]} `

Then, I simplified by logstash.conf file to have only two lines:  
`input {  
beats {  
port =\> 5044  
type =\> "log"  
}  
}

output {  
elasticsearch {  
hosts =\> "localhost:9200" `

No more jruby folders filling up the temp drive, processor operating at normal, and no more errors in the log.

Thank you -

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 2, 2020, 3:28pm UTC](https://discuss.elastic.co/t/server-2016-logstash-7-7-continually-stops-and-restarts-with-errors/235633/4 "2020-07-02T15:28:57Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
