# Service Failed to Run: Failed to find metadata for existing index \>\> Failed to bind service \>\> Failed to read or upgrade local state

**URL:** <https://discuss.elastic.co/t/service-failed-to-run-failed-to-find-metadata-for-existing-index-failed-to-bind-service-failed-to-read-or-upgrade-local-state/300836>\
**Category:** Elasticsearch\
**Created:** [March 28, 2022, 11:56am UTC](https://discuss.elastic.co/t/service-failed-to-run-failed-to-find-metadata-for-existing-index-failed-to-bind-service-failed-to-read-or-upgrade-local-state/300836 "2022-03-28T11:56:45Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![tgs.vaibhav](https://avatars.discourse-cdn.com/v4/letter/t/ac8455/32.png) [@tgs.vaibhav](https://discuss.elastic.co/u/tgs.vaibhav)\
**Post date:** [March 28, 2022, 11:56am UTC](https://discuss.elastic.co/t/service-failed-to-run-failed-to-find-metadata-for-existing-index-failed-to-bind-service-failed-to-read-or-upgrade-local-state/300836/1 "2022-03-28T11:56:45Z")

</div>

```auto
[2022-03-28T06:42:22,558][INFO][o.e.x.m.p.l.CppLogMessageHandler] [SYSTNAME] [controller/13524] [Main.cc@110] controller (64 bit): Version 7.3.2 (Build 265429af874fbe) Copyright (c) 2019 Elasticsearch BV
[2022-03-28T06:42:23,480][ERROR][o.e.g.GatewayMetaState] [SYSTNAME] failed to read or upgrade local state, exiting...
java.io.IOException: failed to find metadata for existing index XXXXXXX [location: DHDFHRC3S6-KVZ6naphVcw, generation: 1]
	at org.elasticsearch.gateway.MetaStateService.loadFullState(MetaStateService.java:99) ~[elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.gateway.GatewayMetaState.upgradeMetaData(GatewayMetaState.java:141) [elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.gateway.GatewayMetaState.<init>(GatewayMetaState.java:95) [elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.node.Node.<init>(Node.java:492) [elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.node.Node.<init>(Node.java:258) [elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:221) [elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:221) [elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:349) [elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) [elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150) [elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) [elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) [elasticsearch-cli-7.3.2.jar:7.3.2]
	at org.elasticsearch.cli.Command.main(Command.java:90) [elasticsearch-cli-7.3.2.jar:7.3.2]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115) [elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) [elasticsearch-7.3.2.jar:7.3.2]
[2022-03-28T06:42:23,494][ERROR][o.e.b.Bootstrap] [SYSTNAME] Exception
org.elasticsearch.ElasticsearchException: failed to bind service
	at org.elasticsearch.node.Node.<init>(Node.java:617) ~[elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.node.Node.<init>(Node.java:258) ~[elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:221) ~[elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:221) ~[elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:349) [elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) [elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150) [elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) [elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) [elasticsearch-cli-7.3.2.jar:7.3.2]
	at org.elasticsearch.cli.Command.main(Command.java:90) [elasticsearch-cli-7.3.2.jar:7.3.2]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115) [elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) [elasticsearch-7.3.2.jar:7.3.2]
Caused by: java.io.IOException: failed to find metadata for existing index XXXXXXX [location: DHDFHRC3S6-KVZ6naphVcw, generation: 1]
	at org.elasticsearch.gateway.MetaStateService.loadFullState(MetaStateService.java:99) ~[elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.gateway.GatewayMetaState.upgradeMetaData(GatewayMetaState.java:141) ~[elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.gateway.GatewayMetaState.<init>(GatewayMetaState.java:95) ~[elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.node.Node.<init>(Node.java:492) ~[elasticsearch-7.3.2.jar:7.3.2]
	... 11 more
[2022-03-28T06:42:23,498][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [SYSTNAME] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: ElasticsearchException[failed to bind service]; nested: IOException[failed to find metadata for existing index XXXXXXX [location: DHDFHRC3S6-KVZ6naphVcw, generation: 1]];
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:163) ~[elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150) ~[elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) ~[elasticsearch-cli-7.3.2.jar:7.3.2]
	at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-7.3.2.jar:7.3.2]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115) ~[elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) ~[elasticsearch-7.3.2.jar:7.3.2]
Caused by: org.elasticsearch.ElasticsearchException: failed to bind service
	at org.elasticsearch.node.Node.<init>(Node.java:617) ~[elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.node.Node.<init>(Node.java:258) ~[elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:221) ~[elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:221) ~[elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:349) ~[elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) ~[elasticsearch-7.3.2.jar:7.3.2]
	... 6 more
Caused by: java.io.IOException: failed to find metadata for existing index XXXXXXX [location: DHDFHRC3S6-KVZ6naphVcw, generation: 1]
	at org.elasticsearch.gateway.MetaStateService.loadFullState(MetaStateService.java:99) ~[elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.gateway.GatewayMetaState.upgradeMetaData(GatewayMetaState.java:141) ~[elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.gateway.GatewayMetaState.<init>(GatewayMetaState.java:95) ~[elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.node.Node.<init>(Node.java:492) ~[elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.node.Node.<init>(Node.java:258) ~[elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:221) ~[elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:221) ~[elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:349) ~[elasticsearch-7.3.2.jar:7.3.2]
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) ~[elasticsearch-7.3.2.jar:7.3.2]
	... 6 more

```

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [March 28, 2022, 9:28pm UTC](https://discuss.elastic.co/t/service-failed-to-run-failed-to-find-metadata-for-existing-index-failed-to-bind-service-failed-to-read-or-upgrade-local-state/300836/2 "2022-03-28T21:28:34Z")

</div>

Welcome to our community! 😃  
Unfortunately posting just a log excerpt with no other information on what you are doing and where you are seeing this error isn't likely to get you any assistance.

---

<div class="post-metadata">

**Author:** ![tgs.vaibhav](https://avatars.discourse-cdn.com/v4/letter/t/ac8455/32.png) [@tgs.vaibhav](https://discuss.elastic.co/u/tgs.vaibhav)\
**Post date:** [March 29, 2022, 9:12am UTC](https://discuss.elastic.co/t/service-failed-to-run-failed-to-find-metadata-for-existing-index-failed-to-bind-service-failed-to-read-or-upgrade-local-state/300836/3 "2022-03-29T09:12:54Z")

</div>

While starting Elasticsearch service from "services" it throw above error in logs, I am not able to start service, can you help me on it?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [March 29, 2022, 9:58pm UTC](https://discuss.elastic.co/t/service-failed-to-run-failed-to-find-metadata-for-existing-index-failed-to-bind-service-failed-to-read-or-upgrade-local-state/300836/4 "2022-03-29T21:58:20Z")

</div>

Can you post more of the logs please?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 26, 2022, 9:58pm UTC](https://discuss.elastic.co/t/service-failed-to-run-failed-to-find-metadata-for-existing-index-failed-to-bind-service-failed-to-read-or-upgrade-local-state/300836/5 "2022-04-26T21:58:36Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
