# Service Not Available - License Not Available

**URL:** <https://discuss.elastic.co/t/service-not-available-license-not-available/291169>\
**Category:** Kibana\
**Tags:** docker\
**Created:** [December 8, 2021, 1:49am UTC](https://discuss.elastic.co/t/service-not-available-license-not-available/291169 "2021-12-08T01:49:45Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![blissweb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/blissweb/32/98524_2.png) [@blissweb](https://discuss.elastic.co/u/blissweb)\
**Post date:** [December 8, 2021, 1:49am UTC](https://discuss.elastic.co/t/service-not-available-license-not-available/291169/1 "2021-12-08T01:49:45Z")

</div>

Hi,

Been using the docker version of filebeat, metricbeat, Elasticsearch and kibana.

Has been working fine, but after about 24 hours up, it starts showing the message about no license.

I'm not using Authentication of any kind.

What's the problem ?

Thanks

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [December 8, 2021, 1:52am UTC](https://discuss.elastic.co/t/service-not-available-license-not-available/291169/2 "2021-12-08T01:52:25Z")

</div>

Welcome to our community! 😃

Can you please share your Kibana logs?

---

<div class="post-metadata">

**Author:** ![blissweb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/blissweb/32/98524_2.png) [@blissweb](https://discuss.elastic.co/u/blissweb)\
**Post date:** [December 8, 2021, 2:16am UTC](https://discuss.elastic.co/t/service-not-available-license-not-available/291169/3 "2021-12-08T02:16:38Z")

</div>

Hi,  
Do I have to enable the logs first ?  
After that, where can I find them on a standard docker install ?  
I just restarted everything so they may have got wiped.  
On restart it was complaining about Java Heap size on Elasticsearch so I upped it from 256 to 512.  
Let me know where the logs are. If it happens again I will send them.  
Thanks

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [December 8, 2021, 2:20am UTC](https://discuss.elastic.co/t/service-not-available-license-not-available/291169/4 "2021-12-08T02:20:47Z")

</div>

That's not a lot of heap for Elasticsearch, no. That may be why it failed to run.

---

<div class="post-metadata">

**Author:** ![blissweb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/blissweb/32/98524_2.png) [@blissweb](https://discuss.elastic.co/u/blissweb)\
**Post date:** [December 8, 2021, 2:26am UTC](https://discuss.elastic.co/t/service-not-available-license-not-available/291169/5 "2021-12-08T02:26:53Z")

</div>

Maybe, what is the recommended size ??  
I'm new to this product.  
Anyways, if Kibana was failing to reach Elasticsearch due to it failing, maybe a more useful error message would be required, like ... "Failed to contact Elasticsearch" 😃  
rather than some cryptic License message.  
I will keep monitoring the situation.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [December 8, 2021, 2:29am UTC](https://discuss.elastic.co/t/service-not-available-license-not-available/291169/6 "2021-12-08T02:29:08Z")

</div>

Generally you'd start at 2GB.

And it would have mentioned that at some point prior to the license error.

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [December 8, 2021, 2:30am UTC](https://discuss.elastic.co/t/service-not-available-license-not-available/291169/7 "2021-12-08T02:30:19Z")

</div>

And Don't forget to give docker enough resources.... if you are running on a laptop / desktop etc. ..

---

<div class="post-metadata">

**Author:** ![blissweb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/blissweb/32/98524_2.png) [@blissweb](https://discuss.elastic.co/u/blissweb)\
**Post date:** [December 8, 2021, 2:31am UTC](https://discuss.elastic.co/t/service-not-available-license-not-available/291169/8 "2021-12-08T02:31:12Z")

</div>

Ok, thanks. Good to know.  
I think I must have copied the params from one of the ancient example configs.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 5, 2022, 2:31am UTC](https://discuss.elastic.co/t/service-not-available-license-not-available/291169/9 "2022-01-05T02:31:14Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
