# Service not starting on Windows server 16

**URL:** <https://discuss.elastic.co/t/service-not-starting-on-windows-server-16/193850>\
**Category:** Elasticsearch\
**Created:** [August 5, 2019, 5:18pm UTC](https://discuss.elastic.co/t/service-not-starting-on-windows-server-16/193850 "2019-08-05T17:18:16Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ugen](https://avatars.discourse-cdn.com/v4/letter/u/8491ac/32.png) [@Ugen](https://discuss.elastic.co/u/Ugen)\
**Post date:** [August 5, 2019, 5:18pm UTC](https://discuss.elastic.co/t/service-not-starting-on-windows-server-16/193850/1 "2019-08-05T17:18:16Z")

</div>

```
Hi,
Service won't start : Missing service ImageFile.
Elasticsearch v 7.2

Elastic has been installed and uses its own jdk supplied java. I added JAVA_HOME to point it in 
case the service needs the path.

```

Any ideas?

```
[2019-08-05 09:43:27] [info] [4852] Commons Daemon procrun (1.1.0.0 64-bit) started
[2019-08-05 09:43:27] [info] [4852] Running 'elasticsearch-service-x64' Service...
[2019-08-05 09:43:27] [info] [5540] Starting service...
[2019-08-05 09:43:27] [error] [5540] Missing service ImageFile
[2019-08-05 09:43:27] [error] [5540] The system cannot find the file specified.
[2019-08-05 09:43:27] [error] [5540] ServiceStart returned 1
[2019-08-05 09:43:27] [error] [5540] The system cannot find the file specified.
[2019-08-05 09:43:28] [info] [4852] Run service finished.
[2019-08-05 09:43:28] [info] [4852] Commons Daemon procrun finished
```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 2, 2019, 5:18pm UTC](https://discuss.elastic.co/t/service-not-starting-on-windows-server-16/193850/2 "2019-09-02T17:18:20Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
