# Service wrapper issue

**URL:** <https://discuss.elastic.co/t/service-wrapper-issue/4332>\
**Category:** Elasticsearch\
**Created:** [May 3, 2011, 2:54pm UTC](https://discuss.elastic.co/t/service-wrapper-issue/4332 "2011-05-03T14:54:30Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Tim1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tim1/32/3233_2.png) [@Tim1](https://discuss.elastic.co/u/Tim1)\
**Post date:** [May 3, 2011, 2:54pm UTC](https://discuss.elastic.co/t/service-wrapper-issue/4332/1 "2011-05-03T14:54:30Z")

</div>

I was able to use the service wrapper successfully the other day after  
initial installation. After a reboot, however, it no longer works.

I'm using elasticsearch 0.16.0

OS: Fedora 14

wrapper.log:

ERROR | wrapper | 2011/05/03 08:53:00 | Coding Error. String  
contains invalid string token for queued logging: Unable to write to  
the configured log directory: %s (%s)  
ERROR | wrapper | 2011/05/03 08:53:00 | The directory does not  
exist.  
ERROR | wrapper | 2011/05/03 08:53:00 | Coding Error. String  
contains invalid string token for queued logging: Unable to write to  
the configured log file: %s (%s)  
ERROR | wrapper | 2011/05/03 08:53:00 | Falling back to the  
default file in the current working directory: %s  
STATUS | wrapper | 2011/05/03 08:53:00 | --\> Wrapper Started as  
Daemon  
STATUS | wrapper | 2011/05/03 08:53:00 | Java Service Wrapper  
Community Edition 64-bit 3.5.6  
STATUS | wrapper | 2011/05/03 08:53:00 | Copyright (C) 1999-2010  
Tanuki Software, Ltd. All Rights Reserved.  
STATUS | wrapper | 2011/05/03 08:53:00 | [http://wrapper.tanukisoftware.com](http://wrapper.tanukisoftware.com)  
STATUS | wrapper | 2011/05/03 08:53:00 |  
STATUS | wrapper | 2011/05/03 08:53:00 | Launching a JVM...  
INFO | jvm 1 | 2011/05/03 08:53:02 | WrapperManager:  
Initializing...  
INFO | jvm 1 | 2011/05/03 08:53:02 | {elasticsearch/0.16.0}:  
^[[31mSetup Failed ...^[[0m  
INFO | jvm 1 | 2011/05/03 08:53:02 | -  
ArrayIndexOutOfBoundsException[0]  
STATUS | wrapper | 2011/05/03 08:53:04 | \<-- Wrapper Stopped

Any ideas or other information I should provide?

---

<div class="post-metadata">

**Author:** ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)\
**Post date:** [May 3, 2011, 4:26pm UTC](https://discuss.elastic.co/t/service-wrapper-issue/4332/2 "2011-05-03T16:26:54Z")

</div>

Strange, does elasticsearch starts fine without the service wrapper?  
On Tuesday, May 3, 2011 at 5:54 PM, [tim.ray2005@gmail.com](mailto:tim.ray2005@gmail.com) wrote:

> I was able to use the service wrapper successfully the other day after  
> initial installation. After a reboot, however, it no longer works.
> 
> I'm using elasticsearch 0.16.0
> 
> OS: Fedora 14
> 
> wrapper.log:
> 
> ERROR | wrapper | 2011/05/03 08:53:00 | Coding Error. String  
> contains invalid string token for queued logging: Unable to write to  
> the configured log directory: %s (%s)  
> ERROR | wrapper | 2011/05/03 08:53:00 | The directory does not  
> exist.  
> ERROR | wrapper | 2011/05/03 08:53:00 | Coding Error. String  
> contains invalid string token for queued logging: Unable to write to  
> the configured log file: %s (%s)  
> ERROR | wrapper | 2011/05/03 08:53:00 | Falling back to the  
> default file in the current working directory: %s  
> STATUS | wrapper | 2011/05/03 08:53:00 | --\> Wrapper Started as  
> Daemon  
> STATUS | wrapper | 2011/05/03 08:53:00 | Java Service Wrapper  
> Community Edition 64-bit 3.5.6  
> STATUS | wrapper | 2011/05/03 08:53:00 | Copyright (C) 1999-2010  
> Tanuki Software, Ltd. All Rights Reserved.  
> STATUS | wrapper | 2011/05/03 08:53:00 | [http://wrapper.tanukisoftware.com](http://wrapper.tanukisoftware.com)  
> STATUS | wrapper | 2011/05/03 08:53:00 |  
> STATUS | wrapper | 2011/05/03 08:53:00 | Launching a JVM...  
> INFO | jvm 1 | 2011/05/03 08:53:02 | WrapperManager:  
> Initializing...  
> INFO | jvm 1 | 2011/05/03 08:53:02 | {elasticsearch/0.16.0}:  
> ^[[31mSetup Failed ...^[[0m  
> INFO | jvm 1 | 2011/05/03 08:53:02 | -  
> ArrayIndexOutOfBoundsException[0]  
> STATUS | wrapper | 2011/05/03 08:53:04 | \<-- Wrapper Stopped
> 
> Any ideas or other information I should provide?

---

<div class="post-metadata">

**Author:** ![Tim1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tim1/32/3233_2.png) [@Tim1](https://discuss.elastic.co/u/Tim1)\
**Post date:** [May 3, 2011, 5:04pm UTC](https://discuss.elastic.co/t/service-wrapper-issue/4332/3 "2011-05-03T17:04:58Z")

</div>

Yep - it still works fine running './elasticsearch -f'

On May 3, 11:26 am, Shay Banon [shay.ba...@elasticsearch.com](mailto:shay.ba...@elasticsearch.com) wrote:

> Strange, does elasticsearch starts fine without the service wrapper?
> 
> On Tuesday, May 3, 2011 at 5:54 PM, [tim.ray2...@gmail.com](mailto:tim.ray2...@gmail.com) wrote:
> 
> > I was able to use the service wrapper successfully the other day after  
> > initial installation. After a reboot, however, it no longer works.
> 
> > I'm using elasticsearch 0.16.0
> 
> > OS: Fedora 14
> 
> > wrapper.log:
> 
> > ERROR | wrapper | 2011/05/03 08:53:00 | Coding Error. String  
> > contains invalid string token for queued logging: Unable to write to  
> > the configured log directory: %s (%s)  
> > ERROR | wrapper | 2011/05/03 08:53:00 | The directory does not  
> > exist.  
> > ERROR | wrapper | 2011/05/03 08:53:00 | Coding Error. String  
> > contains invalid string token for queued logging: Unable to write to  
> > the configured log file: %s (%s)  
> > ERROR | wrapper | 2011/05/03 08:53:00 | Falling back to the  
> > default file in the current working directory: %s  
> > STATUS | wrapper | 2011/05/03 08:53:00 | --\> Wrapper Started as  
> > Daemon  
> > STATUS | wrapper | 2011/05/03 08:53:00 | Java Service Wrapper  
> > Community Edition 64-bit 3.5.6  
> > STATUS | wrapper | 2011/05/03 08:53:00 | Copyright (C) 1999-2010  
> > Tanuki Software, Ltd. All Rights Reserved.  
> > STATUS | wrapper | 2011/05/03 08:53:00 |[http://wrapper.tanukisoftware.com](http://wrapper.tanukisoftware.com)  
> > STATUS | wrapper | 2011/05/03 08:53:00 |  
> > STATUS | wrapper | 2011/05/03 08:53:00 | Launching a JVM...  
> > INFO | jvm 1 | 2011/05/03 08:53:02 | WrapperManager:  
> > Initializing...  
> > INFO | jvm 1 | 2011/05/03 08:53:02 | {elasticsearch/0.16.0}:  
> > ^[[31mSetup Failed ...^[[0m  
> > INFO | jvm 1 | 2011/05/03 08:53:02 | -  
> > ArrayIndexOutOfBoundsException[0]  
> > STATUS | wrapper | 2011/05/03 08:53:04 | \<-- Wrapper Stopped
> 
> > Any ideas or other information I should provide?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 4:07am UTC](https://discuss.elastic.co/t/service-wrapper-issue/4332/4 "2017-07-06T04:07:05Z")

</div>


