# Setting server.basepath results in Courier Fetch Error: Authorization Exception

**URL:** <https://discuss.elastic.co/t/setting-server-basepath-results-in-courier-fetch-error-authorization-exception/84768>\
**Category:** Kibana\
**Created:** [May 5, 2017, 6:40pm UTC](https://discuss.elastic.co/t/setting-server-basepath-results-in-courier-fetch-error-authorization-exception/84768 "2017-05-05T18:40:06Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![cwetterman](https://avatars.discourse-cdn.com/v4/letter/c/f4b2a3/32.png) [@cwetterman](https://discuss.elastic.co/u/cwetterman)\
**Post date:** [May 5, 2017, 6:40pm UTC](https://discuss.elastic.co/t/setting-server-basepath-results-in-courier-fetch-error-authorization-exception/84768/1 "2017-05-05T18:40:06Z")

</div>

Kibana 4.6.3  
ES 2.4.1

We have Kibana installed and running fine on multiple Nginx servers. I'm now configuring a load balancer in front of it where we will proxy embedded visualizations from web pages. I was able to configure that successfully as well. The environment we're in requires every URL to be served under a specific root/path, otherwise any resource not served up under that root will be 404'd.

So I modified the server.basePath in kibana.yml to include the required root path so all of Kibana's js/css resources would not be blocked. I also proxied the bundle files on the LB.

After doing that I am now receiving Courier Fetch Error: unhandled courier request error: Authorization Exception.

Does anyone have any thoughts on resolving this? I can provide more info if needed.

Thanks

---

<div class="post-metadata">

**Author:** ![shaunak](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shaunak/32/6643_2.png) [@shaunak](https://discuss.elastic.co/u/shaunak)\
**Post date:** [May 6, 2017, 1:58am UTC](https://discuss.elastic.co/t/setting-server-basepath-results-in-courier-fetch-error-authorization-exception/84768/2 "2017-05-06T01:58:56Z")

</div>

A couple of follow up questions:

Can you share your nginx configuration?

> After doing that I am now receiving Courier Fetch Error: unhandled courier request error: Authorization Exception.

At what point do you get this error?

---

<div class="post-metadata">

**Author:** ![cwetterman](https://avatars.discourse-cdn.com/v4/letter/c/f4b2a3/32.png) [@cwetterman](https://discuss.elastic.co/u/cwetterman)\
**Post date:** [May 6, 2017, 6:00pm UTC](https://discuss.elastic.co/t/setting-server-basepath-results-in-courier-fetch-error-authorization-exception/84768/3 "2017-05-06T18:00:33Z")

</div>

Hi Shaunak,

I fixed the issue by adjusting the server.basePath and nginx config. Basically, all our requests need to be from a specific root (/root) and I made the basePath /root/kibana and in the nginx config used a location block of /root/kibana/. Basically before not all traffic was being routed properly which caused the authorization exception.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 3, 2017, 6:05pm UTC](https://discuss.elastic.co/t/setting-server-basepath-results-in-courier-fetch-error-authorization-exception/84768/4 "2017-06-03T18:05:26Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
