# Setting up three node elasticsearch with security enabled having issues

**URL:** <https://discuss.elastic.co/t/setting-up-three-node-elasticsearch-with-security-enabled-having-issues/242825>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-security\
**Created:** [July 28, 2020, 4:37am UTC](https://discuss.elastic.co/t/setting-up-three-node-elasticsearch-with-security-enabled-having-issues/242825 "2020-07-28T04:37:52Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![abhilashkom](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/abhilashkom/32/53595_2.png) [@abhilashkom](https://discuss.elastic.co/u/abhilashkom)\
**Post date:** [July 28, 2020, 4:37am UTC](https://discuss.elastic.co/t/setting-up-three-node-elasticsearch-with-security-enabled-having-issues/242825/1 "2020-07-28T04:37:52Z")

</div>

I am trying to setup thre node Elasticsearch(three nodes configured as master/data) security xpack enabled. started servers elasticsearch is accepting connections only on localhost:9300 port, discovery is failing. please let me know if any one ran in to similar issues.

[2020-07-28T04:20:09,272][WARN][o.e.c.c.ClusterFormationFailureHelper] [tstnode2] master not discovered yet: have discovered [{efknode2}{RMu6TBFZS0WFJsbRdB3YWg}{uOjclO7pQ5KKp3x8UOkfUg}{localhost}{127.0.0.1:9300}{dilrt}{ml.machine\_memory=3708436480, xpack.installed=true, transform.node=true, ml.max\_open\_jobs=20}]; discovery will continue using [xxxx:9300, xxxxxx:9300, xxxxxx:9300] from hosts providers and from last-known cluster state; node term 0, last-accepted version 0 in term 0  
[2020-07-28T04:20:19,273][WARN][o.e.c.c.ClusterFormationFailureHelper] [tstnode2] master not discovered yet: have discovered [{efknode2}{RMu6TBFZS0WFJsbRdB3YWg}{uOjclO7pQ5KKp3x8UOkfUg}{localhost}{127.0.0.1:9300}{dilrt}{ml.machine\_memory=3708436480, xpack.installed=true, transform.node=true, ml.max\_open\_jobs=20}]; discovery will continue using [xxxx:9300, xxxxxx:9300, xxxxxx:9300] from hosts providers and from last-known cluster state; node term 0, last-accepted version 0 in term 0

settings:  
cluster.name: tstcluster  
node.name: tstnode2  
node.master: true  
node.data: true  
network.host: xx.xx.xx.xx  
http.host: 0.0.0.0  
http.port: 9200  
discovery.seed\_hosts: ["xx.xx.xx.xx", "xx.xx.xx.xx", "xx.xx.xx.xx"]  
cluster.initial\_master\_nodes: ["tstnode1", "tstnode2", "tstnode3"]  
transport.host: localhost (if I remove this parameter failing to start process ([2020-07-28T03:30:58,090][INFO][o.e.b.BootstrapChecks] [efknode1] bound or publishing to a non-loopback address, enforcing bootstrap checks  
ERROR: [2] bootstrap checks failed)  
xpack.security.enabled: true  
xpack.security.transport.ssl.enabled: true  
xpack.security.transport.ssl.verification\_mode: xxx  
xpack.security.transport.ssl.keystore.path: xxx  
xpack.security.transport.ssl.truststore.path: xxx

Thank You.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 25, 2020, 4:49am UTC](https://discuss.elastic.co/t/setting-up-three-node-elasticsearch-with-security-enabled-having-issues/242825/2 "2020-08-25T04:49:08Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
