# Setup Beats error time out

**URL:** https://discuss.elastic.co/t/setup-beats-error-time-out/155389
**Category:** Beats
**Created:** [November 5, 2018, 11:22am UTC](https://discuss.elastic.co/t/setup-beats-error-time-out/155389 "2018-11-05T11:22:23Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![shahid](https://avatars.discourse-cdn.com/v4/letter/s/f07891/32.png) [@shahid](https://discuss.elastic.co/u/shahid)
#### Post date: [November 5, 2018, 11:22am UTC](https://discuss.elastic.co/t/setup-beats-error-time-out/155389/1 "2018-11-05T11:22:23Z")

</div>

Hi Team,  
i am getting the below below when i am tryting to setup the file and meteric beats on my client machines.

sudo metricbeat -e setup  
sudo filebeat -e setup

ERROR instance/beat.go:743 Exiting: Error importing Kibana dashboards: fail to import the dashboards in Kibana: Error importing directory /usr/share/metricbeat/kibana: Failed to import index-pattern: Failed to load directory /usr/share/metricbeat/kibana/6/index-pattern:  
error loading /usr/share/metricbeat/kibana/6/index-pattern/metricbeat.json: returned 400 to import file: . Response: {"statusCode":400,"error":"Bad Request","message":"Request Timeout after 30000ms"

---

<div class="post-metadata">

### Author: ![shaunak](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shaunak/32/6643_2.png) [@shaunak](https://discuss.elastic.co/u/shaunak)
#### Post date: [November 5, 2018, 6:48pm UTC](https://discuss.elastic.co/t/setup-beats-error-time-out/155389/2 "2018-11-05T18:48:54Z")

</div>

Hi @shahid,

I see a request timeout in the error message. Can you check that Kibana is running and accessible from the host that is running Metricbeat?

The easiest way to check this would be to run the following command from the host that is running Metricbeat:

```auto
curl -v http://localhost:5601

```

This assumes that Kibana is running on the same host as Metricbeat, which is the default setting. If your Kibana is actually running on a different host, then some additional configuration will be needed in your `metricbeat.yml` file. See [https://www.elastic.co/guide/en/beats/metricbeat/current/setup-kibana-endpoint.html](https://www.elastic.co/guide/en/beats/metricbeat/current/setup-kibana-endpoint.html).

Hope that helps,

Shaunak

---

<div class="post-metadata">

### Author: ![shahid](https://avatars.discourse-cdn.com/v4/letter/s/f07891/32.png) [@shahid](https://discuss.elastic.co/u/shahid)
#### Post date: [November 6, 2018, 5:29am UTC](https://discuss.elastic.co/t/setup-beats-error-time-out/155389/3 "2018-11-06T05:29:49Z")

</div>

HI @shaunak,  
the above the metric and file beat error was from my client machine. and Kibana is setup on diffrect server (ELK).  
here is curl result from the client machine (server) to Kibana host.  
root@Web:# curl -v [http://172.x.x.x:5601](http://172.x.x.x:5601)

- Rebuilt URL to: [http://172.x.x.x:5601/](http://172.x.x.x:5601/)
- Trying 172.x.x.x...
- Connected to 172.x.x.x (172.x.x.x) port 5601 (#0)

> GET / HTTP/1.1  
> Host: 172.x.x.x:5601  
> User-Agent: curl/7.47.0  
> Accept: _/_

\< HTTP/1.1 200 OK  
\< kbn-name: kibana  
\< cache-control: no-cache  
\< content-type: text/html; charset=utf-8  
\< content-length: 217  
\< accept-ranges: bytes  
\< Date: Tue, 06 Nov 2018 05:25:41 GMT  
\< Connection: keep-alive  
\<

var hashRoute = '/app/kibana'; var defaultRoute = '/app/kibana'; var hash = window.location.hash; if (hash.length) { window.location = hashRoute + hash; } else { window.location = defaultRoute; \* Connection #0 to host 172.x.x.x left intact

---

<div class="post-metadata">

### Author: ![shaunak](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shaunak/32/6643_2.png) [@shaunak](https://discuss.elastic.co/u/shaunak)
#### Post date: [November 6, 2018, 3:23pm UTC](https://discuss.elastic.co/t/setup-beats-error-time-out/155389/4 "2018-11-06T15:23:46Z")

</div>

Thanks, looks like Kibana is reachable from the machine (`Web`) that is running Metricbeat, which is great.

Next, can you share your `metricbeat.yml` file please? **Please make sure to mask any sensitive information in there before posting it here.**

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [December 4, 2018, 5:23pm UTC](https://discuss.elastic.co/t/setup-beats-error-time-out/155389/5 "2018-12-04T17:23:55Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
