# Setup with Unix

**URL:** https://discuss.elastic.co/t/setup-with-unix/6372
**Category:** Elasticsearch
**Created:** [January 13, 2012, 7:45am UTC](https://discuss.elastic.co/t/setup-with-unix/6372 "2012-01-13T07:45:03Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![Kevin](https://avatars.discourse-cdn.com/v4/letter/k/2acd7d/32.png) [@Kevin](https://discuss.elastic.co/u/Kevin)
#### Post date: [January 13, 2012, 7:45am UTC](https://discuss.elastic.co/t/setup-with-unix/6372/1 "2012-01-13T07:45:03Z")

</div>

1. downloaded and unzip
2. bin/elasticsearch -f  
3.then, return the following error in root or sudo. Was this to be  
expected?

Thanks!

[2012-01-13 02:40:34,297][INFO][node] [Cable]  
{0.18.7}[68383]: initializing ...  
[2012-01-13 02:40:34,304][INFO][plugins] [Cable]  
loaded [], sites []  
[2012-01-13 02:40:36,195][INFO][node] [Cable]  
{0.18.7}[68383]: initialized  
[2012-01-13 02:40:36,195][INFO][node] [Cable]  
{0.18.7}[68383]: starting ...  
[2012-01-13 02:40:36,277][INFO][transport] [Cable]  
bound\_address {inet[/0.0.0.0:9300]}, publish\_address {inet[/  
119.40.215.25:9300]}  
Exception in thread "elasticsearch[cached]-pool-1-thread-1"  
org.elasticsearch.discovery.zen.ping.ZenPingException: Failed to send  
ping request over multicast on java.net.MulticastSocket@7b4653a3  
at  
org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.sendPingRequest(MulticastZenPing.java:  
283)  
at  
org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.ping(MulticastZenPing.java:  
231)  
at  
org.elasticsearch.discovery.zen.ping.ZenPingService.ping(ZenPingService.java:  
129)  
at  
org.elasticsearch.discovery.zen.ping.ZenPingService.pingAndWait(ZenPingService.java:  
111)  
at  
org.elasticsearch.discovery.zen.ZenDiscovery.findMaster(ZenDiscovery.java:  
524)  
at  
org.elasticsearch.discovery.zen.ZenDiscovery.innterJoinCluster(ZenDiscovery.java:  
258)  
at org.elasticsearch.discovery.zen.ZenDiscovery.access  
$500(ZenDiscovery.java:70)  
at org.elasticsearch.discovery.zen.ZenDiscovery  
$1.run(ZenDiscovery.java:243)  
at java.util.concurrent.ThreadPoolExecutor  
$Worker.runTask(ThreadPoolExecutor.java:886)  
at java.util.concurrent.ThreadPoolExecutor  
$Worker.run(ThreadPoolExecutor.java:908)  
at java.lang.Thread.run(Thread.java:680)  
Caused by: java.io.IOException: Permission denied  
at java.net.PlainDatagramSocketImpl.send(Native Method)  
at java.net.DatagramSocket.send(DatagramSocket.java:625)  
at  
org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.sendPingRequest(MulticastZenPing.java:  
272)  
... 10 more  
[2012-01-13 02:41:06,344][WARN][discovery] [Cable]  
waited for 30s and no initial state was set by the discovery  
[2012-01-13 02:41:06,344][INFO][discovery] [Cable]  
elasticsearch/orw8ztCjR3u9u-AjkrCEKw  
[2012-01-13 02:41:06,348][INFO][http] [Cable]  
bound\_address {inet[/0.0.0.0:9200]}, publish\_address {inet[/  
119.40.215.25:9200]}  
[2012-01-13 02:41:06,349][INFO][node] [Cable]  
{0.18.7}[68383]: started

---

<div class="post-metadata">

### Author: ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)
#### Post date: [January 13, 2012, 8:18am UTC](https://discuss.elastic.co/t/setup-with-unix/6372/2 "2012-01-13T08:18:50Z")

</div>

Are you going to use multicast to discover the cluster? If not, just  
disable it and run elasticsearch (search for multicast in teh config).

On Fri, Jan 13, 2012 at 9:45 AM, Kevin [kevinyplau@gmail.com](mailto:kevinyplau@gmail.com) wrote:

> 1. downloaded and unzip
> 2. bin/elasticsearch -f  
> 3.then, return the following error in root or sudo. Was this to be  
> expected?
> 
> Thanks!
> 
> [2012-01-13 02:40:34,297][INFO][node] [Cable]  
> {0.18.7}[68383]: initializing ...  
> [2012-01-13 02:40:34,304][INFO][plugins] [Cable]  
> loaded , sites   
> [2012-01-13 02:40:36,195][INFO][node] [Cable]  
> {0.18.7}[68383]: initialized  
> [2012-01-13 02:40:36,195][INFO][node] [Cable]  
> {0.18.7}[68383]: starting ...  
> [2012-01-13 02:40:36,277][INFO][transport] [Cable]  
> bound\_address {inet[/0.0.0.0:9300]}, publish\_address {inet[/  
> 119.40.215.25:9300]}  
> Exception in thread "elasticsearch[cached]-pool-1-thread-1"  
> org.elasticsearch.discovery.zen.ping.ZenPingException: Failed to send  
> ping request over multicast on java.net.MulticastSocket@7b4653a3  
> at
> 
> org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.sendPingRequest(MulticastZenPing.java:  
> 283)  
> at
> 
> org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.ping(MulticastZenPing.java:  
> 231)  
> at
> 
> org.elasticsearch.discovery.zen.ping.ZenPingService.ping(ZenPingService.java:  
> 129)  
> at
> 
> org.elasticsearch.discovery.zen.ping.ZenPingService.pingAndWait(ZenPingService.java:  
> 111)  
> at  
> org.elasticsearch.discovery.zen.ZenDiscovery.findMaster(ZenDiscovery.java:  
> 524)  
> at
> 
> org.elasticsearch.discovery.zen.ZenDiscovery.innterJoinCluster(ZenDiscovery.java:  
> 258)  
> at org.elasticsearch.discovery.zen.ZenDiscovery.access  
> $500(ZenDiscovery.java:70)  
> at org.elasticsearch.discovery.zen.ZenDiscovery  
> $1.run(ZenDiscovery.java:243)  
> at java.util.concurrent.ThreadPoolExecutor  
> $Worker.runTask(ThreadPoolExecutor.java:886)  
> at java.util.concurrent.ThreadPoolExecutor  
> $Worker.run(ThreadPoolExecutor.java:908)  
> at java.lang.Thread.run(Thread.java:680)  
> Caused by: java.io.IOException: Permission denied  
> at java.net.PlainDatagramSocketImpl.send(Native Method)  
> at java.net.DatagramSocket.send(DatagramSocket.java:625)  
> at
> 
> org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.sendPingRequest(MulticastZenPing.java:  
> 272)  
> ... 10 more  
> [2012-01-13 02:41:06,344][WARN][discovery] [Cable]  
> waited for 30s and no initial state was set by the discovery  
> [2012-01-13 02:41:06,344][INFO][discovery] [Cable]  
> elasticsearch/orw8ztCjR3u9u-AjkrCEKw  
> [2012-01-13 02:41:06,348][INFO][http] [Cable]  
> bound\_address {inet[/0.0.0.0:9200]}, publish\_address {inet[/  
> 119.40.215.25:9200]}  
> [2012-01-13 02:41:06,349][INFO][node] [Cable]  
> {0.18.7}[68383]: started

---

<div class="post-metadata">

### Author: ![Kevin](https://avatars.discourse-cdn.com/v4/letter/k/2acd7d/32.png) [@Kevin](https://discuss.elastic.co/u/Kevin)
#### Post date: [January 13, 2012, 8:27am UTC](https://discuss.elastic.co/t/setup-with-unix/6372/3 "2012-01-13T08:27:49Z")

</div>

Noted and thanks. It seems it is alos addressed in the old discussion  
board (not google group).

[http://elasticsearch-users.115913.n3.nabble.com/exception-at-startup-failed-to-send-ping-request-over-multicast-td2097917.html](http://elasticsearch-users.115913.n3.nabble.com/exception-at-startup-failed-to-send-ping-request-over-multicast-td2097917.html)

On Jan 13, 3:18 am, Shay Banon [kim...@gmail.com](mailto:kim...@gmail.com) wrote:

> Are you going to use multicast to discover the cluster? If not, just  
> disable it and run elasticsearch (search for multicast in teh config).
> 
> On Fri, Jan 13, 2012 at 9:45 AM, Kevin [kevinyp...@gmail.com](mailto:kevinyp...@gmail.com) wrote:
> 
> > 1. downloaded and unzip
> > 2. bin/elasticsearch -f  
> > 3.then, return the following error in root or sudo. Was this to be  
> > expected?
> 
> > Thanks!
> 
> > [2012-01-13 02:40:34,297][INFO][node] [Cable]  
> > {0.18.7}[68383]: initializing ...  
> > [2012-01-13 02:40:34,304][INFO][plugins] [Cable]  
> > loaded , sites   
> > [2012-01-13 02:40:36,195][INFO][node] [Cable]  
> > {0.18.7}[68383]: initialized  
> > [2012-01-13 02:40:36,195][INFO][node] [Cable]  
> > {0.18.7}[68383]: starting ...  
> > [2012-01-13 02:40:36,277][INFO][transport] [Cable]  
> > bound\_address {inet[/0.0.0.0:9300]}, publish\_address {inet[/  
> > 119.40.215.25:9300]}  
> > Exception in thread "elasticsearch[cached]-pool-1-thread-1"  
> > org.elasticsearch.discovery.zen.ping.ZenPingException: Failed to send  
> > ping request over multicast on java.net.MulticastSocket@7b4653a3  
> > at
> 
> > org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.sendPingReq uest(MulticastZenPing.java:  
> > 283)  
> > at
> 
> > org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.ping(Multic astZenPing.java:  
> > 231)  
> > at
> 
> > org.elasticsearch.discovery.zen.ping.ZenPingService.ping(ZenPingService.jav a:  
> > 129)  
> > at
> 
> > org.elasticsearch.discovery.zen.ping.ZenPingService.pingAndWait(ZenPingServ ice.java:  
> > 111)  
> > at  
> > org.elasticsearch.discovery.zen.ZenDiscovery.findMaster(ZenDiscovery.java:  
> > 524)  
> > at
> 
> > org.elasticsearch.discovery.zen.ZenDiscovery.innterJoinCluster(ZenDiscovery .java:  
> > 258)  
> > at org.elasticsearch.discovery.zen.ZenDiscovery.access  
> > $500(ZenDiscovery.java:70)  
> > at org.elasticsearch.discovery.zen.ZenDiscovery  
> > $1.run(ZenDiscovery.java:243)  
> > at java.util.concurrent.ThreadPoolExecutor  
> > $Worker.runTask(ThreadPoolExecutor.java:886)  
> > at java.util.concurrent.ThreadPoolExecutor  
> > $Worker.run(ThreadPoolExecutor.java:908)  
> > at java.lang.Thread.run(Thread.java:680)  
> > Caused by: java.io.IOException: Permission denied  
> > at java.net.PlainDatagramSocketImpl.send(Native Method)  
> > at java.net.DatagramSocket.send(DatagramSocket.java:625)  
> > at
> 
> > org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.sendPingReq uest(MulticastZenPing.java:  
> > 272)  
> > ... 10 more  
> > [2012-01-13 02:41:06,344][WARN][discovery] [Cable]  
> > waited for 30s and no initial state was set by the discovery  
> > [2012-01-13 02:41:06,344][INFO][discovery] [Cable]  
> > elasticsearch/orw8ztCjR3u9u-AjkrCEKw  
> > [2012-01-13 02:41:06,348][INFO][http] [Cable]  
> > bound\_address {inet[/0.0.0.0:9200]}, publish\_address {inet[/  
> > 119.40.215.25:9200]}  
> > [2012-01-13 02:41:06,349][INFO][node] [Cable]  
> > {0.18.7}[68383]: started

---

<div class="post-metadata">

### Author: ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)
#### Post date: [January 13, 2012, 8:29am UTC](https://discuss.elastic.co/t/setup-with-unix/6372/4 "2012-01-13T08:29:58Z")

</div>

Yea. There is an annoyance here though, even if multicast is not working,  
the node should still be usable as a single node cluster, I will fix it.

On Fri, Jan 13, 2012 at 10:27 AM, Kevin [kevinyplau@gmail.com](mailto:kevinyplau@gmail.com) wrote:

> Noted and thanks. It seems it is alos addressed in the old discussion  
> board (not google group).
> 
> [http://elasticsearch-users.115913.n3.nabble.com/exception-at-startup-failed-to-send-ping-request-over-multicast-td2097917.html](http://elasticsearch-users.115913.n3.nabble.com/exception-at-startup-failed-to-send-ping-request-over-multicast-td2097917.html)
> 
> On Jan 13, 3:18 am, Shay Banon [kim...@gmail.com](mailto:kim...@gmail.com) wrote:
> 
> > Are you going to use multicast to discover the cluster? If not, just  
> > disable it and run elasticsearch (search for multicast in teh config).
> > 
> > On Fri, Jan 13, 2012 at 9:45 AM, Kevin [kevinyp...@gmail.com](mailto:kevinyp...@gmail.com) wrote:
> > 
> > > 1. downloaded and unzip
> > > 2. bin/elasticsearch -f  
> > > 3.then, return the following error in root or sudo. Was this to be  
> > > expected?
> > 
> > > Thanks!
> > 
> > > [2012-01-13 02:40:34,297][INFO][node] [Cable]  
> > > {0.18.7}[68383]: initializing ...  
> > > [2012-01-13 02:40:34,304][INFO][plugins] [Cable]  
> > > loaded , sites   
> > > [2012-01-13 02:40:36,195][INFO][node] [Cable]  
> > > {0.18.7}[68383]: initialized  
> > > [2012-01-13 02:40:36,195][INFO][node] [Cable]  
> > > {0.18.7}[68383]: starting ...  
> > > [2012-01-13 02:40:36,277][INFO][transport] [Cable]  
> > > bound\_address {inet[/0.0.0.0:9300]}, publish\_address {inet[/  
> > > 119.40.215.25:9300]}  
> > > Exception in thread "elasticsearch[cached]-pool-1-thread-1"  
> > > org.elasticsearch.discovery.zen.ping.ZenPingException: Failed to send  
> > > ping request over multicast on java.net.MulticastSocket@7b4653a3  
> > > at
> > 
> > >
> 
> org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.sendPingReq  
> uest(MulticastZenPing.java:
> 
> > > 1. at
> > 
> > >
> 
> org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.ping(Multic  
> astZenPing.java:
> 
> > > 1. at
> > 
> > >
> 
> org.elasticsearch.discovery.zen.ping.ZenPingService.ping(ZenPingService.jav  
> a:
> 
> > > 1. at
> > 
> > >
> 
> org.elasticsearch.discovery.zen.ping.ZenPingService.pingAndWait(ZenPingServ  
> ice.java:
> 
> > > 1. at
> 
> org.elasticsearch.discovery.zen.ZenDiscovery.findMaster(ZenDiscovery.java:
> 
> > > 1. at
> > 
> > >
> 
> org.elasticsearch.discovery.zen.ZenDiscovery.innterJoinCluster(ZenDiscovery  
> .java:
> 
> > > 1. at org.elasticsearch.discovery.zen.ZenDiscovery.access  
> > > $500(ZenDiscovery.java:70)  
> > > at org.elasticsearch.discovery.zen.ZenDiscovery  
> > > $1.run(ZenDiscovery.java:243)  
> > > at java.util.concurrent.ThreadPoolExecutor  
> > > $Worker.runTask(ThreadPoolExecutor.java:886)  
> > > at java.util.concurrent.ThreadPoolExecutor  
> > > $Worker.run(ThreadPoolExecutor.java:908)  
> > > at java.lang.Thread.run(Thread.java:680)  
> > > Caused by: java.io.IOException: Permission denied  
> > > at java.net.PlainDatagramSocketImpl.send(Native Method)  
> > > at java.net.DatagramSocket.send(DatagramSocket.java:625)  
> > > at
> > 
> > >
> 
> org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.sendPingReq  
> uest(MulticastZenPing.java:
> 
> > > 1. ... 10 more  
> > > [2012-01-13 02:41:06,344][WARN][discovery] [Cable]  
> > > waited for 30s and no initial state was set by the discovery  
> > > [2012-01-13 02:41:06,344][INFO][discovery] [Cable]  
> > > elasticsearch/orw8ztCjR3u9u-AjkrCEKw  
> > > [2012-01-13 02:41:06,348][INFO][http] [Cable]  
> > > bound\_address {inet[/0.0.0.0:9200]}, publish\_address {inet[/  
> > > 119.40.215.25:9200]}  
> > > [2012-01-13 02:41:06,349][INFO][node] [Cable]  
> > > {0.18.7}[68383]: started

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 3:42am UTC](https://discuss.elastic.co/t/setup-with-unix/6372/5 "2017-07-06T03:42:52Z")

</div>


