# Shard allocated for local recovery (post api), should exists, but doesn't

**URL:** <https://discuss.elastic.co/t/shard-allocated-for-local-recovery-post-api-should-exists-but-doesnt/11493>\
**Category:** Elasticsearch\
**Created:** [April 8, 2013, 8:40pm UTC](https://discuss.elastic.co/t/shard-allocated-for-local-recovery-post-api-should-exists-but-doesnt/11493 "2013-04-08T20:40:26Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Devon\_Crouse](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/devon_crouse/32/1967_2.png) [@Devon\_Crouse](https://discuss.elastic.co/u/Devon_Crouse)\
**Post date:** [April 8, 2013, 8:40pm UTC](https://discuss.elastic.co/t/shard-allocated-for-local-recovery-post-api-should-exists-but-doesnt/11493/1 "2013-04-08T20:40:26Z")

</div>

We're getting the following log message for one of our indices, and are  
unable to recover one of its shards:

[2013-04-08 14:05:42,470][WARN][cluster.action.shard] [search-00]sending failed shard  
for [messages\_20130405][1], node[q2ojLu4QSIabQQs2VUl-\_g], [P], s[  
INITIALIZING], reason [Failed to start shard, message [  
IndexShardGatewayRecoveryException[[messages\_20130405][1] shard allocated  
for local recovery (post api), should exists, but doesn't]]]

I see plenty of data on 3 of the nodes (2 replicas) for this shard - is it  
corrupted somehow? We're on 0.20.6, so I don't think this is related  
to [https://github.com/elasticsearch/elasticsearch/issues/2812](https://github.com/elasticsearch/elasticsearch/issues/2812). Any ideas  
why this may have happened, or what I might do to further troubleshoot/fix  
it?

Thanks in advance,

Devon

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 2:42am UTC](https://discuss.elastic.co/t/shard-allocated-for-local-recovery-post-api-should-exists-but-doesnt/11493/2 "2017-07-06T02:42:10Z")

</div>


