# Shard Failing : queue error

**URL:** <https://discuss.elastic.co/t/shard-failing-queue-error/32529>\
**Category:** Elasticsearch\
**Created:** [October 19, 2015, 8:07pm UTC](https://discuss.elastic.co/t/shard-failing-queue-error/32529 "2015-10-19T20:07:49Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![Rajeev\_Singh](https://avatars.discourse-cdn.com/v4/letter/r/59ef9b/32.png) [@Rajeev\_Singh](https://discuss.elastic.co/u/Rajeev_Singh)\
**Post date:** [October 19, 2015, 8:07pm UTC](https://discuss.elastic.co/t/shard-failing-queue-error/32529/1 "2015-10-19T20:07:49Z")

</div>

HI

Am getting this error and seems like can it be resolved by increasing queue size. Is my assumption correct ?

[2015-10-19 20:41:23,495][DEBUG][action.search.type] [Ghost Rider 2099] [logstash-2015.10.13][4], node[gdLxmHjmSiiHqWBb6hpZhA], [P], s[STARTED]: Failed to execute [org.elasticsearch.action.search.SearchRequest@318396d] lastShard [true]  
org.elasticsearch.common.util.concurrent.EsRejectedExecutionException: rejected execution (queue capacity 1000) on org.elasticsearch.search.action.SearchServiceTransportAction$23@309f21ac

Where can I find the config file so as to change the parameters. Looked into elasticsearch.yml but couldnt find any such setings

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [October 20, 2015, 6:11am UTC](https://discuss.elastic.co/t/shard-failing-queue-error/32529/2 "2015-10-20T06:11:51Z")

</div>

You can temporarily relieve this by changing threadpools, but you are overloading the node so it'll probably happen again.

---

<div class="post-metadata">

**Author:** ![Rajeev\_Singh](https://avatars.discourse-cdn.com/v4/letter/r/59ef9b/32.png) [@Rajeev\_Singh](https://discuss.elastic.co/u/Rajeev_Singh)\
**Post date:** [October 20, 2015, 8:15am UTC](https://discuss.elastic.co/t/shard-failing-queue-error/32529/3 "2015-10-20T08:15:53Z")

</div>

Hi  
Whats the best way to overcome this problem ? Increasing nodes ? Is there a formula which tells me what is the best configuration to overcome this problem

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [October 20, 2015, 9:25am UTC](https://discuss.elastic.co/t/shard-failing-queue-error/32529/4 "2015-10-20T09:25:01Z")

</div>

There's no formula as it really depends on use case.

How are you monitoring ES?

---

<div class="post-metadata">

**Author:** ![Rajeev\_Singh](https://avatars.discourse-cdn.com/v4/letter/r/59ef9b/32.png) [@Rajeev\_Singh](https://discuss.elastic.co/u/Rajeev_Singh)\
**Post date:** [October 20, 2015, 3:38pm UTC](https://discuss.elastic.co/t/shard-failing-queue-error/32529/5 "2015-10-20T15:38:35Z")

</div>

I tried using marvel but it was quiet resource intensive

Also the indexer, is on a machine which is also running elasticsearch and kibana hence may be down on resources

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [October 20, 2015, 8:57pm UTC](https://discuss.elastic.co/t/shard-failing-queue-error/32529/6 "2015-10-20T20:57:03Z")

</div>

What specs does the node have?

---

<div class="post-metadata">

**Author:** ![Rajeev\_Singh](https://avatars.discourse-cdn.com/v4/letter/r/59ef9b/32.png) [@Rajeev\_Singh](https://discuss.elastic.co/u/Rajeev_Singh)\
**Post date:** [October 21, 2015, 4:16pm UTC](https://discuss.elastic.co/t/shard-failing-queue-error/32529/7 "2015-10-21T16:16:56Z")

</div>

Its a Windows 2008 server with 4GB RAM. Though am trying to double the spec up but dont know if that would help to solve this problem

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [October 21, 2015, 10:37pm UTC](https://discuss.elastic.co/t/shard-failing-queue-error/32529/8 "2015-10-21T22:37:00Z")

</div>

That's pretty small, adding more memory would help.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 11:43pm UTC](https://discuss.elastic.co/t/shard-failing-queue-error/32529/9 "2017-07-05T23:43:24Z")

</div>


