# Shard faliure

**URL:** https://discuss.elastic.co/t/shard-faliure/7714
**Category:** Elasticsearch
**Created:** [May 16, 2012, 5:29am UTC](https://discuss.elastic.co/t/shard-faliure/7714 "2012-05-16T05:29:03Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![Kartavya](https://avatars.discourse-cdn.com/v4/letter/k/65b543/32.png) [@Kartavya](https://discuss.elastic.co/u/Kartavya)
#### Post date: [May 16, 2012, 5:29am UTC](https://discuss.elastic.co/t/shard-faliure/7714/1 "2012-05-16T05:29:03Z")

</div>

Hi

When I am starting my elastic search 1 out of 5 shard get failed to  
recover. I am getting following error.

reason [Failed to start shard, message [IndexShardGatewayRecoveryExceptio  
n[[new\_index][3] failed recovery]; nested: EngineCreationFailureException[[new\_i  
ndex][3] Failed to create engine]; nested: FileNotFoundException[D:\elasticsearc  
h-0.17.7\elasticsearch-0.17.7\data\elasticsearch\nodes\0\indices\new\_index\3\ind  
ex\_3dsqg.fnm (The system cannot find the file specified)]; ]]

I am creating index using couchdb integration. Can you please tell me  
what is the cause of problem and fix of it.

Thanks in advance.

---

<div class="post-metadata">

### Author: ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)
#### Post date: [May 16, 2012, 10:12pm UTC](https://discuss.elastic.co/t/shard-faliure/7714/2 "2012-05-16T22:12:08Z")

</div>

Seems like a file from the index is missing, any chance you can start to  
use a newer version of ES than 0.17.7?

On Wed, May 16, 2012 at 8:29 AM, Pulkit Agrawal [pulkitdotcom@gmail.com](mailto:pulkitdotcom@gmail.com)wrote:

> Hi
> 
> When I am starting my Elasticsearch 1 out of 5 shard get failed to  
> recover. I am getting following error.
> 
> reason [Failed to start shard, message [IndexShardGatewayRecoveryExceptio  
> n[[new\_index][3] failed recovery]; nested:  
> EngineCreationFailureException[[new\_i  
> ndex][3] Failed to create engine]; nested:  
> FileNotFoundException[D:\elasticsearc
> 
> h-0.17.7\elasticsearch-0.17.7\data\elasticsearch\nodes\0\indices\new\_index\3\ind  
> ex\_3dsqg.fnm (The system cannot find the file specified)]; ]]
> 
> I am creating index using couchdb integration. Can you please tell me  
> what is the cause of problem and fix of it.
> 
> Thanks in advance.

---

<div class="post-metadata">

### Author: ![Kartavya](https://avatars.discourse-cdn.com/v4/letter/k/65b543/32.png) [@Kartavya](https://discuss.elastic.co/u/Kartavya)
#### Post date: [May 17, 2012, 8:02am UTC](https://discuss.elastic.co/t/shard-faliure/7714/3 "2012-05-17T08:02:38Z")

</div>

Thanks Shay.

can we upgrade running elasticsearch instance?

On Thu, May 17, 2012 at 3:42 AM, Shay Banon [kimchy@gmail.com](mailto:kimchy@gmail.com) wrote:

> Seems like a file from the index is missing, any chance you can start to use  
> a newer version of ES than 0.17.7?
> 
> On Wed, May 16, 2012 at 8:29 AM, Pulkit Agrawal [pulkitdotcom@gmail.com](mailto:pulkitdotcom@gmail.com)  
> wrote:
> 
> > Hi
> > 
> > When I am starting my Elasticsearch 1 out of 5 shard get failed to  
> > recover. I am getting following error.
> > 
> > reason [Failed to start shard, message [IndexShardGatewayRecoveryExceptio  
> > n[[new\_index][3] failed recovery]; nested:  
> > EngineCreationFailureException[[new\_i  
> > ndex][3] Failed to create engine]; nested:  
> > FileNotFoundException[D:\elasticsearc
> > 
> > h-0.17.7\elasticsearch-0.17.7\data\elasticsearch\nodes\0\indices\new\_index\3\ind  
> > ex\_3dsqg.fnm (The system cannot find the file specified)]; ]]
> > 
> > I am creating index using couchdb integration. Can you please tell me  
> > what is the cause of problem and fix of it.
> > 
> > Thanks in advance.

---

<div class="post-metadata">

### Author: ![Kartavya](https://avatars.discourse-cdn.com/v4/letter/k/65b543/32.png) [@Kartavya](https://discuss.elastic.co/u/Kartavya)
#### Post date: [May 17, 2012, 11:58am UTC](https://discuss.elastic.co/t/shard-faliure/7714/4 "2012-05-17T11:58:15Z")

</div>

_A fix I made for the same._

I create one more elasticsearch index with same index and mapping  
configuration.  
Then, I replace the 3rd shard (corrupt one) with the 3rd shard on the  
running elasticsearch instance.

It cause me data loss but now the corrupted instance running fine now with  
all shards.

_Please validate my approach._

Thanks,  
Pulkit Agrawal

On Thu, May 17, 2012 at 1:32 PM, Pulkit Agrawal [pulkitdotcom@gmail.com](mailto:pulkitdotcom@gmail.com)wrote:

> Thanks Shay.
> 
> can we upgrade running elasticsearch instance?
> 
> On Thu, May 17, 2012 at 3:42 AM, Shay Banon [kimchy@gmail.com](mailto:kimchy@gmail.com) wrote:
> 
> > Seems like a file from the index is missing, any chance you can start to  
> > use  
> > a newer version of ES than 0.17.7?
> > 
> > On Wed, May 16, 2012 at 8:29 AM, Pulkit Agrawal [pulkitdotcom@gmail.com](mailto:pulkitdotcom@gmail.com)  
> > wrote:
> > 
> > > Hi
> > > 
> > > When I am starting my Elasticsearch 1 out of 5 shard get failed to  
> > > recover. I am getting following error.
> > > 
> > > reason [Failed to start shard, message  
> > > [IndexShardGatewayRecoveryExceptio  
> > > n[[new\_index][3] failed recovery]; nested:  
> > > EngineCreationFailureException[[new\_i  
> > > ndex][3] Failed to create engine]; nested:  
> > > FileNotFoundException[D:\elasticsearc
> 
> h-0.17.7\elasticsearch-0.17.7\data\elasticsearch\nodes\0\indices\new\_index\3\ind
> 
> > > ex\_3dsqg.fnm (The system cannot find the file specified)]; ]]
> > > 
> > > I am creating index using couchdb integration. Can you please tell me  
> > > what is the cause of problem and fix of it.
> > > 
> > > Thanks in advance.

---

<div class="post-metadata">

### Author: ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)
#### Post date: [May 20, 2012, 7:43pm UTC](https://discuss.elastic.co/t/shard-faliure/7714/5 "2012-05-20T19:43:12Z")

</div>

That will work, yes.

On Thu, May 17, 2012 at 1:58 PM, Pulkit Agrawal [pulkitdotcom@gmail.com](mailto:pulkitdotcom@gmail.com)wrote:

> _A fix I made for the same._
> 
> I create one more elasticsearch index with same index and mapping  
> configuration.  
> Then, I replace the 3rd shard (corrupt one) with the 3rd shard on the  
> running elasticsearch instance.
> 
> It cause me data loss but now the corrupted instance running fine now with  
> all shards.
> 
> _Please validate my approach._
> 
> Thanks,  
> Pulkit Agrawal
> 
> On Thu, May 17, 2012 at 1:32 PM, Pulkit Agrawal [pulkitdotcom@gmail.com](mailto:pulkitdotcom@gmail.com)wrote:
> 
> > Thanks Shay.
> > 
> > can we upgrade running elasticsearch instance?
> > 
> > On Thu, May 17, 2012 at 3:42 AM, Shay Banon [kimchy@gmail.com](mailto:kimchy@gmail.com) wrote:
> > 
> > > Seems like a file from the index is missing, any chance you can start  
> > > to use  
> > > a newer version of ES than 0.17.7?
> > > 
> > > On Wed, May 16, 2012 at 8:29 AM, Pulkit Agrawal \<[pulkitdotcom@gmail.com](mailto:pulkitdotcom@gmail.com)
> > > 
> > > wrote:
> > > 
> > > > Hi
> > > > 
> > > > When I am starting my Elasticsearch 1 out of 5 shard get failed to  
> > > > recover. I am getting following error.
> > > > 
> > > > reason [Failed to start shard, message  
> > > > [IndexShardGatewayRecoveryExceptio  
> > > > n[[new\_index][3] failed recovery]; nested:  
> > > > EngineCreationFailureException[[new\_i  
> > > > ndex][3] Failed to create engine]; nested:  
> > > > FileNotFoundException[D:\elasticsearc
> > 
> > h-0.17.7\elasticsearch-0.17.7\data\elasticsearch\nodes\0\indices\new\_index\3\ind
> > 
> > > > ex\_3dsqg.fnm (The system cannot find the file specified)]; ]]
> > > > 
> > > > I am creating index using couchdb integration. Can you please tell me  
> > > > what is the cause of problem and fix of it.
> > > > 
> > > > Thanks in advance.

---

<div class="post-metadata">

### Author: ![Kartavya](https://avatars.discourse-cdn.com/v4/letter/k/65b543/32.png) [@Kartavya](https://discuss.elastic.co/u/Kartavya)
#### Post date: [May 21, 2012, 4:33am UTC](https://discuss.elastic.co/t/shard-faliure/7714/6 "2012-05-21T04:33:42Z")

</div>

Thanks, Shay

Regards,  
Pulkit Agrawal

On Mon, May 21, 2012 at 1:13 AM, Shay Banon [kimchy@gmail.com](mailto:kimchy@gmail.com) wrote:

> That will work, yes.
> 
> On Thu, May 17, 2012 at 1:58 PM, Pulkit Agrawal [pulkitdotcom@gmail.com](mailto:pulkitdotcom@gmail.com)wrote:
> 
> > _A fix I made for the same._
> > 
> > I create one more elasticsearch index with same index and mapping  
> > configuration.  
> > Then, I replace the 3rd shard (corrupt one) with the 3rd shard on the  
> > running elasticsearch instance.
> > 
> > It cause me data loss but now the corrupted instance running fine now  
> > with all shards.
> > 
> > _Please validate my approach._
> > 
> > Thanks,  
> > Pulkit Agrawal
> > 
> > On Thu, May 17, 2012 at 1:32 PM, Pulkit Agrawal [pulkitdotcom@gmail.com](mailto:pulkitdotcom@gmail.com)wrote:
> > 
> > > Thanks Shay.
> > > 
> > > can we upgrade running elasticsearch instance?
> > > 
> > > On Thu, May 17, 2012 at 3:42 AM, Shay Banon [kimchy@gmail.com](mailto:kimchy@gmail.com) wrote:
> > > 
> > > > Seems like a file from the index is missing, any chance you can start  
> > > > to use  
> > > > a newer version of ES than 0.17.7?
> > > > 
> > > > On Wed, May 16, 2012 at 8:29 AM, Pulkit Agrawal \<  
> > > > [pulkitdotcom@gmail.com](mailto:pulkitdotcom@gmail.com)\>  
> > > > wrote:
> > > > 
> > > > > Hi
> > > > > 
> > > > > When I am starting my Elasticsearch 1 out of 5 shard get failed to  
> > > > > recover. I am getting following error.
> > > > > 
> > > > > reason [Failed to start shard, message  
> > > > > [IndexShardGatewayRecoveryExceptio  
> > > > > n[[new\_index][3] failed recovery]; nested:  
> > > > > EngineCreationFailureException[[new\_i  
> > > > > ndex][3] Failed to create engine]; nested:  
> > > > > FileNotFoundException[D:\elasticsearc
> > > 
> > > h-0.17.7\elasticsearch-0.17.7\data\elasticsearch\nodes\0\indices\new\_index\3\ind
> > > 
> > > > > ex\_3dsqg.fnm (The system cannot find the file specified)]; ]]
> > > > > 
> > > > > I am creating index using couchdb integration. Can you please tell me  
> > > > > what is the cause of problem and fix of it.
> > > > > 
> > > > > Thanks in advance.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 3:27am UTC](https://discuss.elastic.co/t/shard-faliure/7714/7 "2017-07-06T03:27:52Z")

</div>


