# Shards failed caused by index.max\_docvalue\_fields\_search

**URL:** <https://discuss.elastic.co/t/shards-failed-caused-by-index-max-docvalue-fields-search/251587>\
**Category:** Elasticsearch\
**Created:** [October 9, 2020, 3:23pm UTC](https://discuss.elastic.co/t/shards-failed-caused-by-index-max-docvalue-fields-search/251587 "2020-10-09T15:23:53Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![cctk](https://avatars.discourse-cdn.com/v4/letter/c/73ab20/32.png) [@cctk](https://discuss.elastic.co/u/cctk)\
**Post date:** [October 9, 2020, 3:23pm UTC](https://discuss.elastic.co/t/shards-failed-caused-by-index-max-docvalue-fields-search/251587/1 "2020-10-09T15:23:53Z")

</div>

I have a problem with filebeat indexes , a new index is made everyday and each time I get a shard failed error. The reason behind it is shown as the `index.max_docvalue_fields_search` is too low.  
I run this in dev tools every time I see a shard failed error.

```auto
PUT /filebeat-*/_settings
{
  "index.max_docvalue_fields_search": 200
}

```

I also added this is filebeat.yml

```auto
setup.template.settings:
  index:
    max_docvalue_fields_search: 200

```

There has been no difference. Is there any way I can fix this error, I have checked the index patterns and there is no mapping issue. any help would be great

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [October 11, 2020, 7:42am UTC](https://discuss.elastic.co/t/shards-failed-caused-by-index-max-docvalue-fields-search/251587/2 "2020-10-11T07:42:29Z")

</div>

You might need to directly update the filebeat index template. Am not sure changing this in Filebeat will cause it to be updated.

---

<div class="post-metadata">

**Author:** ![cctk](https://avatars.discourse-cdn.com/v4/letter/c/73ab20/32.png) [@cctk](https://discuss.elastic.co/u/cctk)\
**Post date:** [October 12, 2020, 12:19pm UTC](https://discuss.elastic.co/t/shards-failed-caused-by-index-max-docvalue-fields-search/251587/3 "2020-10-12T12:19:24Z")

</div>

you mean by re-indexing or the actual template through stack management ?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 9, 2020, 12:19pm UTC](https://discuss.elastic.co/t/shards-failed-caused-by-index-max-docvalue-fields-search/251587/4 "2020-11-09T12:19:29Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
