# 'sincedb\_path' for http\_poller not working

**URL:** <https://discuss.elastic.co/t/sincedb-path-for-http-poller-not-working/244734>\
**Category:** Logstash\
**Created:** [August 12, 2020, 2:05pm UTC](https://discuss.elastic.co/t/sincedb-path-for-http-poller-not-working/244734 "2020-08-12T14:05:24Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![AditiKhalatkar](https://avatars.discourse-cdn.com/v4/letter/a/a183cd/32.png) [@AditiKhalatkar](https://discuss.elastic.co/u/AditiKhalatkar)\
**Post date:** [August 12, 2020, 2:05pm UTC](https://discuss.elastic.co/t/sincedb-path-for-http-poller-not-working/244734/1 "2020-08-12T14:05:25Z")

</div>

I am trying to ingest data from an API using http\_poller plugin in logstash. Tried using some methods, however was it is throwing error like this.

> ```
> Java HotSpot(TM) 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
> WARNING: An illegal reflective access operation has occurred
> WARNING: Illegal reflective access by com.headius.backport9.modules.Modules (file:/usr/share/logstash/logstash-core/lib/jars/jruby-complete-9.2.7.0.jar) to field java.io.FileDescriptor.fd
> WARNING: Please consider reporting this to the maintainers of com.headius.backport9.modules.Modules
> WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
> WARNING: All illegal access operations will be denied in a future release
> WARNING: Could not find logstash.yml which is typically located in $LS_HOME/config or /etc/logstash. You can specify the path using --path.settings. Continuing using the defaults
> Could not find log4j2 configuration at path /usr/share/logstash/config/log4j2.properties. Using default config which logs errors to the console
> [WARN] 2020-08-12 09:56:00.939 [LogStash::Runner] multilocal - Ignoring the 'pipelines.yml' file because modules or command line options are specified
> [ERROR] 2020-08-12 09:56:04.472 [LogStash::Runner] http_poller - Unknown setting 'sincedb_path' for http_poller
> [FATAL] 2020-08-12 09:56:04.495 [LogStash::Runner] runner - The given configuration is invalid. Reason: Something is wrong with your configuration.
> [ERROR] 2020-08-12 09:56:04.507 [LogStash::Runner] Logstash - java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit
> 
> ```

If I don't include sincedb\_path attribute then it runs smoothly but no index is created on Elasticsearch end (trying to view index in Kibana)

Kindly guide.

This is my configuration file.

> input {  
> http\_poller {  
> urls =\> {  
> urlname =\> "[https://randomuser.me/api](https://randomuser.me/api)"  
> }  
> request\_timeout =\> 20  
> schedule =\> { every =\> "20s" }  
> codec =\> "line"  
> sincedb\_path =\> "/var/log/logstash"  
> }  
> }  
> output {  
> elasticsearch {  
> hosts =\> ["localhost:9200"]  
> index =\> "monitorwebsite"  
> }  
> stdout {  
> codec =\> rubydebug  
> }  
> }

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [August 12, 2020, 2:23pm UTC](https://discuss.elastic.co/t/sincedb-path-for-http-poller-not-working/244734/2 "2020-08-12T14:23:29Z")

</div>

> [@AditiKhalatkar](#):
>
> `Unknown setting 'sincedb_path' for http_poller`

The http\_poller input does not support a sincedb\_path option. You need to remove it.

---

<div class="post-metadata">

**Author:** ![AditiKhalatkar](https://avatars.discourse-cdn.com/v4/letter/a/a183cd/32.png) [@AditiKhalatkar](https://discuss.elastic.co/u/AditiKhalatkar)\
**Post date:** [August 12, 2020, 2:28pm UTC](https://discuss.elastic.co/t/sincedb-path-for-http-poller-not-working/244734/3 "2020-08-12T14:28:05Z")

</div>

I removed it and it works. Thank you!

I realized I was checking Kibana too soon, given there is 20s wait, the index was taking some time for creation. Silly me. Lol.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 9, 2020, 2:28pm UTC](https://discuss.elastic.co/t/sincedb-path-for-http-poller-not-working/244734/4 "2020-09-09T14:28:06Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
