# Sir I have issue with storage for 7 days

**URL:** <https://discuss.elastic.co/t/sir-i-have-issue-with-storage-for-7-days/349509>\
**Category:** APM\
**Tags:** go, server\
**Created:** [December 17, 2023, 11:42am UTC](https://discuss.elastic.co/t/sir-i-have-issue-with-storage-for-7-days/349509 "2023-12-17T11:42:13Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![zabtech](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zabtech/32/128351_2.png) [@zabtech](https://discuss.elastic.co/u/zabtech)\
**Post date:** [December 17, 2023, 11:42am UTC](https://discuss.elastic.co/t/sir-i-have-issue-with-storage-for-7-days/349509/1 "2023-12-17T11:42:13Z")

</div>

I have issue with storage, my storage is full more than 7 days, I can't use APM for 7 days also, I try to created cases and use enterprise plan, but it's look like no one really can't help me. What can I do with my issue because I paid you everyday that I use your service, but I got nothing comeback. Do I have to cancel all of your service ?

---

<div class="post-metadata">

**Author:** ![zabtech](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zabtech/32/128351_2.png) [@zabtech](https://discuss.elastic.co/u/zabtech)\
**Post date:** [December 17, 2023, 11:45am UTC](https://discuss.elastic.co/t/sir-i-have-issue-with-storage-for-7-days/349509/2 "2023-12-17T11:45:32Z")

</div>

So someone advice me how to delete data.  
I use DELETE METHOD  
/.ds-traces-apm-default-2023.12.08-000001/\_doc/1

and got error

```auto
{
"status": 429,
"error": {
"root_cause": [
{
"reason": "index [.ds-traces-apm-default-2023.12.08-000001] blocked by: [TOO_MANY_REQUESTS/12/disk usage exceeded flood-stage watermark, index has read-only-allow-delete block];",
"type": "cluster_block_exception"
}
],
"type": "cluster_block_exception",
"reason": "index [.ds-traces-apm-default-2023.12.08-000001] blocked by: [TOO_MANY_REQUESTS/12/disk usage exceeded flood-stage watermark, index has read-only-allow-delete block];"
}
}

```

---

<div class="post-metadata">

**Author:** ![zabtech](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zabtech/32/128351_2.png) [@zabtech](https://discuss.elastic.co/u/zabtech)\
**Post date:** [December 17, 2023, 11:49am UTC](https://discuss.elastic.co/t/sir-i-have-issue-with-storage-for-7-days/349509/3 "2023-12-17T11:49:13Z")

</div>

Even I try this still got error

```auto
/.ds-traces-apm*/_doc/1
{
  "status": 404,
  "error": {
    "index_uuid": "_na_",
    "index": ".ds-traces-apm*",
    "resource.type": "index_or_alias",
    "root_cause": [
      {
        "index_uuid": "_na_",
        "index": ".ds-traces-apm*",
        "resource.type": "index_or_alias",
        "resource.id": ".ds-traces-apm*",
        "reason": "no such index [.ds-traces-apm*]",
        "type": "index_not_found_exception"
      }
    ],
    "reason": "no such index [.ds-traces-apm*]",
    "type": "index_not_found_exception",
    "resource.id": ".ds-traces-apm*"
  }
}

```

---

<div class="post-metadata">

**Author:** ![BenB196](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/benb196/32/83401_2.png) [@BenB196](https://discuss.elastic.co/u/BenB196)\
**Post date:** [December 17, 2023, 12:42pm UTC](https://discuss.elastic.co/t/sir-i-have-issue-with-storage-for-7-days/349509/4 "2023-12-17T12:42:40Z")

</div>

You have 3 options here:

1. Increase your disk size.
  - See whatever hosting/OS docs for how to do this.

2. [Delete index(es)](https://www.elastic.co/guide/en/elasticsearch/reference/current/indices-delete-index.html) to free up disk space.
  - Note: You are currently trying to delete docs from an index which is not the same and will fail. You need to delete the entire index.

3. Setup ILM to delete indexes on a more "aggressive" interval to free up disk space.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 14, 2024, 12:42pm UTC](https://discuss.elastic.co/t/sir-i-have-issue-with-storage-for-7-days/349509/5 "2024-01-14T12:42:56Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
