# Skipping security auto configuration

**URL:** <https://discuss.elastic.co/t/skipping-security-auto-configuration/315173>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-security\
**Created:** [September 26, 2022, 1:30pm UTC](https://discuss.elastic.co/t/skipping-security-auto-configuration/315173 "2022-09-26T13:30:04Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![cdy5159](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cdy5159/32/115812_2.png) [@cdy5159](https://discuss.elastic.co/u/cdy5159)\
**Post date:** [September 26, 2022, 1:30pm UTC](https://discuss.elastic.co/t/skipping-security-auto-configuration/315173/1 "2022-09-26T13:30:04Z")

</div>

I'm attempting to build a 3 node cluster with Elastic 8.2.3. I can build the first node as a single node cluster successfully and connect with kibana. My problem is adding nodes.  
On the first node, I've run the command elasticsearch-create-enrollment-node -s node' and received my token. On the second node, I installed elasticsearch and, without any configuration of the elasticsearch.yml file, ran the command elasticsearch --enrollment-token . I get the error "ERROR: Skipping security auto configuration because it appears that security is already configured."

On this node, I have un-installed and re-installed elasticsearch. I've also cleaned out the /var/lib/elasticsearch folder and the /etc/elasticsearch folder after erasing the RPM.

So, based on some other topics that I've read, I ran the elasticsearch-reconfigure-node command with the enrollment token. That command fails with the error "Aborting enrollment to cluster. This node doesn't appear to be auto-configured for security. Expected configuration is missing from elasticsearch.yml. "

So basically, I'm confused. One command indicates that the node has already been auto-configured for security, the others indicates that it hasn't. Either way, my node is not getting configured to work with the cluster.

What am I doing wrong?

---

<div class="post-metadata">

**Author:** ![Yang\_Wang](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yang_wang/32/48857_2.png) [@Yang\_Wang](https://discuss.elastic.co/u/Yang_Wang)\
**Post date:** [September 27, 2022, 12:12am UTC](https://discuss.elastic.co/t/skipping-security-auto-configuration/315173/2 "2022-09-27T00:12:41Z")

</div>

> get the error "ERROR: Skipping security auto configuration because it appears that security is already configured."

This error means the `xpack.security.enabled` is already explicitly configured. Please check whether this is the case in `elasticsearch.yml` file. If this is the new node and you don't need to retain any old data, pelase remove any settings from `elasticsearch.yml` and try start the node again with the enrollement token (you'll need a new one because it is valid for 30 min only).

> I ran the elasticsearch-reconfigure-node command with the enrollment token. That command fails with the error "Aborting enrollment to cluster. This node doesn't appear to be auto-configured for security. Expected configuration is missing from elasticsearch.yml. "

This is expected. Reconfigure-node only works if the node has been previously successfully auto-configured for security.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 25, 2022, 12:13am UTC](https://discuss.elastic.co/t/skipping-security-auto-configuration/315173/3 "2022-10-25T00:13:09Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
