# Snapshot error (Solved)

**URL:** <https://discuss.elastic.co/t/snapshot-error-solved/28985>\
**Category:** Elasticsearch\
**Created:** [September 10, 2015, 4:28am UTC](https://discuss.elastic.co/t/snapshot-error-solved/28985 "2015-09-10T04:28:31Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Jason\_Zheng](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jason_zheng/32/4041_2.png) [@Jason\_Zheng](https://discuss.elastic.co/u/Jason_Zheng)\
**Post date:** [September 10, 2015, 4:28am UTC](https://discuss.elastic.co/t/snapshot-error-solved/28985/1 "2015-09-10T04:28:31Z")

</div>

Hi All,

I would like to create the snapshot but get the result

```
{"error":"RepositoryVerificationException[[my_backup] path is not accessible on master node]; nested: FileNotFoundException[/mnt/es_snapshot/tests-AHLJFeQaTMap0CjEvhZhNA-master (Permission denied)]; ","status":500}

```

Following is my steps.

There are 2 nodes of my elasticsearch cluster, all of two are mount to GFS, like

```
140.92.25.176:/cakestorage/elasticsearch
                     5857675264 104251392 5753423872 2% /mnt/es_snapshot

```

My elasticsearch.yml setting (all nodes)

```
path.repo: /mnt/es_snapshot

```

Then create snapshot

```
$curl -XPOST -u es_admin:iiiiii "http://localhost:9200/_snapshot/my_backup" -d '
{
    "type": "fs",
    "settings": {
        "location": "/mnt/es_snapshot"
    }
}'

```

Anyone can help?

Jason

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 10, 2015, 7:26am UTC](https://discuss.elastic.co/t/snapshot-error-solved/28985/2 "2015-09-10T07:26:12Z")

</div>

What's the output from `ls -ld /mnt/es_snapshot`

---

<div class="post-metadata">

**Author:** ![Jason\_Zheng](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jason_zheng/32/4041_2.png) [@Jason\_Zheng](https://discuss.elastic.co/u/Jason_Zheng)\
**Post date:** [September 10, 2015, 9:23am UTC](https://discuss.elastic.co/t/snapshot-error-solved/28985/3 "2015-09-10T09:23:15Z")

</div>

Hi Mark,

```
drwxr-xr-x 3 root root 124 Sep 10 15:22 /mnt/es_snapshot

```

I change owner root to elasticsearch, it can be work, thanks

```
drwxr-xr-x 3 elasticsearch elasticsearch 124 Sep 10 15:25 /mnt/es_snapshot

```

Jason

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 11:51pm UTC](https://discuss.elastic.co/t/snapshot-error-solved/28985/4 "2017-07-05T23:51:22Z")

</div>


