# Snapshot of ES Index failing Using Curator to S3

**URL:** <https://discuss.elastic.co/t/snapshot-of-es-index-failing-using-curator-to-s3/28601>\
**Category:** Elasticsearch\
**Created:** [September 3, 2015, 12:03pm UTC](https://discuss.elastic.co/t/snapshot-of-es-index-failing-using-curator-to-s3/28601 "2015-09-03T12:03:20Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Deb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/deb/32/46162_2.png) [@Deb](https://discuss.elastic.co/u/Deb)\
**Post date:** [September 3, 2015, 12:03pm UTC](https://discuss.elastic.co/t/snapshot-of-es-index-failing-using-curator-to-s3/28601/1 "2015-09-03T12:03:20Z")

</div>

Hi,

I am trying to take a snapshot of ES Index having name of the type `reincarnation.2015.07.21` with the below curator command:-

```
curator --host locahost --port 9200 snapshot --repository walle_elk_archive indices --older-than 10 --time-unit days --timestring %Y.%m.%d --prefix reincarnation

```

But I am getting the below error

```
2015-09-03 17:18:14,938 INFO Job starting: snapshot indices
2015-09-03 17:18:14,938 WARNING Overriding default connection timeout. New timeout: 21600
ERROR: Connection failure.

```

I have added the aws keys in `elasticsearch.yaml` as shown below. Restarted elasticsearch after that.

```
################################## AWS Cloud ################################
cloud.aws.access_key: <SomeMixofNumbersandLetters>
cloud.aws.secret_key: <CanOnlyBeObtainedUponCreationOfAccessKeyDon'tLose>

```

AWS Plugin has also been added to ES node and restarted the node after that.

I have created the repo using the below command and it was successful

```
$ curl -XPUT '<hostname>:9200/_snapshot/walle_elk_archive' -d '
{
  "type": "s3",
  "settings": {
     "bucket": "my_bucket_name",
     "region": "your_aws_region",
     "access_key": "your_access_key", 
     "secret_key": "your_secret_key" 
  }
}'

```

Can some one let me know what I am doing wrong ? What this `Connection Failure` mean? Is it curator failing to connect to elasticsearch or elasticsearch failing to connect to S3? I could not find anything in elasticsearch logs.

- Curator Version 3.3.0
- ES Version 1.5.1

---

<div class="post-metadata">

**Author:** ![Igor\_Motov](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/igor_motov/32/45193_2.png) [@Igor\_Motov](https://discuss.elastic.co/u/Igor_Motov)\
**Post date:** [September 4, 2015, 3:13am UTC](https://discuss.elastic.co/t/snapshot-of-es-index-failing-using-curator-to-s3/28601/2 "2015-09-04T03:13:56Z")

</div>

Already answered on [stack overflow](http://stackoverflow.com/questions/32380728/snapshot-of-elasticsearch-using-curator-failing).

---

<div class="post-metadata">

**Author:** ![Deb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/deb/32/46162_2.png) [@Deb](https://discuss.elastic.co/u/Deb)\
**Post date:** [September 4, 2015, 7:21am UTC](https://discuss.elastic.co/t/snapshot-of-es-index-failing-using-curator-to-s3/28601/3 "2015-09-04T07:21:52Z")

</div>

Thanks @Igor_Motov

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 11:52pm UTC](https://discuss.elastic.co/t/snapshot-of-es-index-failing-using-curator-to-s3/28601/4 "2017-07-05T23:52:07Z")

</div>


