# SNMP with Logstash (Pipeline Error)

**URL:** https://discuss.elastic.co/t/snmp-with-logstash-pipeline-error/346533
**Category:** Logstash
**Created:** [November 6, 2023, 2:14pm UTC](https://discuss.elastic.co/t/snmp-with-logstash-pipeline-error/346533 "2023-11-06T14:14:49Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Funkster](https://avatars.discourse-cdn.com/v4/letter/f/b782af/32.png) [@Funkster](https://discuss.elastic.co/u/Funkster)
#### Post date: [November 6, 2023, 2:14pm UTC](https://discuss.elastic.co/t/snmp-with-logstash-pipeline-error/346533/1 "2023-11-06T14:14:50Z")

</div>

Hello,

I am trying to get SNMP-Loggin to work whithin ELK in Logstash and I get the following Error:

````auto
root@vm-kibana:~# /usr/share/logstash/bin/logstash -f /etc/logstash/conf.d/logstash-snmp.conf --path.settings=/etc/logstash
Using bundled JDK: /usr/share/logstash/jdk
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
Sending Logstash logs to /var/log/logstash which is now configured via log4j2.properties
[2023-11-06T14:13:29,438][INFO][logstash.runner] Log4j configuration path used is: /etc/logstash/log4j2.properties
[2023-11-06T14:13:29,447][INFO][logstash.runner] Starting Logstash {"logstash.version"=>"7.17.14", "jruby.version"=>"jruby 9.2.20.1 (2.5.8) 2021-11-30 2a2962fbd1 OpenJDK 64-Bit Server VM 11.0.20+8 on 11.0.20+8 +indy +jit [linux-x86_64]"}
[2023-11-06T14:13:29,449][INFO][logstash.runner] JVM bootstrap flags: [-Xms1g, -Xmx1g, -XX:+UseConcMarkSweepGC, -XX:CMSInitiatingOccupancyFraction=75, -XX:+UseCMSInitiatingOccupancyOnly, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djdk.io.File.enableADS=true, -Djruby.compile.invokedynamic=true, -Djruby.jit.threshold=0, -Djruby.regexp.interruptible=true, -XX:+HeapDumpOnOutOfMemoryError, -Djava.security.egd=file:/dev/urandom, -Dlog4j2.isThreadContextMapInheritable=true]
[2023-11-06T14:13:29,716][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified
[2023-11-06T14:13:31,109][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=>9600, :ssl_enabled=>false}
[2023-11-06T14:13:32,642][INFO][org.reflections.Reflections] Reflections took 86 ms to scan 1 urls, producing 119 keys and 419 values
[2023-11-06T14:13:34,227][INFO][logstash.outputs.elasticsearch][main] New Elasticsearch output {:class=>"LogStash::Outputs::ElasticSearch", :hosts=>["//127.0.0.1:9200"]}
[2023-11-06T14:13:34,554][INFO][logstash.outputs.elasticsearch][main] Elasticsearch pool URLs updated {:changes=>{:removed=>[], :added=>[http://elastic:xxxxxx@127.0.0.1:9200/]}}
[2023-11-06T14:13:34,798][WARN][logstash.outputs.elasticsearch][main] Restored connection to ES instance {:url=>"http://elastic:xxxxxx@127.0.0.1:9200/"}
[2023-11-06T14:13:34,811][INFO][logstash.outputs.elasticsearch][main] Elasticsearch version determined (7.17.14) {:es_version=>7}
[2023-11-06T14:13:34,813][WARN][logstash.outputs.elasticsearch][main] Detected a 6.x and above cluster: the `type` event field won't be used to determine the document _type {:es_version=>7}
[2023-11-06T14:13:34,887][INFO][logstash.outputs.elasticsearch][main] Config is not compliant with data streams. `data_stream => auto` resolved to `false`
[2023-11-06T14:13:34,991][INFO][logstash.javapipeline][main] Starting pipeline {:pipeline_id=>"main", "pipeline.workers"=>4, "pipeline.batch.size"=>125, "pipeline.batch.delay"=>50, "pipeline.max_inflight"=>500, "pipeline.sources"=>["/etc/logstash/conf.d/logstash-snmp.conf"], :thread=>"#<Thread:0x4173f901 run>"}
[2023-11-06T14:13:35,088][INFO][logstash.outputs.elasticsearch][main] Using a default mapping template {:es_version=>7, :ecs_compatibility=>:disabled}
[2023-11-06T14:13:36,465][INFO][logstash.javapipeline][main] Pipeline Java execution initialization time {"seconds"=>1.47}
[2023-11-06T14:13:36,902][ERROR][logstash.javapipeline][main] Pipeline error {:pipeline_id=>"main", :exception=>#<NameError: uninitialized constant LogStash::Inputs::Snmp::Logstash>, :backtrace=>["org/jruby/RubyModule.java:3766:in `const_missing'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-input-snmp-1.3.3/lib/logstash/inputs/snmp.rb:312:in `block in validate_oids!'", "org/jruby/RubyArray.java:1821:in `each'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-input-snmp-1.3.3/lib/logstash/inputs/snmp.rb:310:in `block in validate_oids!'", "org/jruby/RubyArray.java:1821:in `each'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-input-snmp-1.3.3/lib/logstash/inputs/snmp.rb:307:in `validate_oids!'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-input-snmp-1.3.3/lib/logstash/inputs/snmp.rb:131:in `register'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-mixin-ecs_compatibility_support-1.3.0-java/lib/logstash/plugin_mixins/ecs_compatibility_support/target_check.rb:48:in `register'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:233:in `block in register_plugins'", "org/jruby/RubyArray.java:1821:in `each'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:232:in `register_plugins'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:391:in `start_inputs'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:316:in `start_workers'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:190:in `run'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:142:in `block in start'"], "pipeline.sources"=>["/etc/logstash/conf.d/logstash-snmp.conf"], :thread=>"#<Thread:0x4173f901 run>"}
[2023-11-06T14:13:36,907][INFO][logstash.javapipeline][main] Pipeline terminated {"pipeline.id"=>"main"}
[2023-11-06T14:13:36,942][ERROR][logstash.agent] Failed to execute action {:id=>:main, :action_type=>LogStash::ConvergeResult::FailedAction, :message=>"Could not execute action: PipelineAction::Create<main>, action_result: false", :backtrace=>nil}
[2023-11-06T14:13:37,143][INFO][logstash.runner] Logstash shut down.
[2023-11-06T14:13:37,161][FATAL][org.logstash.Logstash] Logstash stopped processing because of an error: (SystemExit) exit
org.jruby.exceptions.SystemExit: (SystemExit) exit
        at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:747) ~[jruby-complete-9.2.20.1.jar:?]
        at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:710) ~[jruby-complete-9.2.20.1.jar:?]
        at usr.share.logstash.lib.bootstrap.environment.<main>(/usr/share/logstash/lib/bootstrap/environment.rb:94) ~[?:?]```

````

I use the following config:

```auto
root@vm-kibana:~# cat /etc/logstash/conf.d/logstash-snmp.conf
input {
  snmp {
    hosts => [{host => "udp:172.17.32.248/161" community => "monitor" version => "2c" retries => 2 timeout => 1000}]
    tables => [{"name" => "interfaces" "columns" => ["1.3.6.1.2.1.2.2.1.1", "1.3.6.1.2.1.2.2.1.2", "1.3.6.1.2.1.2.2.1.5", "1.3.6.1.2.1.31.1.1.1.6", "1.3. .1.2.1.31.1.1.1.10"]} ]
  }
}
output {
    stdout
    {
        codec => rubydebug
    }
     elasticsearch {
        action => "index"
        hosts => ["127.0.0.1:9200"]
        user => "${ES_USER}"
        password => "${ES_PWD}"
        index => "snmp"
    }
}

```

---

<div class="post-metadata">

### Author: ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)
#### Post date: [November 6, 2023, 3:48pm UTC](https://discuss.elastic.co/t/snmp-with-logstash-pipeline-error/346533/2 "2023-11-06T15:48:57Z")

</div>

> [@Funkster](#):
>
> ```auto
> tables => [{"name" => "interfaces" "columns" => ["1.3.6.1.2.1.2.2.1.1", "1.3.6.1.2.1.2.2.1.2", "1.3.6.1.2.1.2.2.1.5", "1.3.6.1.2.1.31.1.1.1.6", "1.3. .1.2.1.31.1.1.1.10"]} ]
>  
> 
> ```

The code is [trying](https://github.com/logstash-plugins/logstash-input-snmp/blob/0e4fe940d35f97e62d15d96963c7570dfa51e9f8/lib/logstash/inputs/snmp.rb#L312) to complain about an invalid regex. No idea why it fails in that way, but "1.3. .1.2.1.31.1.1.1.10" should not contain a space.

---

<div class="post-metadata">

### Author: ![Funkster](https://avatars.discourse-cdn.com/v4/letter/f/b782af/32.png) [@Funkster](https://discuss.elastic.co/u/Funkster)
#### Post date: [November 6, 2023, 4:03pm UTC](https://discuss.elastic.co/t/snmp-with-logstash-pipeline-error/346533/3 "2023-11-06T16:03:19Z")

</div>

Many thanks, works so far. Unfortunately the space came with a Logstash guide.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [December 4, 2023, 4:04pm UTC](https://discuss.elastic.co/t/snmp-with-logstash-pipeline-error/346533/4 "2023-12-04T16:04:12Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
