# "socket hang up"

**URL:** <https://discuss.elastic.co/t/socket-hang-up/87763>\
**Category:** Kibana\
**Created:** [May 31, 2017, 2:30pm UTC](https://discuss.elastic.co/t/socket-hang-up/87763 "2017-05-31T14:30:09Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![hailaeos.troy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hailaeos.troy/32/12817_2.png) [@hailaeos.troy](https://discuss.elastic.co/u/hailaeos.troy)\
**Post date:** [May 31, 2017, 2:30pm UTC](https://discuss.elastic.co/t/socket-hang-up/87763/1 "2017-05-31T14:30:10Z")

</div>

Hi all getting some strange timeouts. I have serveral kibana instances. When I go to the management tab and refresh the fields I the the following logs messages

> {"type":"response","@timestamp":"2017-05-31T14:17:04Z","tags":,"pid":25970,"method":"get","statusCode":200,"req":{"url":"/api/kibana/logstash-_/field\_capabilities","method":"get","headers":{"connection":"upgrade","host":"kibana06-vlp.du.edu","x-real-ip":"130.253.15.45, 130.253.15.45","x-forwarded-for":"130.253.15.45","x-forwarded-proto":"https","accept":"application/json, text/plain, /","kbn-version":"5.4.0","user-agent":"Mozilla/5.0 (Macintosh; Intel Mac OS X 10\_12\_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36","referer":"[https://kibana06-vlp.du.edu/app/kibana","accept-encoding":"gzip](https://kibana06-vlp.du.edu/app/kibana%22,%22accept-encoding%22:%22gzip), deflate, sdch, br","accept-language":"en-US,en;q=0.8"},"remoteAddress":"127.0.0.1","userAgent":"127.0.0.1","referer":"[https://kibana06-vlp.du.edu/app/kibana"},"res":{"statusCode":200,"responseTime":120024,"contentLength":9},"message":"GET](https://kibana06-vlp.du.edu/app/kibana%22%7D,%22res%22:%7B%22statusCode%22:200,%22responseTime%22:120024,%22contentLength%22:9%7D,%22message%22:%22GET) /api/kibana/logstash-_/field\_capabilities 200 120024ms - 9.0B"}  
> {"type":"log","@timestamp":"2017-05-31T14:19:13Z","tags":["error","elasticsearch","admin"],"pid":25970,"message":"Request error, retrying\nGET [http://kibana06-vlp.du.edu:9200/\_nodes?filter\_path=nodes.\*.version%2Cnodes.\*.http.publish\_address%2Cnodes.\*.ip](http://kibana06-vlp.du.edu:9200/_nodes?filter_path=nodes.*.version%2Cnodes.*.http.publish_address%2Cnodes.*.ip) =\> socket hang up"}  
> {"type":"log","@timestamp":"2017-05-31T14:19:30Z","tags":["status","plugin:elasticsearch@5.4.0","info"],"pid":25970,"state":"green","message":"Status changed from red to green - Kibana index ready","prevState":"red","prevMsg":{"code":"ECONNRESET"}}  
> {"type":"log","@timestamp":"2017-05-31T14:19:30Z","tags":["status","ui settings","info"],"pid":25970,"state":"green","message":"Status changed from red to green - Ready","prevState":"red","prevMsg":"Elasticsearch plugin is red"}

Its not elasticsearch as I can do searches using curl no issue. I deleted the indices associated with the kibana instance and attempted to recreate but still get the messages. I have tried backing out to the previous version of kibana 5.3 but that didn't work. I am currently at 6.4.0 of Kibana

Any ideas?

---

<div class="post-metadata">

**Author:** ![jbudz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jbudz/32/45922_2.png) [@jbudz](https://discuss.elastic.co/u/jbudz)\
**Post date:** [May 31, 2017, 6:05pm UTC](https://discuss.elastic.co/t/socket-hang-up/87763/2 "2017-05-31T18:05:14Z")

</div>

Are the mappings for your index large? The request may be taking longer than kibana's configured request timeout.  
Bumping elasticsearch.requestTimeout in kibana.yml is worth a try.

If that doesn't work, are there any proxies between elasticsearch and kibana? It might be worth checking if the connection works directly, there could be a timeout on the proxy.

---

<div class="post-metadata">

**Author:** ![hailaeos.troy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hailaeos.troy/32/12817_2.png) [@hailaeos.troy](https://discuss.elastic.co/u/hailaeos.troy)\
**Post date:** [May 31, 2017, 6:56pm UTC](https://discuss.elastic.co/t/socket-hang-up/87763/3 "2017-05-31T18:56:15Z")

</div>

I bumped up the Timeout to some crazy high number and that didn't work. I have 2477 fields. I also put X11 and firefox and went local to by pass nginx.  
One thing I just tried is pointed the kibana to a new indices and on startup the I see the indices created. But get the same sort of error messages:

{"type":"response","@timestamp":"2017-05-31T18:38:41Z","tags":[],"pid":1831,"method":"get","statusCode":200,"req":{"url":"/elasticsearch/logstash-_/\_mapping/field/_?_=1496255921770&ignore\_unavailable=false&allow\_no\_indices=false&include\_defaults=true","method":"get","headers":{"host":"localhost:5601","user-agent":"Mozilla/5.0 (X11; Linux x86\_64; rv:52.0) Gecko/20100101 Firefox/52.0","accept":"application/json, text/plain, /","accept-language":"en-US,en;q=0.5","accept-encoding":"gzip, deflate","kbn-version":"5.4.0","referer":"[http://localhost:5601/app/kibana","connection":"keep-alive"},"remoteAddress":"127.0.0.1","userAgent":"127.0.0.1","referer":"http://localhost:5601/app/kibana"},"res":{"statusCode":200,"responseTime":5354,"contentLength":9},"message":"GET](http://localhost:5601/app/kibana%22,%22connection%22:%22keep-alive%22%7D,%22remoteAddress%22:%22127.0.0.1%22,%22userAgent%22:%22127.0.0.1%22,%22referer%22:%22http://localhost:5601/app/kibana%22%7D,%22res%22:%7B%22statusCode%22:200,%22responseTime%22:5354,%22contentLength%22:9%7D,%22message%22:%22GET) /elasticsearch/logstash-/\_mapping/field/?_=1496255921770&ignore\_unavailable=false&allow\_no\_indices=false&include\_defaults=true 200 5354ms - 9.0B"}  
{"type":"log","@timestamp":"2017-05-31T18:39:17Z","tags":["error","elasticsearch","data"],"pid":1831,"message":"Request error, retrying\nPOST [http://kibana06-vlp.du.edu:9200/logstash-](http://kibana06-vlp.du.edu:9200/logstash-)_/\_field\_stats?fields=_&allow\_no\_indices=false =\> socket hang up"}  
{"type":"log","@timestamp":"2017-05-31T18:39:19Z","tags":["error","elasticsearch","admin"],"pid":1831,"message":"Request error, retrying\nGET [http://kibana06-vlp.du.edu:9200/\_nodes?filter\_path=nodes](http://kibana06-vlp.du.edu:9200/_nodes?filter_path=nodes)._.version%2Cnodes._.http.publish\_address%2Cnodes._.ip =\> socket hang up"}  
{"type":"log","@timestamp":"2017-05-31T18:39:47Z","tags":["error","elasticsearch","data"],"pid":1831,"message":"Request error, retrying\nPOST [http://kibana06-vlp.du.edu:9200/logstash-](http://kibana06-vlp.du.edu:9200/logstash-)_/\_field\_stats?fields=_&allow\_no\_indices=false =\> socket hang up"}  
{"type":"log","@timestamp":"2017-05-31T18:39:49Z","tags":["error","elasticsearch","admin"],"pid":1831,"message":"Request error, retrying\nGET [http://kibana06-vlp.du.edu:9200/\_nodes?filter\_path=nodes](http://kibana06-vlp.du.edu:9200/_nodes?filter_path=nodes)._.version%2Cnodes._.http.publish\_address%2Cnodes._.ip =\> socket hang up"}  
{"type":"log","@timestamp":"2017-05-31T18:40:17Z","tags":["error","elasticsearch","data"],"pid":1831,"message":"Request error, retrying\nPOST [http://kibana06-vlp.du.edu:9200/logstash-](http://kibana06-vlp.du.edu:9200/logstash-)_/\_field\_stats?fields=_&allow\_no\_indices=false =\> socket hang up"}  
{"type":"log","@timestamp":"2017-05-31T18:40:19Z","tags":["error","elasticsearch","admin"],"pid":1831,"message":"Request error, retrying\nGET [http://kibana06-vlp.du.edu:9200/\_nodes?filter\_path=nodes](http://kibana06-vlp.du.edu:9200/_nodes?filter_path=nodes)._.version%2Cnodes._.http.publish\_address%2Cnodes._.ip =\> socket hang up"}  
{"type":"log","@timestamp":"2017-05-31T18:40:47Z","tags":["error","elasticsearch","data"],"pid":1831,"message":"Request complete with error\nPOST [http://kibana06-vlp.du.edu:9200/logstash-](http://kibana06-vlp.du.edu:9200/logstash-)_/\_field\_stats?fields=_&allow\_no\_indices=false =\> socket hang up"}  
{"type":"response","@timestamp":"2017-05-31T18:38:47Z","tags":[],"pid":1831,"method":"get","statusCode":503,"req":{"url":"/api/kibana/logstash-_/field\_capabilities","method":"get","headers":{"host":"localhost:5601","user-agent":"Mozilla/5.0 (X11; Linux x86\_64; rv:52.0) Gecko/20100101 Firefox/52.0","accept":"application/json, text/plain, _/_","accept-language":"en-US,en;q=0.5","accept-encoding":"gzip, deflate","kbn-version":"5.4.0","referer":"[http://localhost:5601/app/kibana","connection":"keep-alive"},"remoteAddress":"127.0.0.1","userAgent":"127.0.0.1","referer":"http://localhost:5601/app/kibana"},"res":{"statusCode":503,"responseTime":120058,"contentLength":9},"message":"GET](http://localhost:5601/app/kibana%22,%22connection%22:%22keep-alive%22%7D,%22remoteAddress%22:%22127.0.0.1%22,%22userAgent%22:%22127.0.0.1%22,%22referer%22:%22http://localhost:5601/app/kibana%22%7D,%22res%22:%7B%22statusCode%22:503,%22responseTime%22:120058,%22contentLength%22:9%7D,%22message%22:%22GET) /api/kibana/logstash-_/field\_capabilities 503 120058ms - 9.0B"}  
{"type":"log","@timestamp":"2017-05-31T18:40:49Z","tags":["error","elasticsearch","admin"],"pid":1831,"message":"Request complete with error\nGET [http://kibana06-vlp.du.edu:9200/\_nodes?filter\_path=nodes](http://kibana06-vlp.du.edu:9200/_nodes?filter_path=nodes)._.version%2Cnodes._.http.publish\_address%2Cnodes._.ip =\> socket hang up"}  
{"type":"log","@timestamp":"2017-05-31T18:40:49Z","tags":["status","plugin:elasticsearch@5.4.0","error"],"pid":1831,"state":"red","message":"Status changed from green to red - Error: socket hang up","prevState":"green","prevMsg":"Kibana index ready"}  
{"type":"log","@timestamp":"2017-05-31T18:40:49Z","tags":["status","ui settings","error"],"pid":1831,"state":"red","message":"Status changed from green to red - Elasticsearch plugin is red","prevState":"green","prevMsg":"Ready"}  
{"type":"log","@timestamp":"2017-05-31T18:41:21Z","tags":["error","elasticsearch","admin"],"pid":1831,"message":"Request error, retrying\nGET [http://kibana06-vlp.du.edu:9200/\_nodes?filter\_path=nodes](http://kibana06-vlp.du.edu:9200/_nodes?filter_path=nodes)._.version%2Cnodes._.http.publish\_address%2Cnodes._.ip =\> socket hang up"}  
{"type":"log","@timestamp":"2017-05-31T18:41:51Z","tags":["error","elasticsearch","admin"],"pid":1831,"message":"Request error, retrying\nGET [http://kibana06-vlp.du.edu:9200/\_nodes?filter\_path=nodes](http://kibana06-vlp.du.edu:9200/_nodes?filter_path=nodes)._.version%2Cnodes._.http.publish\_address%2Cnodes._.ip =\> socket hang up"}  
{"type":"log","@timestamp":"2017-05-31T18:42:21Z","tags":["error","elasticsearch","admin"],"pid":1831,"message":"Request error, retrying\nGET [http://kibana06-vlp.du.edu:9200/\_nodes?filter\_path=nodes](http://kibana06-vlp.du.edu:9200/_nodes?filter_path=nodes)._.version%2Cnodes._.http.publish\_address%2Cnodes.\*.ip =\> socket hang up"}  
{"type":"log","@timestamp":"2017-05-31T18:42:42Z","tags":["status","plugin:elasticsearch@5.4.0","info"],"pid":1831,"state":"green","message":"Status changed from red to green - Kibana index ready","prevState":"red","prevMsg":{"code":"ECONNRESET"}}  
{"type":"log","@timestamp":"2017-05-31T18:42:42Z","tags":["status","ui settings","info"],"pid":1831,"state":"green","message":"Status changed from red to green - Ready","prevState":"red","prevMsg":"Elasticsearch plugin is red"}

---

<div class="post-metadata">

**Author:** ![hailaeos.troy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hailaeos.troy/32/12817_2.png) [@hailaeos.troy](https://discuss.elastic.co/u/hailaeos.troy)\
**Post date:** [May 31, 2017, 7:13pm UTC](https://discuss.elastic.co/t/socket-hang-up/87763/4 "2017-05-31T19:13:54Z")

</div>

Another clue to my issue is if I run :  
curl '[http://localhost:5601/api/kibana/logstash-2017.05.31/field\_capabilities](http://localhost:5601/api/kibana/logstash-2017.05.31/field_capabilities)'  
it fails with "Empty reply from server"  
but if I run  
curl '[http://localhost:5601/api/kibana/logstash-2017.05.29/field\_capabilities](http://localhost:5601/api/kibana/logstash-2017.05.29/field_capabilities)'  
This works so I am thinking I have an issue with my logstash indices from 30 and today.

---

<div class="post-metadata">

**Author:** ![hailaeos.troy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hailaeos.troy/32/12817_2.png) [@hailaeos.troy](https://discuss.elastic.co/u/hailaeos.troy)\
**Post date:** [June 2, 2017, 2:14pm UTC](https://discuss.elastic.co/t/socket-hang-up/87763/5 "2017-06-02T14:14:59Z")

</div>

Ok I found the fix for this and its a bit odd but who cares.  
I Put the following lines into my elasticsearch.yml file:  
\> **http.cors.enabled: true**  
\> **http.cors.allow-origin: "\*"**  
\> **http.max\_header\_size: 16kb**

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 30, 2017, 2:15pm UTC](https://discuss.elastic.co/t/socket-hang-up/87763/6 "2017-06-30T14:15:23Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
