# SocketError: send: name or service not known - logstash 2.3.4 version

**URL:** <https://discuss.elastic.co/t/socketerror-send-name-or-service-not-known-logstash-2-3-4-version/72767>\
**Category:** Logstash\
**Created:** [January 25, 2017, 12:01pm UTC](https://discuss.elastic.co/t/socketerror-send-name-or-service-not-known-logstash-2-3-4-version/72767 "2017-01-25T12:01:09Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![ravitandur](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ravitandur/32/4568_2.png) [@ravitandur](https://discuss.elastic.co/u/ravitandur)\
**Post date:** [January 25, 2017, 12:01pm UTC](https://discuss.elastic.co/t/socketerror-send-name-or-service-not-known-logstash-2-3-4-version/72767/1 "2017-01-25T12:01:09Z")

</div>

## Logstash agent configuration:

## input { heartbeat { type =\> "heartbeat" interval =\> 60 add\_field =\> { "[app.name](http://app.name)" =\> "esper" } } file { path =\> "/home/pg/pg-services/esper/log/json/esper.json" codec =\> json sincedb\_path =\> "/home/release/release\_independent/elk/logstash/data/sincedb/.sincedb" } } output { udp { host =\> "10.166.184.133" port =\> 7400 codec =\> json } }

This configuration was working fine for some time and suddenly we are getting the below exception and logstash agenent if getting killed.  
Any idea what is going wrong.

SocketError: send: name or service not known  
send at org/jruby/ext/socket/RubyUDPSocket.java:318  
register at /home/release/release\_independent/elk/logstash/logstash-2.3.4/vendor/bundle/jruby/1.9/gems/logstash-output-udp-2.0.4/lib/logstash/outputs/udp.rb:24  
call at org/jruby/RubyProc.java:281  
encode at /home/release/release\_independent/elk/logstash/logstash-2.3.4/vendor/bundle/jruby/1.9/gems/logstash-codec-json-2.1.4/lib/logstash/codecs/json.rb:42  
receive at /home/release/release\_independent/elk/logstash/logstash-2.3.4/vendor/bundle/jruby/1.9/gems/logstash-output-udp-2.0.4/lib/logstash/outputs/udp.rb:31  
multi\_receive at /home/release/release\_independent/elk/logstash/logstash-2.3.4/vendor/bundle/jruby/1.9/gems/logstash-core-2.3.4-java/lib/logstash/outputs/base.rb:83  
each at org/jruby/RubyArray.java:1613  
multi\_receive at /home/release/release\_independent/elk/logstash/logstash-2.3.4/vendor/bundle/jruby/1.9/gems/logstash-core-2.3.4-java/lib/logstash/outputs/base.rb:83  
worker\_multi\_receive at /home/release/release\_independent/elk/logstash/logstash-2.3.4/vendor/bundle/jruby/1.9/gems/logstash-core-2.3.4-java/lib/logstash/output\_delegator.rb:130  
multi\_receive at /home/release/release\_independent/elk/logstash/logstash-2.3.4/vendor/bundle/jruby/1.9/gems/logstash-core-2.3.4-java/lib/logstash/output\_delegator.rb:114  
output\_batch at /home/release/release\_independent/elk/logstash/logstash-2.3.4/vendor/bundle/jruby/1.9/gems/logstash-core-2.3.4-java/lib/logstash/pipeline.rb:301  
each at org/jruby/RubyHash.java:1342  
output\_batch at /home/release/release\_independent/elk/logstash/logstash-2.3.4/vendor/bundle/jruby/1.9/gems/logstash-core-2.3.4-java/lib/logstash/pipeline.rb:301  
worker\_loop at /home/release/release\_independent/elk/logstash/logstash-2.3.4/vendor/bundle/jruby/1.9/gems/logstash-core-2.3.4-java/lib/logstash/pipeline.rb:232  
start\_workers at /home/release/release\_independent/elk/logstash/logstash-2.3.4/vendor/bundle/jruby/1.9/gems/logstash-core-2.3.4-java/lib/logstash/pipeline.rb:201

---

<div class="post-metadata">

**Author:** ![ravitandur](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ravitandur/32/4568_2.png) [@ravitandur](https://discuss.elastic.co/u/ravitandur)\
**Post date:** [January 25, 2017, 2:41pm UTC](https://discuss.elastic.co/t/socketerror-send-name-or-service-not-known-logstash-2-3-4-version/72767/2 "2017-01-25T14:41:01Z")

</div>

we identified the root cause for the problem.  
As json file getting generated by application and with the recent changes in application is logging very huge data in single line. When agent tries to send this line to UDP server, it failing throwing the exception. Because of this exception logstash agent is getting killed.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 22, 2017, 2:41pm UTC](https://discuss.elastic.co/t/socketerror-send-name-or-service-not-known-logstash-2-3-4-version/72767/3 "2017-02-22T14:41:33Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
