# Solaris 10 for Elasticsearch

**URL:** <https://discuss.elastic.co/t/solaris-10-for-elasticsearch/24716>\
**Category:** Elasticsearch\
**Created:** [July 1, 2015, 11:31am UTC](https://discuss.elastic.co/t/solaris-10-for-elasticsearch/24716 "2015-07-01T11:31:16Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Nilesh\_Date](https://avatars.discourse-cdn.com/v4/letter/n/a9a28c/32.png) [@Nilesh\_Date](https://discuss.elastic.co/u/Nilesh_Date)\
**Post date:** [July 1, 2015, 11:31am UTC](https://discuss.elastic.co/t/solaris-10-for-elasticsearch/24716/1 "2015-07-01T11:31:16Z")

</div>

Hi,

Can I use solaris 10 as an base operation system to install elasticsearch ?  
It will be a production setup which will have 3 nodes in elasticseach cluster.

---

<div class="post-metadata">

**Author:** ![Igor\_Motov](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/igor_motov/32/45193_2.png) [@Igor\_Motov](https://discuss.elastic.co/u/Igor_Motov)\
**Post date:** [July 1, 2015, 12:53pm UTC](https://discuss.elastic.co/t/solaris-10-for-elasticsearch/24716/2 "2015-07-01T12:53:17Z")

</div>

While some users are running elasticsearch on Solaris 10, this is not one of the [officially supported platforms](https://www.elastic.co/subscriptions/matrix).

---

<div class="post-metadata">

**Author:** ![jtgajda](https://avatars.discourse-cdn.com/v4/letter/j/f4b2a3/32.png) [@jtgajda](https://discuss.elastic.co/u/jtgajda)\
**Post date:** [February 27, 2017, 6:40pm UTC](https://discuss.elastic.co/t/solaris-10-for-elasticsearch/24716/3 "2017-02-27T18:40:33Z")

</div>

I'm trying to run Elasticsearch on Solaris 10 and have been able to install it and create indexes.  
However when I try to load a mapping, via either curl or the Perl interface it fails with:  
{  
"error" : {  
"root\_cause" : [  
{  
"type" : "mapper\_parsing\_exception",  
"reason" : "failed to parse, document is empty"  
}  
],  
"type" : "mapper\_parsing\_exception",  
"reason" : "failed to parse, document is empty"  
},  
"status" : 400

Have any other Solaris users experienced this issue?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 10:02pm UTC](https://discuss.elastic.co/t/solaris-10-for-elasticsearch/24716/4 "2017-07-05T22:02:49Z")

</div>


