# \[SOLVED\]After upgrade to 7.7.0 in a cluster of 3 nodes. - failed to retrieve password hash for reserved user \[elastic\]

**URL:** https://discuss.elastic.co/t/solved-after-upgrade-to-7-7-0-in-a-cluster-of-3-nodes-failed-to-retrieve-password-hash-for-reserved-user-elastic/234700
**Category:** Elasticsearch
**Tags:** elastic-stack-security
**Created:** [May 28, 2020, 9:13am UTC](https://discuss.elastic.co/t/solved-after-upgrade-to-7-7-0-in-a-cluster-of-3-nodes-failed-to-retrieve-password-hash-for-reserved-user-elastic/234700 "2020-05-28T09:13:56Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Andreas\_Falk](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andreas_falk/32/82595_2.png) [@Andreas\_Falk](https://discuss.elastic.co/u/Andreas_Falk)
#### Post date: [May 28, 2020, 9:13am UTC](https://discuss.elastic.co/t/solved-after-upgrade-to-7-7-0-in-a-cluster-of-3-nodes-failed-to-retrieve-password-hash-for-reserved-user-elastic/234700/1 "2020-05-28T09:13:56Z")

</div>

Hi,

We have a small cluster that we upgraded from 7.6.2 to 7.7.0 with .deb's.  
Everything went fine with the upgrade.  
Plugins were updated and all was rainbows and ponies 🙂

Then when I tried to update the plugins in kibana things were looking interesting.

I can not connect to the elasticsearch API with the set credentials.  
[2020-05-28T10:22:16,825][INFO][o.e.x.s.a.AuthenticationService] [log01] Authentication of [elastic] was terminated by realm [reserved] - failed to authenticate user [elastic]  
[2020-05-28T10:22:16,871][ERROR][o.e.x.s.a.e.ReservedRealm] [log01] failed to retrieve password hash for reserved user [elastic]  
org.elasticsearch.action.UnavailableShardsException: at least one primary shard for the index [.security-7] is unavailable

Any Ideas?

--  
Regards Falk

---

<div class="post-metadata">

### Author: ![Andreas\_Falk](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andreas_falk/32/82595_2.png) [@Andreas\_Falk](https://discuss.elastic.co/u/Andreas_Falk)
#### Post date: [May 28, 2020, 9:47am UTC](https://discuss.elastic.co/t/solved-after-upgrade-to-7-7-0-in-a-cluster-of-3-nodes-failed-to-retrieve-password-hash-for-reserved-user-elastic/234700/2 "2020-05-28T09:47:22Z")

</div>

Humm,  
This is now solved.  
And I wish I could say what we did...  
My working assumption is that the cluster was in a failed mode so the master node could not read .security index..  
After a restart of the whole cluster things are getting back to some kind of likenesses of working 🙂

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [June 25, 2020, 9:47am UTC](https://discuss.elastic.co/t/solved-after-upgrade-to-7-7-0-in-a-cluster-of-3-nodes-failed-to-retrieve-password-hash-for-reserved-user-elastic/234700/3 "2020-06-25T09:47:31Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
