# \[Solved\] Cannot visualise field with analyzed strings in kibana 4.3

**URL:** <https://discuss.elastic.co/t/solved-cannot-visualise-field-with-analyzed-strings-in-kibana-4-3/36553>\
**Category:** Kibana\
**Created:** [December 7, 2015, 3:52pm UTC](https://discuss.elastic.co/t/solved-cannot-visualise-field-with-analyzed-strings-in-kibana-4-3/36553 "2015-12-07T15:52:25Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![mirnuj\_atom](https://avatars.discourse-cdn.com/v4/letter/m/7c8e57/32.png) [@mirnuj\_atom](https://discuss.elastic.co/u/mirnuj_atom)\
**Post date:** [December 7, 2015, 3:52pm UTC](https://discuss.elastic.co/t/solved-cannot-visualise-field-with-analyzed-strings-in-kibana-4-3/36553/1 "2015-12-07T15:52:25Z")

</div>

Hi Guys

I am having a problem with vizualization of any "analyzed" field in Kibana 4.3.0 on one of my servers. Whenever I try to build any vizualization (say piechart, or anything else) based on any non-raw field I get the next error message:

Visualize: java.lang.IllegalStateException: Field data loading is forbidden on FIELDNAME

[quote]Error: Request to Elasticsearch failed: {"error":{"root\_cause":[{"type":"exception","reason":"java.lang.IllegalStateException: Field data loading is forbidden on file"}],"type":"search\_phase\_execution\_exception","reason":"all shards failed","phase":"query","grouped":true,"failed\_shards":[{"shard":0,"index":"logstash-2015.12.07","node":"C8TZLPH\_Q7GYQzCLi8\_HuA","reason":{"type":"exception","reason":"java.lang.IllegalStateException: Field data loading is forbidden on file","caused\_by":{"type":"unchecked\_execution\_exception","reason":"java.lang.IllegalStateException: Field data loading is forbidden on file","caused\_by":{"type":"illegal\_state\_exception","reason":"Field data loading is forbidden on file"}}}}]}}  
KbnError@[http://dev-cres-db-s2-2.vega.ironport.com/bundles/commons.bundle.js:58153:21](http://dev-cres-db-s2-2.vega.ironport.com/bundles/commons.bundle.js:58153:21)  
RequestFailure@[http://dev-cres-db-s2-2.vega.ironport.com/bundles/commons.bundle.js:58186:1](http://dev-cres-db-s2-2.vega.ironport.com/bundles/commons.bundle.js:58186:1)  
callResponseHandlers/\<@[http://dev-cres-db-s2-2.vega.ironport.com/bundles/kibana.bundle.js:78760:39](http://dev-cres-db-s2-2.vega.ironport.com/bundles/kibana.bundle.js:78760:39)  
**WEBPACK\_AMD\_DEFINE\_RESULT** \</\</Promise.try@[http://dev-cres-db-s2-2.vega.ironport.com/bundles/commons.bundle.js:60967:20](http://dev-cres-db-s2-2.vega.ironport.com/bundles/commons.bundle.js:60967:20)  
**WEBPACK\_AMD\_DEFINE\_RESULT** \</\</Promise.map/\<@[http://dev-cres-db-s2-2.vega.ironport.com/bundles/commons.bundle.js:60936:17](http://dev-cres-db-s2-2.vega.ironport.com/bundles/commons.bundle.js:60936:17)  
**WEBPACK\_AMD\_DEFINE\_RESULT** \</\</Promise.map@[http://dev-cres-db-s2-2.vega.ironport.com/bundles/commons.bundle.js:60935:27](http://dev-cres-db-s2-2.vega.ironport.com/bundles/commons.bundle.js:60935:27)  
callResponseHandlers@[http://dev-cres-db-s2-2.vega.ironport.com/bundles/kibana.bundle.js:78732:1](http://dev-cres-db-s2-2.vega.ironport.com/bundles/kibana.bundle.js:78732:1)  
fetchWithStrategy/\<@[http://dev-cres-db-s2-2.vega.ironport.com/bundles/kibana.bundle.js:78239:17](http://dev-cres-db-s2-2.vega.ironport.com/bundles/kibana.bundle.js:78239:17)  
processQueue@[http://dev-cres-db-s2-2.vega.ironport.com/bundles/commons.bundle.js:42339:29](http://dev-cres-db-s2-2.vega.ironport.com/bundles/commons.bundle.js:42339:29)  
scheduleProcessQueue/\<@[http://dev-cres-db-s2-2.vega.ironport.com/bundles/commons.bundle.js:42355:28](http://dev-cres-db-s2-2.vega.ironport.com/bundles/commons.bundle.js:42355:28)  
$RootScopeProvider/this.$get\</Scope.prototype.$eval@[http://dev-cres-db-s2-2.vega.ironport.com/bundles/commons.bundle.js:43583:17](http://dev-cres-db-s2-2.vega.ironport.com/bundles/commons.bundle.js:43583:17)  
$RootScopeProvider/this.$get\</Scope.prototype.$digest@[http://dev-cres-db-s2-2.vega.ironport.com/bundles/commons.bundle.js:43394:16](http://dev-cres-db-s2-2.vega.ironport.com/bundles/commons.bundle.js:43394:16)  
$RootScopeProvider/this.$get\</Scope.prototype.$apply@[http://dev-cres-db-s2-2.vega.ironport.com/bundles/commons.bundle.js:43691:14](http://dev-cres-db-s2-2.vega.ironport.com/bundles/commons.bundle.js:43691:14)  
done@[http://dev-cres-db-s2-2.vega.ironport.com/bundles/commons.bundle.js:38140:37](http://dev-cres-db-s2-2.vega.ironport.com/bundles/commons.bundle.js:38140:37)  
completeRequest@[http://dev-cres-db-s2-2.vega.ironport.com/bundles/commons.bundle.js:38338:8](http://dev-cres-db-s2-2.vega.ironport.com/bundles/commons.bundle.js:38338:8)  
requestLoaded@[http://dev-cres-db-s2-2.vega.ironport.com/bundles/commons.bundle.js:38279:1](http://dev-cres-db-s2-2.vega.ironport.com/bundles/commons.bundle.js:38279:1)  
[/quote]

I have another server running the same versions of kibana/elasticsearch/logstash which works just fine, the sad thing that the one which works fine is my testing one and the problem one should have become prod 🙂  
I use kibana 4.3 and elasticsearch 2.1.0  
The only difference (except servers' hardware) is that the working one uses JDK8u40 when non-working is on u65.

Thank you for any info.  
Andrii.

---

<div class="post-metadata">

**Author:** ![mirnuj\_atom](https://avatars.discourse-cdn.com/v4/letter/m/7c8e57/32.png) [@mirnuj\_atom](https://discuss.elastic.co/u/mirnuj_atom)\
**Post date:** [December 8, 2015, 7:19am UTC](https://discuss.elastic.co/t/solved-cannot-visualise-field-with-analyzed-strings-in-kibana-4-3/36553/2 "2015-12-08T07:19:54Z")

</div>

So I tried to use the same build of java on both servers - it didn't solve the problem.  
I have also tried to copy kibana folder from the working one to none working with no luck as well.  
I also reinstalled elasticsearch and removed and re-created it's lib directory with same no results.

---

<div class="post-metadata">

**Author:** ![mirnuj\_atom](https://avatars.discourse-cdn.com/v4/letter/m/7c8e57/32.png) [@mirnuj\_atom](https://discuss.elastic.co/u/mirnuj_atom)\
**Post date:** [December 8, 2015, 11:29am UTC](https://discuss.elastic.co/t/solved-cannot-visualise-field-with-analyzed-strings-in-kibana-4-3/36553/3 "2015-12-08T11:29:03Z")

</div>

So I was able to fix the issue by simply moving /var/lib/elasticsearch from the working one to the non-working. Lost all data but at least I have a working index now.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 2:07pm UTC](https://discuss.elastic.co/t/solved-cannot-visualise-field-with-analyzed-strings-in-kibana-4-3/36553/4 "2017-07-06T14:07:10Z")

</div>


