# \[SOLVED\]Caused by: java.security.AccessControlException: access denied

**URL:** <https://discuss.elastic.co/t/solved-caused-by-java-security-accesscontrolexception-access-denied/154566>\
**Category:** Elasticsearch\
**Created:** [October 30, 2018, 6:24am UTC](https://discuss.elastic.co/t/solved-caused-by-java-security-accesscontrolexception-access-denied/154566 "2018-10-30T06:24:43Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![ironbeast](https://avatars.discourse-cdn.com/v4/letter/i/b5a626/32.png) [@ironbeast](https://discuss.elastic.co/u/ironbeast)\
**Post date:** [October 30, 2018, 6:24am UTC](https://discuss.elastic.co/t/solved-caused-by-java-security-accesscontrolexception-access-denied/154566/1 "2018-10-30T06:24:43Z")

</div>

Hi There,  
I' ve got this strange issue with my certs.... I know the certs should go in the conf dir (which is the case:  
[root@esmaster01dev esmaster01dev]# echo $ES\_CONF\_DIR  
/etc/elasticsearch/esmaster01dev

Contents of the directory:  
[root@esmaster01dev esmaster01dev]# ll  
total 32  
-rw-r--r--. 1 elasticsearch elasticsearch 3440 30. Okt 06:32 elastic-certificates.p12  
-rw-rw----. 1 elasticsearch elasticsearch 249 29. Okt 15:20 elasticsearch.keystore  
-rw-r--r--. 1 elasticsearch elasticsearch 2884 30. Okt 07:09 elasticsearch.yml  
-rw-r--r--. 1 elasticsearch elasticsearch 2524 30. Okt 06:32 elastic-stack-ca.p12

But still...

```
[2018-10-30T07:09:39,087][INFO][o.e.n.Node] [esmaster01dev.brusselsairport.aero-esmaster01dev] JVM arguments [-Xms6g, -Xmx6g, -XX:+UseConcMarkSweepGC, -XX:CMSInitiatingOccupancyFraction=75, -XX:+UseCMSInitiatingOccupancyOnly, -XX:+AlwaysPreTouch, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -Djdk.io.permissionsUseCanonicalPath=true, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=true, -Dlog4j.skipJansi=true, -XX:+HeapDumpOnOutOfMemoryError, -Des.path.home=/usr/share/elasticsearch, -Des.path.conf=/etc/elasticsearch/esmaster01dev, -Des.distribution.flavor=default, -Des.distribution.type=rpm]
[2018-10-30T07:09:39,614][ERROR][o.e.b.Bootstrap] Exception
java.lang.IllegalStateException: failed to load plugin class [org.elasticsearch.xpack.core.XPackPlugin]
	at org.elasticsearch.plugins.PluginsService.loadPlugin(PluginsService.java:607) ~[elasticsearch-6.4.0.jar:6.4.0]
	at org.elasticsearch.plugins.PluginsService.loadBundle(PluginsService.java:549) ~[elasticsearch-6.4.0.jar:6.4.0]
	at org.elasticsearch.plugins.PluginsService.loadBundles(PluginsService.java:464) ~[elasticsearch-6.4.0.jar:6.4.0]
	at org.elasticsearch.plugins.PluginsService.<init>(PluginsService.java:156) ~[elasticsearch-6.4.0.jar:6.4.0]
	at org.elasticsearch.node.Node.<init>(Node.java:315) ~[elasticsearch-6.4.0.jar:6.4.0]
	at org.elasticsearch.node.Node.<init>(Node.java:256) ~[elasticsearch-6.4.0.jar:6.4.0]
	at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:213) ~[elasticsearch-6.4.0.jar:6.4.0]
	at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:213) ~[elasticsearch-6.4.0.jar:6.4.0]
	at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:326) [elasticsearch-6.4.0.jar:6.4.0]
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:136) [elasticsearch-6.4.0.jar:6.4.0]
	at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:127) [elasticsearch-6.4.0.jar:6.4.0]
	at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) [elasticsearch-6.4.0.jar:6.4.0]
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) [elasticsearch-cli-6.4.0.jar:6.4.0]
	at org.elasticsearch.cli.Command.main(Command.java:90) [elasticsearch-cli-6.4.0.jar:6.4.0]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:93) [elasticsearch-6.4.0.jar:6.4.0]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:86) [elasticsearch-6.4.0.jar:6.4.0]
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:?]
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) ~[?:?]
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) ~[?:?]
	at java.lang.reflect.Constructor.newInstance(Constructor.java:423) ~[?:1.8.0_181]
	at org.elasticsearch.plugins.PluginsService.loadPlugin(PluginsService.java:598) ~[elasticsearch-6.4.0.jar:6.4.0]
	... 15 more
Caused by: org.elasticsearch.ElasticsearchException: failed to initialize a TrustManagerFactory
	at org.elasticsearch.xpack.core.ssl.StoreTrustConfig.createTrustManager(StoreTrustConfig.java:61) ~[?:?]
	at org.elasticsearch.xpack.core.ssl.SSLService.createSslContext(SSLService.java:355) ~[?:?]
	at java.util.HashMap.computeIfAbsent(HashMap.java:1127) ~[?:1.8.0_181]
	at org.elasticsearch.xpack.core.ssl.SSLService.lambda$loadSSLConfigurations$1(SSLService.java:403) ~[?:?]
	at java.util.HashMap.forEach(HashMap.java:1289) ~[?:1.8.0_181]
	at org.elasticsearch.xpack.core.ssl.SSLService.loadSSLConfigurations(SSLService.java:397) ~[?:?]
	at org.elasticsearch.xpack.core.ssl.SSLService.<init>(SSLService.java:92) ~[?:?]
	at org.elasticsearch.xpack.core.XPackPlugin.<init>(XPackPlugin.java:130) ~[?:?]
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:?]
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) ~[?:?]
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) ~[?:?]
	at java.lang.reflect.Constructor.newInstance(Constructor.java:423) ~[?:1.8.0_181]
	at org.elasticsearch.plugins.PluginsService.loadPlugin(PluginsService.java:598) ~[elasticsearch-6.4.0.jar:6.4.0]
	... 15 more
Caused by: java.security.AccessControlException: access denied ("java.io.FilePermission" "/etc/elasticssearch/esmaster01dev/elastic-certificates.p12" "read")
```

---

<div class="post-metadata">

**Author:** ![ironbeast](https://avatars.discourse-cdn.com/v4/letter/i/b5a626/32.png) [@ironbeast](https://discuss.elastic.co/u/ironbeast)\
**Post date:** [October 30, 2018, 8:49am UTC](https://discuss.elastic.co/t/solved-caused-by-java-security-accesscontrolexception-access-denied/154566/2 "2018-10-30T08:49:07Z")

</div>

There was a stupid typo in my elasticsearch.yml file in the path for the certs... Fixed the typo.. Problems solved

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 27, 2018, 8:49am UTC](https://discuss.elastic.co/t/solved-caused-by-java-security-accesscontrolexception-access-denied/154566/3 "2018-11-27T08:49:13Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
