# SOLVED! Error "Request to Elasticsearch failed: "Bad Request"" after upgrading ES to 5.5.1

**URL:** <https://discuss.elastic.co/t/solved-error-request-to-elasticsearch-failed-bad-request-after-upgrading-es-to-5-5-1/96556>\
**Category:** Elasticsearch\
**Created:** [August 10, 2017, 6:41am UTC](https://discuss.elastic.co/t/solved-error-request-to-elasticsearch-failed-bad-request-after-upgrading-es-to-5-5-1/96556 "2017-08-10T06:41:52Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![JR\_FFM](https://avatars.discourse-cdn.com/v4/letter/j/d26b3c/32.png) [@JR\_FFM](https://discuss.elastic.co/u/JR_FFM)\
**Post date:** [August 10, 2017, 6:41am UTC](https://discuss.elastic.co/t/solved-error-request-to-elasticsearch-failed-bad-request-after-upgrading-es-to-5-5-1/96556/1 "2017-08-10T06:41:53Z")

</div>

Hello,

I'm new in this forum and not very familiar with Elasticsearch and Kibana.  
After upgrading our Elasticsearch-system to 5.5.1 I get the following error-message in Kibana when I try to access the "winlogbeat-\*"-data:

Request to Elasticsearch failed: "Bad Request"

Error: Request to Elasticsearch failed: "Bad Request"  
KbnError@[https://kibana-test.example.com/bundles/commons.bundle.js?v=15405:83:18295](https://kibana-test.example.com/bundles/commons.bundle.js?v=15405:83:18295)  
RequestFailure@[https://kibana-test.example.com/bundles/commons.bundle.js?v=15405:83:19044](https://kibana-test.example.com/bundles/commons.bundle.js?v=15405:83:19044)  
DocSendToEsProvider/\</\<@[https://kibana-test.example.com/bundles/kibana.bundle.js?v=15405:27:23337](https://kibana-test.example.com/bundles/kibana.bundle.js?v=15405:27:23337)  
processQueue@[https://kibana-test.example.com/bundles/commons.bundle.js?v=15405:38:23621](https://kibana-test.example.com/bundles/commons.bundle.js?v=15405:38:23621)  
scheduleProcessQueue/\<@[https://kibana-test.example.com/bundles/commons.bundle.js?v=15405:38:23888](https://kibana-test.example.com/bundles/commons.bundle.js?v=15405:38:23888)  
$RootScopeProvider/this.$get\</Scope.prototype.$eval@[https://kibana-test.example.com/bundles/commons.bundle.js?v=15405:39:4607](https://kibana-test.example.com/bundles/commons.bundle.js?v=15405:39:4607)  
$RootScopeProvider/this.$get\</Scope.prototype.$digest@[https://kibana-test.example.com/bundles/commons.bundle.js?v=15405:39:2343](https://kibana-test.example.com/bundles/commons.bundle.js?v=15405:39:2343)  
$RootScopeProvider/this.$get\</Scope.prototype.$apply@[https://kibana-test.example.com/bundles/commons.bundle.js?v=15405:39:5026](https://kibana-test.example.com/bundles/commons.bundle.js?v=15405:39:5026)  
done@[https://kibana-test.example.com/bundles/commons.bundle.js?v=15405:37:25016](https://kibana-test.example.com/bundles/commons.bundle.js?v=15405:37:25016)  
completeRequest@[https://kibana-test.example.com/bundles/commons.bundle.js?v=15405:37:28702](https://kibana-test.example.com/bundles/commons.bundle.js?v=15405:37:28702)  
createHttpBackend/\</xhr.onload@[https://kibana-test.example.com/bundles/commons.bundle.js?v=15405:37:29634](https://kibana-test.example.com/bundles/commons.bundle.js?v=15405:37:29634)

But I am able to access the "filebeat-\*"-data without any problems.

Can anyone help me, please?

Thank you!

---

<div class="post-metadata">

**Author:** ![Jean-Claude](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jean-claude/32/7732_2.png) [@Jean-Claude](https://discuss.elastic.co/u/Jean-Claude)\
**Post date:** [August 14, 2017, 8:17am UTC](https://discuss.elastic.co/t/solved-error-request-to-elasticsearch-failed-bad-request-after-upgrading-es-to-5-5-1/96556/2 "2017-08-14T08:17:09Z")

</div>

Hi

Didi you fix this problem ?

I have the same issue.

Thanks

---

<div class="post-metadata">

**Author:** ![ch07077555](https://avatars.discourse-cdn.com/v4/letter/c/ac8455/32.png) [@ch07077555](https://discuss.elastic.co/u/ch07077555)\
**Post date:** [August 15, 2017, 7:45am UTC](https://discuss.elastic.co/t/solved-error-request-to-elasticsearch-failed-bad-request-after-upgrading-es-to-5-5-1/96556/3 "2017-08-15T07:45:47Z")

</div>

Hi,

I may have the same problem. Has any of you managed to resolve it yet?

---

<div class="post-metadata">

**Author:** ![JR\_FFM](https://avatars.discourse-cdn.com/v4/letter/j/d26b3c/32.png) [@JR\_FFM](https://discuss.elastic.co/u/JR_FFM)\
**Post date:** [August 16, 2017, 6:56am UTC](https://discuss.elastic.co/t/solved-error-request-to-elasticsearch-failed-bad-request-after-upgrading-es-to-5-5-1/96556/4 "2017-08-16T06:56:54Z")

</div>

Hi,

the problem still exists.  
I suppose that I have to re-initialize the index of the "winlogbeat"-data due to the fact that my "filebeat"-data does not have this problem.  
But before I will do that I hope that an EL-specialist tell me wether this will solve the problem or do more harm.

---

<div class="post-metadata">

**Author:** ![ch07077555](https://avatars.discourse-cdn.com/v4/letter/c/ac8455/32.png) [@ch07077555](https://discuss.elastic.co/u/ch07077555)\
**Post date:** [August 16, 2017, 10:45am UTC](https://discuss.elastic.co/t/solved-error-request-to-elasticsearch-failed-bad-request-after-upgrading-es-to-5-5-1/96556/5 "2017-08-16T10:45:06Z")

</div>

I solved it by deleting (sigh) my kibana index.

---

<div class="post-metadata">

**Author:** ![JR\_FFM](https://avatars.discourse-cdn.com/v4/letter/j/d26b3c/32.png) [@JR\_FFM](https://discuss.elastic.co/u/JR_FFM)\
**Post date:** [August 17, 2017, 4:30am UTC](https://discuss.elastic.co/t/solved-error-request-to-elasticsearch-failed-bad-request-after-upgrading-es-to-5-5-1/96556/6 "2017-08-17T04:30:08Z")

</div>

@ch07077555 Can you describe how you have done this?

THX!

---

<div class="post-metadata">

**Author:** ![ch07077555](https://avatars.discourse-cdn.com/v4/letter/c/ac8455/32.png) [@ch07077555](https://discuss.elastic.co/u/ch07077555)\
**Post date:** [August 17, 2017, 1:33pm UTC](https://discuss.elastic.co/t/solved-error-request-to-elasticsearch-failed-bad-request-after-upgrading-es-to-5-5-1/96556/7 "2017-08-17T13:33:59Z")

</div>

Sure, I followed the docs from [https://www.elastic.co/guide/en/elasticsearch/reference/current/indices-delete-index.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/indices-delete-index.html) 🙂

---

<div class="post-metadata">

**Author:** ![JR\_FFM](https://avatars.discourse-cdn.com/v4/letter/j/d26b3c/32.png) [@JR\_FFM](https://discuss.elastic.co/u/JR_FFM)\
**Post date:** [August 18, 2017, 4:22am UTC](https://discuss.elastic.co/t/solved-error-request-to-elasticsearch-failed-bad-request-after-upgrading-es-to-5-5-1/96556/8 "2017-08-18T04:22:24Z")

</div>

Ok... this solved the problem... but deleted the complete data of the index also.

---

<div class="post-metadata">

**Author:** ![JR\_FFM](https://avatars.discourse-cdn.com/v4/letter/j/d26b3c/32.png) [@JR\_FFM](https://discuss.elastic.co/u/JR_FFM)\
**Post date:** [August 18, 2017, 9:29am UTC](https://discuss.elastic.co/t/solved-error-request-to-elasticsearch-failed-bad-request-after-upgrading-es-to-5-5-1/96556/9 "2017-08-18T09:29:26Z")

</div>

Because I need the historical "winlogbeat"-data, I've restored my data from backup and try to solve the problem without deleting the index.  
I've refreshed the "winlogbeat"-index also without any success.

Anyone an idea?

---

<div class="post-metadata">

**Author:** ![JR\_FFM](https://avatars.discourse-cdn.com/v4/letter/j/d26b3c/32.png) [@JR\_FFM](https://discuss.elastic.co/u/JR_FFM)\
**Post date:** [August 25, 2017, 7:45am UTC](https://discuss.elastic.co/t/solved-error-request-to-elasticsearch-failed-bad-request-after-upgrading-es-to-5-5-1/96556/10 "2017-08-25T07:45:44Z")

</div>

After upgrading to version 5.5.2 I can access the "winlogbeat"-historical-data.  
SOLVED!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 22, 2017, 7:45am UTC](https://discuss.elastic.co/t/solved-error-request-to-elasticsearch-failed-bad-request-after-upgrading-es-to-5-5-1/96556/11 "2017-09-22T07:45:54Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
