# \[SOLVED\] Index issues after upgrade from 5.x to 6.2

**URL:** <https://discuss.elastic.co/t/solved-index-issues-after-upgrade-from-5-x-to-6-2/119119>\
**Category:** Elasticsearch\
**Created:** [February 8, 2018, 8:29pm UTC](https://discuss.elastic.co/t/solved-index-issues-after-upgrade-from-5-x-to-6-2/119119 "2018-02-08T20:29:23Z")\
**Posts on this page:** 1\
**Showing post:** 2

<div class="post-metadata">

**Author:** ![Enis](https://avatars.discourse-cdn.com/v4/letter/e/ea666f/32.png) [@Enis](https://discuss.elastic.co/u/Enis)\
**Post date:** [February 9, 2018, 11:51am UTC](https://discuss.elastic.co/t/solved-index-issues-after-upgrade-from-5-x-to-6-2/119119/2 "2018-02-09T11:51:49Z")

</div>

Hey,

I had the same problem and the solution for this problem is written in this post:

> [@Failed to parse mapping for index](https://discuss.elastic.co/t/failed-to-parse-mapping-for-index/110102/4):
>
> Get the current one using the [index template API](https://www.elastic.co/guide/en/elasticsearch/reference/6.0/indices-templates.html) and update it. You can the push it back into the cluster using the same API. If you are using the default Logstash template, you can just upload the [standard 6.0 template](https://github.com/logstash-plugins/logstash-output-elasticsearch/blob/master/lib/logstash/outputs/elasticsearch/elasticsearch-template-es6x.json) and overwrite the existing one.

I have deleted my saved logstash template and added the standard logstash template like mentioned.

---

_[View the full topic](https://discuss.elastic.co/t/solved-index-issues-after-upgrade-from-5-x-to-6-2/119119)._
