# \[Solved\] Logstash 5 not starting when using Kafka input version 4

**URL:** <https://discuss.elastic.co/t/solved-logstash-5-not-starting-when-using-kafka-input-version-4/64716>\
**Category:** Logstash\
**Created:** [November 2, 2016, 1:04pm UTC](https://discuss.elastic.co/t/solved-logstash-5-not-starting-when-using-kafka-input-version-4/64716 "2016-11-02T13:04:46Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![IngaFeick](https://avatars.discourse-cdn.com/v4/letter/i/7ab992/32.png) [@IngaFeick](https://discuss.elastic.co/u/IngaFeick)\
**Post date:** [November 2, 2016, 1:04pm UTC](https://discuss.elastic.co/t/solved-logstash-5-not-starting-when-using-kafka-input-version-4/64716/1 "2016-11-02T13:04:46Z")

</div>

Hallos!

I set up a logstash 5.0.0 and downgraded the kafka plugin version as described in the breaking changes document ([https://www.elastic.co/guide/en/logstash/5.0/breaking-changes.html](https://www.elastic.co/guide/en/logstash/5.0/breaking-changes.html)) because our kafka cluster run version 0.9  
bin/logstash-plugin list --verbose | grep kafka  
logstash-input-kafka (4.0.0)  
logstash-output-kafka (4.0.1)  
When I use this plugin, logstash fails to start, giving me the following error message:  
[ERROR][logstash.agent] Pipeline aborted due to error {:exception=\>#\<NameError: uninitialized constant LogStash::Logger\>, :backtrace=\>["org/jruby/RubyModule.java:2719:in `const_missing'", "/appdata/logstash-5.0.0/vendor/bundle/jruby/1.9/gems/logstash-input-kafka-4.0.0/lib/logstash/inputs/kafka.rb:136:in`register'"

My start command looks like this:  
logstash-5.0.0$ bin/logstash -f /path/to/configs/something.conf  
and it boots for any configuration that doesn't make use of the kafka input.

Any ideas? 🙂 Thanks!

---

<div class="post-metadata">

**Author:** ![IngaFeick](https://avatars.discourse-cdn.com/v4/letter/i/7ab992/32.png) [@IngaFeick](https://discuss.elastic.co/u/IngaFeick)\
**Post date:** [November 7, 2016, 10:11am UTC](https://discuss.elastic.co/t/solved-logstash-5-not-starting-when-using-kafka-input-version-4/64716/2 "2016-11-07T10:11:29Z")

</div>

Example of what happens on a freshly downloaded copy of logstash 5.0.0:

```
$ cd logstash -5.0.0
$ bin/logstash-plugin remove logstash-input-kafka; bin/logstash-plugin install --version 4.0.0 logstash-input-kafka
Removing logstash-input-kafka
Validating logstash-input-kafka-4.0.0
Installing logstash-input-kafka
Installation successful
$ bin/logstash -f ~/test_kafka_connection_logstash5.conf
Sending Logstash logs to /some/path/logstash-5.0.0/logs which is now configured via log4j2.properties.
[2016-11-07T11:04:46,075][ERROR][logstash.agent] Pipeline aborted due to error {:exception=>#<NameError: uninitialized constant LogStash::Logger>, :backtrace=>["org/jruby/RubyModule.java:2719:in `const_missing'", "/some/path/logstash-5.0.0/vendor/bundle/jruby/1.9/gems/logstash-input-kafka-4.0.0/lib/logstash/inputs/kafka.rb:136:in `register'", "/some/path/logstash-5.0.0/logstash-core/lib/logstash/pipeline.rb:319:in `start_inputs'", "org/jruby/RubyArray.java:1613:in `each'", "/some/path/logstash-5.0.0/logstash-core/lib/logstash/pipeline.rb:318:in `start_inputs'", "/some/path/logstash-5.0.0/logstash-core/lib/logstash/pipeline.rb:195:in `start_workers'", "/some/path/logstash-5.0.0/logstash-core/lib/logstash/pipeline.rb:153:in `run'", "/some/path/logstash-5.0.0/logstash-core/lib/logstash/agent.rb:250:in `start_pipeline'"]}
[2016-11-07T11:04:46,113][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=>9600}
[2016-11-07T11:04:49,093][WARN][logstash.agent] stopping pipeline {:id=>"main"}

```

with the config looking like this:

```
input
{
    kafka
    {
        bootstrap_servers => "iplist_here"
        codec => plain
        topics => ["topic_here"]
        client_id => "logstash5"
        group_id => "test"      
    }
}
filter
{

}
output
{
  stdout {}
}
```

---

<div class="post-metadata">

**Author:** ![IngaFeick](https://avatars.discourse-cdn.com/v4/letter/i/7ab992/32.png) [@IngaFeick](https://discuss.elastic.co/u/IngaFeick)\
**Post date:** [November 15, 2016, 4:53pm UTC](https://discuss.elastic.co/t/solved-logstash-5-not-starting-when-using-kafka-input-version-4/64716/3 "2016-11-15T16:53:11Z")

</div>

Quick update: my question has become obsolete by the 4.1 version of the plugin which offers a patch for this.

---

<div class="post-metadata">

**Author:** ![crazyphil](https://avatars.discourse-cdn.com/v4/letter/c/9f8e36/32.png) [@crazyphil](https://discuss.elastic.co/u/crazyphil)\
**Post date:** [November 15, 2016, 5:09pm UTC](https://discuss.elastic.co/t/solved-logstash-5-not-starting-when-using-kafka-input-version-4/64716/4 "2016-11-15T17:09:55Z")

</div>

I just tried installing that plugin because I was having the same error (I'm still running kafka .9), and am getting a different error now.

My install:

```
[root@orion-logf-1 logstash]# bin/logstash-plugin remove logstash-input-kafka
Removing logstash-input-kafka
[root@orion-logf-1 logstash]# bin/logstash-plugin install --version 4.1.0 logstash-input-kafka
Validating logstash-input-kafka-4.1.0
Installing logstash-input-kafka
Installation successful
[root@orion-logf-1 logstash]

```

Here's what happens now:

```
[2016-11-15T09:01:25,079][DEBUG][logstash.registry] Problems loading a plugin with {:type=>"input", :name=>#<LogStash::Registry::Plugin:0xaf3b487 @type="input", @name="kafka">, :path=>"logstash/inputs/kafka", :error=>#<LogStash::EnvironmentError: Could not find jar files under /usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-kafka-4.1.0/vendor/jar-dependencies/runtime-jars/*.jar>}
[2016-11-15T09:01:25,080][DEBUG][logstash.plugin] Problems loading the plugin with {:type=>"input", :name=>"kafka", :path=>"logstash/inputs/kafka"}
[2016-11-15T09:01:25,086][ERROR][logstash.agent] :reason=>"Couldn't find any input plugin named 'kafka'. Are you sure this is correct? Trying to load the kafka input plugin resulted in this error: Problems loading the requested plugin named kafka of type input.", :backtrace=>["/usr/share/logstash/logstash-core/lib/logstash/plugin.rb:127:in `lookup'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:413:in `plugin'", "(eval):8:in `initialize'", "org/jruby/RubyKernel.java:1079:in `eval'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:90:in `initialize'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:195:in `create_pipeline'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:87:in `register_pipeline'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:258:in `execute'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67:in `run'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:174:in `run'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:132:in `run'", "/usr/share/logstash/lib/bootstrap/environment.rb:68:in `(root)'"]}

```

Input config:

```
    kafka {
            auto_offset_reset => "smallest"
            consumer_threads => "1"
            group_id => "kafka_nginxtlsaccess"
            type => "nginx-tlsaccess"
            bootstrap_servers => "kafka.service.consul:9092"
            client_id => "orion-logf-1"
            topics => ["nginxtlsaccess"]
    }

```

Suggestions?

---

<div class="post-metadata">

**Author:** ![Naushad\_Ansari](https://avatars.discourse-cdn.com/v4/letter/n/7cd45c/32.png) [@Naushad\_Ansari](https://discuss.elastic.co/u/Naushad_Ansari)\
**Post date:** [January 30, 2017, 8:13am UTC](https://discuss.elastic.co/t/solved-logstash-5-not-starting-when-using-kafka-input-version-4/64716/5 "2017-01-30T08:13:07Z")

</div>

Use version 4.1.1 for logstash-input-kafka

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 4:29am UTC](https://discuss.elastic.co/t/solved-logstash-5-not-starting-when-using-kafka-input-version-4/64716/6 "2017-07-06T04:29:04Z")

</div>


